Import and Link Options for CAD Formats and Revit Models
 
 
 

The following options apply to linked or imported CAD format files (on the Import CAD Formats and Link CAD Formats dialogs that display when you click Insert tabImport panelImport CAD, or Insert tabLink panelLink CAD). Positioning options also apply to linked Revit models (when you click Insert tabLink panelLink Revit).

Option Definition
Current View Only Imports a CAD drawing into the active Revit view only. For example, you might want an AutoCAD object to appear only in a Revit floor plan view and not in a 3D view. If you set this option, any text in the imported file is visible and can be cropped by the crop region of the view. If you are using worksharing, the import will belong to a view workset.

If the option is not selected, only lines and geometry are imported, and the import behaves like model geometry: it can be cropped by the crop region of the view. This option is not available in 3D views. If you are using worksharing, the import will belong to a model workset.

NoteIf you are importing data from a CAD file for use in creating a toposurface, do not select this option.
Colors
Invert Inverts the colors of all line and text objects from the imported file to Revit-specific colors. Dark colors become lighter, and light colors become darker. This can improve readability when the file is in Revit Architecture. This option is set by default.
Preserve Preserves the colors defined in the imported document.
Black and White Imports the document in black and white.
Layers
All Imports or links all layers. Layers that are not visible in the link are turned off in the current view in Revit Architecture.
Visible Imports or links only visible layers.
Specify Allows you to select the layers and levels to import or link (on the dialog that displays). Layers not selected are deleted.

If you select Visible or Specify and you are linking the file, when you later reload the linked file, still only the selected or visible layers originally linked are loaded. Any layers not selected or visible are not linked. If you later want omitted layers to be linked, you must delete the link and relink the file.

TipIf you want to be able to see and hide layers as needed, you can link to all layers, and then click View tabGraphics panelVisibility/Graphics to control the visibility of different categories in a view. (See Visibility and Graphic Display in Project Views.) Or you can link to all layers, and then query the import and hide a selected layer in the active view. (See Querying Objects in Layers.)
Import Units Explicitly sets the unit of measure for imported geometry. The values are Auto-Detect, feet, inch, meter, decimeter, centimeter, millimeter, and Custom factor.

If you specify Auto-Detect for an AutoCAD file created in Imperial (English), then the file imports with feet and inches as the units. If the AutoCAD file was created in metric, then the file imports into Revit Architecture with millimeters as the units.

For MicroStation® files, Revit Architecture reads the units from the file and uses them. Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If the DGN file has custom units, then the unit in Revit Architecture defaults to feet.

NoteIf you import a file into a project with opposing units (for example, a metric file into an Imperial project), the units in the host project prevail. If the imported file has a custom unit, select Custom factor for Import Units. This enables the text box adjacent to the selection list so that you can enter a scale value.

For example, the file has a unit called widget where one widget equals 10 meters. When importing the file, select Custom factor for Import Units and specify a value of 10 in the adjacent text box. Each unit from the source file is now equal to 10 meters in the Revit file.

The value you enter here displays in the Scale Factor type property of the import symbol.

If the units are known, you can select Custom factor and enter a scale factor. This can increase or decrease the size of the imported elements in Revit Architecture.

Positioning
Auto - Center to Center

Revit Architecture places the center of the import at the center of the Revit model. The center of a Revit model is calculated by finding the center of a bounding box around the model.

If most of the Revit Architecture model is not visible, this center point may not be visible in the current view. To make the point visible in the current view, set the zoom to Zoom View to Fit. This centers the view on the Revit Architecture model.

Auto - Origin to Origin Revit Architecture places the import’s world origin at the Revit project’s internal origin. If the import object has been drawn at a large distance from its origin, it may display at a large distance from the model. To test this, set the zoom to Zoom View to Fit.
Auto - By Shared Coordinates Revit Architecture places the imported geometry according to its position with respect to the shared coordinates between the 2 files.

If there is no current shared coordinate system between the files, Revit Architecture notifies you, and uses Auto - Center to Center positioning. See Shared Positioning.

NoteThis option is for Revit files only.
Manual - Origin The imported document's origin is centered on the cursor.
Manual - Base Point The imported document's base point is centered on the cursor. Use this option only for AutoCAD files that have a defined base point.
Manual - Center Sets the cursor at the center of the imported geometry. You can drag the imported geometry to its position.
Place at Select the level to place the origin/base point.
Orient to View Revit Architecture places the import at the same orientation as the current view. This option is available only for non–view-specific imports.