# Contents

## Chapter 1  Overview ......................................................... 1
  Introduction to AutoCAD P&ID .............................................. 1
  Tour the P&ID Drawing Environment ..................................... 2
    Welcome Screen .......................................................... 2
    P&ID Workspaces ......................................................... 2
    Project Manager ......................................................... 3
    Project Setup Dialog Box ............................................... 4
    P&ID Ribbon ............................................................. 5
    Tool Palettes ........................................................... 6
    P&ID Properties Palette ............................................... 7
    Data Manager ............................................................ 8
    P&ID Validation Settings Dialog Box .................................. 9
    Validation Summary ..................................................... 10
    Work History Dialog Box ............................................... 11
    Assign Tag Dialog Box .................................................. 12
    P&ID Grips .............................................................. 13
    Substitution Palettes .................................................. 14
    P&ID Drawing Tooltips ................................................ 15
    P&ID Shortcut Menus ................................................... 15
    Control the Display of the P&ID Drawing Space ..................... 16

## Chapter 2  Create a Project and Organize Drawings .................. 19
  Create a Project .......................................................... 20
Create Drawing Files for My Project .................................................. 26
Set Drawing Properties ................................................................. 27
Organize Project Files ..................................................................... 29

Chapter 3 Work in a Project Environment .......................................... 33
Open a Project ................................................................................. 34
Refresh the Drawing Status ............................................................. 35
Update Work History ....................................................................... 36
Save Project Drawings ..................................................................... 37
Publish a P&ID DWF or DWFx File .................................................. 38

Chapter 4 Design a P&ID Drawing ..................................................... 43
Add Components ............................................................................ 44
Add Schematic Lines ....................................................................... 47
Validate the Drawing ........................................................................ 49
Add Inline Components .................................................................... 53
Add Instruments ............................................................................... 54
Edit the P&ID Drawing ..................................................................... 57
Tag and Annotate Components and Lines ....................................... 62
View and Manipulate Drawing Data ............................................... 64
Export a P&ID Drawing to AutoCAD ............................................. 69

Chapter 5 Advanced Tasks - Configure the P&ID Drawing Environment . ....... 71
Set Up a New Project ........................................................................ 72
Set Up Components and Lines ....................................................... 76
Set Up Tag Formatting ...................................................................... 82
Set Up Annotations .......................................................................... 89
Set Up Layers and Colors for Components and Lines .................. 92
Set Up Properties for Components and Lines ................................. 95
Set Up a Customized View for the Data Manager ......................... 102

Index .................................................................................................. 113
Overview

Welcome to the AutoCAD P&ID Getting Started Guide.

This guide provides introductory best-practice workflows and tasks that prepare you for working in AutoCAD P&ID. Each chapter contains a workflow diagram for each major project or drawing. Each workflow is a visual representation of the specific exercises that follow the workflow.

In this guide, PIP symbols are used in the examples and exercises. The program includes PIP, ISO, ISA, DIN, and JIS/ISO symbols.

For more information about each workflow and set of procedures, see the AutoCAD P&ID Help system (available from the Help menu in the program).

Introduction to AutoCAD P&ID

AutoCAD P&ID is a drafting program that helps you to create P&ID drawings easily and with a minimum of training.

The program provides a library of symbols that you access from a tool palette and then place in your drawing. You use schematic lines that move when you move equipment, resize automatically, and display the flow direction.

You work exclusively in a project environment, so that your drafting is consistent with others working in the same project.

You can also create reports for a single drawing or an entire project.

If you are an administrator, you can configure a custom P&ID drafting environment that is exactly right for your organization and your designers.
Tour the P&ID Drawing Environment

Before you begin drafting, it is important that you understand how the drawing environment is organized and learn some tips for working in this environment.

Welcome Screen

The Welcome screen displays during startup and whenever you close all of your drawings.

It provides quick access to recent projects and drawings. When you launch AutoCAD P&ID for the first time, the Welcome Screen displays with tools to help you open a project or work with the included Sample Project.

P&ID Workspaces

A workspace consists of a ribbon and palettes that are organized so that you can work in a custom, task-oriented drawing environment while saving drawing real estate for those interface elements you want to display.

When you first open AutoCAD P&ID, the P&ID PIP workspace is displayed by default. It displays interface elements that are particular to both that symbol standard and to the P&ID program. Other elements of the workspace are displayed as you use the program.

The Workspace button is displayed in the lower-right corner of your drawing area. You can switch among five P&ID workspaces (P&ID PIP, P&ID ISO, P&ID ISA, P&ID DIN and P&ID JIS/ISO). You can also select AutoCAD workspaces.
For more information about using workspaces, see “Create Task-Based Workspaces” in the AutoCAD Help system.

**Project Manager**

The Project Manager provides an organized project environment in which to work.

You can create a new project, and you can open, link, copy, and create drawings. You can also export and import data, create project reports, and perform other project tasks.
The Project Manager also provides access to the Project Setup dialog box, which is used by administrators to configure the drawing environment based on your company or client requirements.

**Project Setup Dialog Box**

Administrators can configure project and drafting preferences, such as symbology, tagging rules, annotation properties, layers, colors, and Data Manager views.
P&ID Ribbon

The P&ID ribbon displays grouped icons that provide quick access to creating or editing schematic lines and line groups.

It also provides quick access to the Project Manager and the Data Manager and to the validation, annotation, and tagging options.
Tool Palettes

The P&ID PIP, ISO, ISA, DIN, and JIS/ISO tool palettes display standard component and line symbols for your P&ID drawings.

By default, the P&ID PIP tool palette is displayed. You can switch to another tool palette by right-clicking the tool palette title bar and selecting a tool palette from the list. Of course, you want to use the tool palette that matches the symbol standards you use in your P&ID project.

Administrators can add custom component and line symbols to a P&ID tool palette when they set up a project. For more information about project setup, see Advanced Tasks--Configure the P&ID Drawing Environment (page 71).

The following illustration displays the P&ID PIP, ISO, ISA, DIN, and JIS/ISO tool palettes, with the Equipment tab selected for each standard.
To place a tool from the tool palette into a drawing, click a symbol in the tool palette and click in the drawing where you want to place it.

**NOTE** If you do not see the P&ID workspace interface elements in your drawing area, you may not be displaying the proper workspace. Verify that you are using one of the P&ID workspaces by clicking the Workspace button and clicking P&ID PIP, P&ID ISO, P&ID ISA, P&ID DIN, or P&ID JIS/ISO.

### P&ID Properties Palette

The P&ID Properties palette is similar to the AutoCAD Properties palette, where you can change the property values of selected components or lines.
Following is an illustration of the Properties palette that is displayed when you double-click a schematic line. The P&ID-specific properties that you can populate are illustrated here (under P&ID).

Data Manager

Like the Properties palette, the Data Manager provides access to component and line data.

You can view and change data for multiple P&ID objects in a drawing or project. You can tag multiple components and lines, select components and lines to zoom to in the drawing, export component and line data to Microsoft® Excel® spreadsheets (XLS/XLSX), and import modified data back into your drawing or project. You can also export data to and import data from text-only CSV (comma-separated value) files.
P&ID Validation Settings Dialog Box

You can check your project for common errors such as size or spec mismatches, non-terminating lines, unconnected components, and flow direction conflicts.

You specify what errors are checked in the P&ID Validation Settings dialog box.
Validation Summary

The Validation Summary window displays a list of all errors found in your drawings.
Work History Dialog Box

Depending on how your administrator sets up the Work History prompting behavior, the Work History dialog box may be displayed when you open a drawing from the Project Manager or close the drawing.

You are prompted to provide details about the drawing file that you or another designer may find useful later, such as the work history status and any notes about the drawing.
Assign Tag Dialog Box

Depending on how your administrator sets up the tag prompting behavior, the Assign Tag dialog box may be displayed when you add a component or line that is likely to require a tag.

You may not know the tagging data at the time you insert a component or line. You can add the data later by right-clicking the component or line and clicking Assign Tag or by using the Assign Tag ribbon button.
P&ID Grips

Grips are displayed at strategic points on components or lines that you select. You can click or drag these grips to perform actions described in the following table.

<table>
<thead>
<tr>
<th>Grip Name</th>
<th>Grip Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection grip</td>
<td><img src="image" alt="Connection Grip" /></td>
<td>Connects a schematic line to a component or to another schematic line.</td>
</tr>
<tr>
<td>Endline grip</td>
<td><img src="image" alt="Endline Grip" /></td>
<td>Lengthens or shortens a schematic line.</td>
</tr>
<tr>
<td>Grip Name</td>
<td>Grip Symbol</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Flip grip</td>
<td>Flip</td>
<td>Flips a component in the opposite direction.</td>
</tr>
<tr>
<td>Gap grip</td>
<td>Gap</td>
<td>Breaks a schematic line between the gap symbols.</td>
</tr>
<tr>
<td>Stretch grip</td>
<td>Stretch</td>
<td>Displays at the midpoints of schematic line segments; it moves a line orthogonally.</td>
</tr>
<tr>
<td>Substitution grip</td>
<td>Substitution</td>
<td>Displays a palette with similar components so that you can select a substitute for the component you originally placed.</td>
</tr>
</tbody>
</table>

**Substitution Palettes**

Substitution palettes are displayed for certain components and lines. With these palettes, you can switch to a similar item by selecting the item from the palette.
P&ID Drawing Tooltips

After you add components and line segments to a P&ID drawing, you can perform a quick query of a component or line segment by moving the crosshairs over it.

When the crosshairs are positioned over a component, the values stored in the Class Name and Tag fields for the component are displayed in a tooltip. If the crosshairs are positioned over a line segment, the Pipe Line Type (instead of the Class Name), Tag, and To and From information are displayed in a tooltip.

P&ID Shortcut Menus

With shortcut menus, you can perform tasks that are specific to a component or line.
For example, when you right-click a schematic line, a shortcut menu is displayed for quick access to tasks such as assigning a tag, annotating the line, substituting a line type, and various options for schematic line editing.

Control the Display of the P&ID Drawing Space

By controlling the display of dockable windows and toolbars, locking their position, and using two monitors, you can optimize your P&ID drawing space.

Control the Display of Dockable Windows

Many windows, such as the Project Manager, the P&ID tool palette, and the Data Manager, are dockable. Each can be docked, anchored, or floating.
Commands for changing the display of dockable windows are available on a shortcut menu. You can change the following options for dockable windows:

- **Size.** You can change the size of a window and resize the panes.
- **Allow Docking.** Dock or anchor a dockable window. A docked window adheres to one side of the application window, causing the drawing area to be resized.
- **Anchor.** Attach, or anchor, a dockable window or palette to the left or right side of the drawing area. An anchored window opens or closes as the cursor moves across it. When an anchored window is open, its content overlaps the drawing area. An anchored window cannot be set to stay open. The Allow Docking option must be selected before you can anchor a window.
- **Auto-hide.** Display a floating window that opens or closes as the cursor moves across it. When this option is cleared, the window stays open.
- **Transparency.** Display a window as transparent so that it does not obscure objects behind it. This option is not available for all windows or when hardware acceleration is turned on.

**Lock the Position of Toolbars and Dockable Windows**

After you have arranged toolbars and windows, you can lock their positions. Locked toolbars and windows can still be opened and closed, and items can be added and deleted.

**Use Dual Monitors to Optimize the Drawing Area**

To create a larger drawing space, you can use two monitors. For example, you can use one monitor to display the drawing area, while the other monitor displays the tools for working in the drawing area such as the P&ID tool palette, Project Manager, Data Manager, and so on.

For more information about setting up dual monitors, see the instructions provided with your monitors.
Create a Project and Organize Drawings

Use the Project Manager to create and organize the drawings in your AutoCAD P&ID project.

The workflow on the next page describes one way to create a project and organize your project drawings. For more information and procedures, see Create and Configure a Project and Organize Project Drawings in the AutoCAD P&ID Help system.

You can also configure various settings for a project. Learn more about project setup in Advanced Tasks--Configure the P&ID Drawing Environment (page 71).
Create a Project

Create a new project to use for the exercises you'll perform in this section.

To create a project

1. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ New Project ➤ New Project.

2. In the Project Setup wizard (Page 1 of 6), do the following, and then click Next:
   - Under Enter a Name For This Project, enter My Project.
   - Under Enter an Optional Description, enter My project for Getting Started Guide tasks.
   - Under Specify the Directory Where Program-generated Files are Stored, enter C:\Users\user_name\Documents (for Windows 7 or Vista) or C:\My Documents (for Windows XP).
   - Under Specify the Directory Where Supporting Files (such as spreadsheets or Word documents) are Stored, enter C:\Users\user_name\Documents\My Project\Related Files (for Windows 7 or Vista) or C:\My Documents\My Project\Related Files (for Windows XP).
   - Clear the Copy Setting From Existing Project check box. For most exercises in this guide, you use the default project settings.
In the Project Setup wizard (Page 2 of 6), under Specify the Base Unit for Project Drawings, click Imperial. Click Next.
In the Project Setup wizard (Page 3 of 6), do the following:

- Under Specify the Directory Where P&ID Drawings are Stored, browse to or enter C:\Users\user_name\Documents\My Project\PID DWG (for Windows 7 or Vista) or C:\My Documents\My Project\PID DWG (for Windows XP).
- Under Select the Standard for P&ID Tool Palette Content, click PIP (Imperial).
- Click Next.
In the Project Setup wizard (Page 4 of 6), do the following:

■ Under Plant 3D Model DWG File Directory, browse to or enter C:\Users\user_name\Documents\My Project\Plant 3D Models (for Windows 7 or Vista) or C:\My Documents\My Project\Plant 3D Models (for Windows XP).

■ Under Spec Sheets Directory, browse to or enter C:\Users\user_name\Documents\My Project\Spec Sheets (for Windows 7 or Vista) or C:\My Documents\My Project\Spec Sheets (for Windows XP).

■ Under Orthographic Output Directory, browse to or enter C:\Users\user_name\Documents\My Project\Orthos (for Windows 7 or Vista) or C:\My Documents\My Project\Orthos (for Windows XP).

■ Click Next.
In the Project Setup wizard (Page 5 of 6), make sure SQLite local database is selected and click Next.
7 In the Project Setup wizard (Page 6 of 6), click Finish.
Create Drawing Files for My Project

Now that you’ve created a project, you create drawing files that become part of the project. In later exercises, you work within those drawing files.

To create new project drawing files

1. In the Project Manager tree view, click P&ID Drawings.
2. On the Project toolbar, click New Drawing.
3. In the New DWG dialog box, under Drawing Name, do the following:
   - Under File name, enter 001.
   - Click OK.
Repeat steps 1-4 of this exercise to create a second drawing file with the File name 002.
You are now ready to set drawing properties for your project drawing files.

Set Drawing Properties

Drawing properties that you can set for a project include the drawing title, the drawing number, the author, a short description of the drawing, and the plant area documented in a drawing.

To set drawing properties

1. In the Project Manager tree view, expand the P&ID Drawings node and right-click 001. Click Properties.
2  In the Drawing Properties dialog box, enter the following information:

- In the DWG Number box, enter **01**.
- In the Drawing Area box, enter **51**.
- In the Description box, enter **Test drawing 01-001**.
- Click OK.
3 To set drawing properties for drawing 002, repeat steps 1 and 2, substituting the following steps:

■ In the DWG Number box, enter 02.
■ In the Drawing Area box, enter 52.
■ In the Description box, enter Test drawing 02-002.
■ Click OK.

**NOTE** Make sure you add a DWG number to all drawings in your project. You can then track drawing-specific data in the Data Manager, which displays the DWG number for all components and lines that are part of this drawing. The DWG number is especially important when you are using an off-page connector to continue a line between drawings.

### Organize Project Files

Now that you've created your project, added new drawings to the project, and added drawing properties, you can arrange drawings into folders in the project tree.

**To create a folder in the Project Manager**

1 In the Project Manager tree view, right-click **P&ID Drawings**. Click New Folder.

![Project Folder Properties](image)
2 In the Project Folder Properties dialog box, do the following:
■ Under Folder Name, enter **Areas 51-52**.
■ Select the check box labeled Create Folders Relative to Parent Folder Storage Location. This option ensures that the folder paths retain the same folder hierarchy, even if the project files are moved to another computer.
■ Click OK.

3 Click and drag drawing **001** into the **Areas 51-52** folder. When you see an arrow next to the **Areas 51-52** folder, release the cursor.
The new folder expands to display the drawing you moved into it.
Now that you have learned the basics of creating and organizing a project and project drawings, move on to Work in a Project Environment (P&ID) (page 33).
Work in a Project Environment

When you work in a project environment, you can be sure that you and other designers are all working with the same drawing files, symbols, data, and templates.

The following workflow describes one way to work in the project environment. For more information and procedures, see Work in a Project Environment (page 33) in the AutoCAD P&ID Help system.
Open a Project

When a P&ID workspace (P&ID PIP, P&ID ISO, P&ID ISA, P&ID DIN or P&ID JIS/ISO) is the current workspace, the Project Manager is automatically displayed.

The last project you opened is displayed in the project tree and on the welcome screen. You can start work immediately, select a recent project from the drop-down list, create a new project, or search for a project.

In this set of exercises, you work with the project you created in My Project located at:

- `C:\Users\user_name\Documents\My Project\Project.xml` (In Windows 7 or Windows Vista)
To open a project

1. If the Project Manager is not already displayed, on the ribbon, click Home tab ➤ Project panel ➤ Project Manager.
2. In the Project Manager, in the Current Project list, click My Project.

Refresh the Drawing Status

You can display a thumbnail view of a drawing in the project by selecting a drawing and clicking Preview on the bottom panel of the Project Manager.
To refresh the drawing status

- In the Project Manager, on the Project toolbar, click Refresh DWG Status. The icons representing drawings are updated to indicate their current editing status, as follows:
  - Locked (drawing has been opened by you or another user)
  - Available (drawing is available for editing)
  - Missing (drawing has been moved or removed from the project)

Update Work History

You can add work history information as you work in project drawings.

To add status and notes to the Work History

1. In the Project Manager, click `001`.
2. On the bottom toolbar, click Work History.
3 Under Work History, do the following:
   ■ In the Status list, click Revision 1.
   ■ In the Notes box, enter **Updated PID data for process engineer. Round 1.**

**NOTE** In the Project Setup dialog box, Project Details pane, you can set up prompting behavior so that the Work History dialog box opens when designers open or close a drawing file. For more information about this setting and other project settings, see Set or Change Project Details in the AutoCAD P&ID Help system.

**Save Project Drawings**

Save all project drawings or save a single drawing.
To save all open drawings in a project

- In the Project Manager tree view, right-click My Project. Click Resave All Project Drawings.

To save an open drawing in a project

- On the Quick Access bar, click Save.

Publish a P&ID DWF or DWFx File

In the Project Manager, you can publish an entire project, a subset of a project, or a single drawing in a project to the DWF or DWFx format.

A DWF (Design Web Format) is a set of drawings or images that is compressed into a single, smaller file, making sharing across the Web fast and secure. A DWFx file is based on the XML Paper Specification (XPS) format from Microsoft®. DWFx files are easily distributable on the Windows Vista platform because this format is supported by the XPS Viewer. You can also view DWFx files using Autodesk® Design Review.

Much like Adobe® PDF, the sheets within the set are images of the drawings and are not any more editable than drawings printed to paper. In addition, DWF and DWFx files retain design information and scale. Therefore, they are suitable for architects, engineers, and designers to review and mark up without risk of changes to the original DWG file.

In the following exercise, you publish the entire project. For more information about other DWF publishing options, see Share Project Drawings in the AutoCAD P&ID Help system.

To publish a P&ID DWF file

1. In the Project Manager tree view, right-click My Project. Click Publish.
2 In the Publish dialog box, in the Publish To list, select either DWF File or DWFx File.

3 Click Publish Options.
In the Project Publish Options dialog box, do the following:

- Under P&ID DWF Options, in the P&ID Information box, verify that Include is displayed. If it is not, click the box and click Include in the drop-down list.

- Under Default Output Location, click Location. Click the [...] button. In the Select a Folder for Generated Files dialog box, navigate to \Users\user_name\Documents (Windows 7 or Windows Vista) or \My Documents (Windows XP) and click the My Project folder. Click Select.

- Click OK to close the Project Publish Options dialog box.

In the Publish dialog box, click Publish.

If the Plot - Processing Background Job message is displayed, click Close.

When the DWF or DWFx file is published, you can use Autodesk Design Review to communicate changes and markups without changing the actual drawing (DWG) file. If you plan to share the DWF or DWFx file with clients, they should download Autodesk Design Review from the Autodesk website.

You can also export a P&ID drawing file to an AutoCAD drawing file format without losing the visual fidelity of the P&ID drawing. For more information,
see Export a P&ID Drawing to AutoCAD (page 69) in the AutoCAD P&ID Help System.
Design a P&ID Drawing

You can easily create dynamic schematic drawings. AutoCAD P&ID provides numerous components and lines that you can place in your drawings.

Components and lines contain data that links to the Data Manager, where you can view reports, export the data, and import changed data back into the program. You can also export a drawing to AutoCAD.

At any stage in the drafting process, you can validate a drawing, several drawings, or an entire project. By checking for errors often, you can make corrections early in the drafting process and make sure that your drawings comply with your company standards.

The following workflow describes one way to design your P&ID drawings using the PIP standards. For more information and procedures, see P&ID - Create and Modify Drawings in the AutoCAD P&ID Help system.
Add Components

You can place various types of components and lines to create and edit dynamic schematic drawings that are part of your project.

The following exercises illustrate how to add a pump and then a tank to a drawing. This is just one way that you can work on drawings.

44 | Chapter 4  Design a P&ID Drawing
In the exercises that follow, you create a simple schematic drawing that builds from one exercise to the next. Make sure to save your drawing file after each exercise.

**To add a pump to a drawing**

1. In the Project Manager tree view, right-click drawing 001 and click Open.
2. If the P&ID PIP tool palette is not already open, on the ribbon, click View tab ➤ Tool Palettes.
3. In the P&ID PIP tool palette, on the Equipment tab, under Pumps, click Horizontal Centrifugal Pump.
4. Click an open area in the middle of the drawing area to specify a location for the pump.
5 If the Assign Tag dialog box is displayed, click Cancel. You add tagging information and annotations later.

6 On the Quick Access bar, click Save.

**To add a Tank to a drawing**

1 In the P&ID PIP tool palette, on the Equipment tab, under Storage Tanks, click Dome Roof Tank.
2 Click any open area in the upper-right section of the drawing area to specify a location for the tank.

3 Specify a scale factor for the tank size or press ENTER to accept the default scale.

4 If the Assign Tag dialog box is displayed, click Cancel. You add tagging information later.

5 On the Quick Access bar, click Save.

**Add Schematic Lines**

In the previous exercises, you added a pump and a tank to your drawing. Now, connect these components with a pipe line.

**To add a pipe line**

1 In the P&ID tool palette, on the Lines tab, under Pipe Lines, click Primary Line Segment.
2 In the drawing area, click the top nozzle of the pump to place the primary line.

3 Move the cursor to the middle of the tank and click to the left of the tank to specify the second point of the pipe line.

4 Move the cursor to the right and click again at the edge of the tank to connect the line to the tank.

A nozzle is created automatically when the line is connected to the tank.
5 Press ENTER to end the series of pipe line segments.
   A pipe line is displayed with arrows that indicate the flow direction of the line.

6 On the Quick Access bar, click Save.

Validate the Drawing

You can check your drawing for errors at any time, preferably early in the project.

The validation process detects property mismatches between components and lines and identifies any items that do not conform to your company’s standards.

The following exercises illustrate how to configure validation, validate a drawing, and fix a common error.

To view validation settings

1 On the ribbon, click Home tab ➤ Validate panel ➤ Validate Config.
2 In the P&ID Validation Settings dialog box, under Error Reporting, do the following:
   ■ Expand the P&ID Objects node and make sure all check boxes are selected.
   ■ Expand the Base AutoCAD Objects node.
   ■ Clear each check box. Click OK.

   **NOTE** To view a description of all error types, click each error type (do not select the check box). Under Description, view the error description.

**To validate a drawing**

1 On the ribbon, click Home tab ➤ Validate panel ➤ Run Validation.
The Validation Progress dialog box is displayed. When the validation is complete, the Validation Summary window displays the validation results. You should see an Unconnected Components error.

2 In the Validation Summary window, click the Unconnected Components error node. In the drawing, the horizontal centrifugal pump is highlighted because its left nozzle is not connected to a line.

3 Close the Validation Summary window.

In the next exercise, you add another tank and line to correct this problem.

To repair the validation error

1 In the P&ID PIP tool palette, click the Equipment tab. Under Storage Tanks, click Dome Roof Tank.

2 Click to the left of the pump to specify a location for the tank.

   NOTE If you want to reposition the view, right-click the drawing area and click Pan. Drag the cursor to pan the drawing to a new location. To zoom, right-click the drawing area and click Zoom. Drag the cursor up to zoom in and down to zoom out. Right-click again and click Exit.
3 Specify a scale factor for the tank size or press ENTER to accept the default scale.

4 If the Assign Tag dialog box is displayed, click Cancel. You add tagging information later.

5 Add a schematic line that connects the tank to the left nozzle of the pump. To make sure the flow direction is from tank to pump, start the schematic line at the tank and connect it to the pump.

**NOTE** To view a flow-direction error, start the schematic line at the pump and end it at the tank. You can then reverse the flow to fix the error. To reverse the flow, click the line and on the ribbon Home tab ➤ Schematic Line panel, click Edit. In the list, click Reverseflow. Press Enter.

6 On the Quick Access bar, click Save.

7 ✔️ On the ribbon, click Home tab ➤ Validate panel ➤ Run Validation.

8 In the Validation Complete message, click OK.
NOTE Close the Validation Summary window. If your drawing has additional errors, experiment with resolving the errors using the Validation tool.

Add Inline Components

Inline components, such as valves, are placed on schematic lines.

In the previous exercises, you added a pump and two tanks to your drawing, and then you connected the components with pipe lines. Now, place a valve on one of the lines.

To place a valve on a line

1 In the P&ID PIP tool palette, on the Valves tab, click Gate Valve.
2 Click a location on the top horizontal line to place the valve, as shown in the following illustration.

3 On the Quick Access toolbar, click Save.

Add Instruments

In the previous exercises, you added a pump, two tanks, and two pipe lines. You placed a valve on one of the lines. Now, add a control valve to one of the pipe lines.

To add a control valve to a line

1 In the P&ID PIP tool palette, on the Instruments tab, click Control Valve.

   NOTE The Control Valve Browser is displayed the first time you place a control valve in a drawing. If the Control Valve Browser is not displayed, skip to step 3.

2 In the Control Valve Browser, do the following:
   ■ In the Select Control Valve Body tree view, click Gate Valve.
   ■ In the Select Control Valve Actuator tree view, click Diaphragm Actuator.
   ■ Click OK.
3 Click the horizontal line to the right of the gate valve to place the control valve, as shown in the following illustration.

4 You are prompted to select an annotation position. Move your cursor to position the annotation, and click where you want to place it.
If the Assign Tag dialog box is displayed, click Cancel. You add tagging information later.

A leader line is automatically placed to connect the annotation bubble to the control valve.

On the Quick Access toolbar, click Save.
Edit the P&ID Drawing

After you have created a drawing file and added components (such as equipment), valves, lines, and instruments, you can continue to make modifications to the drawing to make sure that it is precise and current.

Editing tasks you perform in this exercise include moving an equipment item, a valve, and a line, and substituting one component for another. These are just some of the editing tasks you can perform. For more information about editing your P&ID drawings, see P&ID - Create and Modify Drawings in the AutoCAD P&ID Help system.

To move a tank

1. In the P&ID drawing (001) you worked on in the previous exercises, click anywhere on the border of the top tank to select it.

2. On the lower-left corner of the selected tank, click the grip and drag the tank to the left, about half the length of the horizontal line. Click again to place the tank in the new position.

   NOTE The control valve and gate valve adjust to fit the shortened horizontal line.
3 On the Quick Access toolbar, click Save.

To move the gate valve

1 In P&ID drawing 001, click the gate valve.

2 Drag the gate valve from the horizontal line, and click on the vertical line to place the valve.
NOTE: If the gate valve jumps to the top of the vertical line, click the Object Snap button at the bottom left of the P&ID window to turn off snap behavior. When object snap is inactive, the button background is gray instead of blue. Return the gate valve to its former position and attempt the move again.

3 Press Escape to see that the valve has flipped to align with the vertical line.

To substitute a valve type

1 Click the gate valve to select it.

2 Click the substitution grip.
3 Click Ball Valve (the second valve in the list). The gate valve is replaced by the ball valve.

4 On the Quick Access toolbar, click Save.

**To move a line**

1 In P&ID drawing 001, click the top horizontal line. All items on or connected to the line are also selected.
2 Click the stretch grip in the middle of the top horizontal line, and move the line up slightly. Click the new location to place the line. The control valve and instrument bubble move with the line, but the tank does not move.

3 Continue to experiment with moving the lines and the components.

4 On the Quick Access toolbar, click Save.
Tag and Annotate Components and Lines

A tag is a property that uniquely identifies a component or line.

You can assign tags to components and lines at any time. Use annotations to place text on a drawing to label a component. An annotation often includes a tag property and displays that property on the drawing. The result is not a tag, however, but an annotation.

Because the terms tag and annotation are easily confused, they are described in detail in this table.

<table>
<thead>
<tr>
<th>A tag is:</th>
<th>An annotation is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A unique identifier for a component or line segment</td>
<td>Component or line segment information that is displayed in a drawing</td>
</tr>
<tr>
<td>Data</td>
<td>Text and (optional) shapes</td>
</tr>
<tr>
<td>Unique</td>
<td>Not necessarily unique</td>
</tr>
<tr>
<td>Viewable as a property in the Data Manager</td>
<td>Viewable in the drawing</td>
</tr>
<tr>
<td>A single element for each component or line segment</td>
<td>Not necessarily a single element per component or line segment. (A component or line segment can have multiple annotations.)</td>
</tr>
<tr>
<td>Comprised of sub-parts as defined by the tag format</td>
<td>Text defined in the Annotation Style's block definition Text that can include the tag property of a component or line segment. This text is not a tag, but an annotation.</td>
</tr>
</tbody>
</table>

In the previous exercises, you added a pump and two tanks to the drawing, connected them with a pipe line, and then added a valve and a control valve to one of the pipe lines. Then you edited some of those items.

Now, add tagging information and specify that an annotation be placed on the drawing.
NOTE You can add tagging information and annotations to the other items in the drawing using the same method illustrated in the following exercise.

**To add a tag**

1. On the ribbon, click Home tab ➤ P&ID panel ➤ Assign tag.
2. In P&ID drawing 001, click the pump. Press Enter.

3. In the Assign Tag dialog box, click the arrow to the right of Existing Pumps to view the tag data for other horizontal centrifugal pumps in your project (the list may be empty or differ from the one shown in the illustration).
   - In the Number box, enter **110** (or another number if that number is not available).
   - Select the Place Annotation After Assigning Tag check box.
   - In the Annotation Style list, click Pump InfoTag.
4. Click Assign.
You are prompted to select an annotation position.

5 Move your cursor to position the annotation below the pump, and click to place it.

6 Continue tagging and annotating the other items in the drawing using the method you learned in this exercise.

7 On the Quick Access bar, click Save.

**View and Manipulate Drawing Data**

You use the Data Manager to view, edit, and manipulate component and line data and to generate reports.

Export reports or import them using Microsoft® Excel® spreadsheets (XLS/XLSX) or as plain text in the form of comma-separated value (CSV) files.

In the exercises that follow, you export data, manipulate the data in a spreadsheet, and import the data back into the Data Manager.

**NOTE** You must have Microsoft® Excel® 2003 or later installed on your system.

**To view and export drawing data in the Data Manager**

1 On the ribbon, click Home tab ➤ Project panel ➤ Data Manager.

   The Data Manager displays data for the components and lines that you placed in drawing 001 in the previous exercises.
NOTE In the upper-left corner of the Data Manager, Current Drawing Data is displayed in the drop-down list to indicate that you are working with a drawing’s component and line data. You can also work with project data, report data, or data organized in a customized view. You learn how to create a customized view for the Data Manager later. For information about other ways to view data, see Work with the Data Manager in the AutoCAD P&ID Help system.

2 To export all components and line data in the drawing, in the Data Manager tree view, click Engineering Items.

3 On the Data Manager toolbar, click Export.

4 In the Export Data dialog box, click Browse.
5 In the Export To dialog box, in the Save In list, navigate to the \My Project folder. In the File Name box, accept the default spreadsheet file name (01-EngineeringItems.xls), and click Save.

6 In the Export Data dialog box, click OK.

To modify exported P&ID data in a spreadsheet

1 Open Windows Explorer and locate the spreadsheet (01-EngineeringItems.xls) that you exported and saved in the \My Project folder.

2 In the spreadsheet, locate and select the Engineering Items worksheet.

3 On the Engineering Items worksheet, in the Manufacturer column, enter Sam's Discount Valves as the manufacturer for valves and ACME as the manufacturer for nozzles.
Save the file with the same name, same file type (.xls), and in the same location (\My Project) as the original file.

To import changed P&ID data from a spreadsheet

1. In the Data Manager, make sure that the Engineering Items node is selected.

2. In the Data Manager toolbar, click Import.

3. If the AutoCAD P&ID log file message is displayed, click OK.

4. In the Import From dialog box, navigate to the \My Project folder and click 01-EngineeringItems.xls.
5 Click Open.

6 In the Import Data dialog box, click OK.
   In the Data Manager, the changes you made in the spreadsheet are
   highlighted in yellow. In the drawing, the affected components have
   red outlines, called revision clouds.

7 In the Data Manager, click Revision Cloud to hide or display
   the revision clouds.
8 Right-click each of the modified records and click Accept Edit.

NOTE In this exercise, you are accepting changes one at a time. You can also accept or reject all changes by using the Accept All or Reject All buttons on the Data Manager toolbar.

9 On the Quick Access bar, click Save.

Export a P&ID Drawing to AutoCAD

You can export a P&ID DWG file to an AutoCAD DWG file format without losing the visual fidelity of the P&ID drawing. The exported drawing retains all P&ID components and annotations as AutoCAD blocks. All P&ID schematic lines are retained as AutoCAD lines. You can then use AutoCAD to open, view, edit, and plot the exported P&ID DWG files.

To export a P&ID drawing to AutoCAD

1 Make sure the drawing you have been working on (001) is open.
2 In the Project Manager tree view, right-click the drawing. Click Export to AutoCAD.
In the Export to AutoCAD dialog box, browse to the location where you want to save the drawing.

In the File Name box, enter **PID_to_ACAD**.

In the Files of Type list, specify one of the following file formats for the drawing:
- AutoCAD 2012 Drawing (*.dwg)
- AutoCAD 2012/LT 2012 Drawing (*.dwg)

Click Save

Congratulations! You have completed the first four chapters of the Getting Started Guide.

If you want to learn more about the advanced features of the program, you can continue with Chapter 5, *Advanced Tasks--Configure the P&ID Drawing Environment* (page 71).

You can also continue to experiment with the program and build onto the project you used throughout this guide (My Project), or you can delete the files from your system and start with a new project.
AutoCAD P&ID provides a default project configuration that works for the majority of your project and drawing needs.

As an administrator of a project, you can modify project and drawing settings by using the Project Setup dialog box.

The following workflow describes some of the ways you can configure project settings. For more information and procedures, see Create and Configure a Project.
Set Up a New Project

In Create a Project and Organize Drawings (page 19), you created a new project but you did not configure the project settings.

If you want to change the default project settings, create a new project and then change the settings. By creating a new project, you retain the default project settings.

To set up a new project

1. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ New Project ➤ New Project.

2. In the Project Setup wizard (Page 1 of 6), do the following, and then click Next:
   - Under Enter a Name For This Project, enter P&ID Test Project.
   - Under Enter an Optional Description, enter P&ID Test Project for Learning AutoCAD P&ID.
   - Under Specify the Directory Where Program-generated Files are Stored, click the [...] button. In the Select Project Directory dialog box, navigate to the Temp folder on your local drive. (If you do not have a Temp folder on your local drive, create one.) Click Open. The complete path is C:\Temp.
   - Under Specify the Directory Where Supporting Files (such as spreadsheets or Word documents) are Stored, navigate to the Temp folder on your local drive and click Open. Enter \P&ID Test Project\Related Files. The complete path is C:\Temp\P&ID Test Project\Related Files.
   - Clear the Copy Setting From Existing Project check box. For most exercises in this guide, you use the default project settings.
3 In the Project Setup wizard (Page 2 of 6), under Specify the Base Unit for Project Drawings, click Imperial. Click Next.

4 In the Project Setup wizard (Page 3 of 6), do the following:
   ■ Under Specify the Directory Where P&ID drawings are Stored, browse to or enter C:\Temp\P&ID Test Project\PID DWG.
   ■ Under Select the Standard for P&ID Tool Palette Content, click PIP (Imperial).
   ■ Click Next.

5 In the Project Setup wizard (Page 4 of 6), do the following:
   ■ Under Plant 3D Model DWG File Directory, browse to or enter C:\Temp\P&ID Test Project\Plant 3D Models.
   ■ Under Spec Sheets Directory, browse to or enter C:\Temp\P&ID Test Project\Spec Sheets.
   ■ Under Orthographic Output Directory, browse to or enter C:\Temp\P&ID Test Project\Orthos.
   ■ Click Next.

   NOTE The directories on page 4 of the wizard pertain to Plant 3D.

6 In the Project Setup wizard (Page 5 of 6), make sure SQLite local database is selected and click Next.

7 In the Project Setup wizard (Page 6 of 6), select the check box labeled Edit Project Properties After Creating Project. Click Finish.
NOTE If you already have project drawings open, you are prompted to close those drawings before you start the new project.

After the project is created, the Project Setup dialog box is displayed. You have a new test project where you can make changes without modifying the configuration of an actual working project.

8 In the Project Setup dialog box, familiarize yourself with the tree structure and the configuration options. You can use the tree view on the left side of the Project Setup dialog box to choose the options you want to change, and then modify the information displayed on the right pane.
When you finish exploring the Project Setup dialog box, click OK.

Next, you set up some drawing files to use for your project setup tasks. Later, you see how changes you make in Project Setup affect the drawings in a project.

**To set up new project drawings**

1. In the Project Manager tree view, click *P&ID Test Project* (the project you created in the previous exercise). Click *P&ID Drawings*.
2. On the Project toolbar, click New Drawing.
3. In the New DWG dialog box, under File Name, enter *Test Drawing 1*. Click OK.
4. Repeat steps 1 through 3 to add another new drawing to your project, making sure to give it the file name *Test Drawing 2*.
5. In the Project Manager tree view, right-click *Test Drawing 1*. Click Properties.
6. In the Drawing Properties dialog box, in the DWG Number box, enter 01. Click OK.
7. To set drawing properties for drawing Test Drawing 2, repeat steps 5 and 6, substituting 02. Click OK.
In the Project Manager, the new drawings are added to the project. You are ready to start editing properties for the project you just created.

**NOTE** You can set up a file name format to ensure that all files created within a project follow a specific pattern. For more information and procedures, see Configure File Name Formats in the AutoCAD P&ID Help system.

---

### Set Up Components and Lines

To create most equipment, instruments, lines, inline items, and nozzles, you start with an existing class definition and you edit that class definition.

You might also want to create your own class definitions. For example, your company might use a different kind of pump than the pump symbols provided in the product.

You can create your own pump symbol for your designers to use. For more information about creating your own class definitions, see Set Up Class Definitions for Components and Lines in the AutoCAD P&ID Help system.

When you create or modify a component, you can modify the following class definitions in the program:

- **Symbol or line settings.** The name of the symbol or line style; the name of the block controlling the geometry that is displayed in the drawing after a component is inserted; the layer, color, linetype, linetype scale, and plot style; the lineweight of a component when it is inserted; and other settings that affect the insertion of a component or how a schematic line is drawn.

- **Properties.** The values assigned to a component or line class definition to determine how it looks and behaves in a P&ID drawing, and the values that are attached to a component or line (such as default value, description, substitution, supported standards, and so on).

- **Tag format.** The information that comprises a unique tag for a component or line.

- **Annotation.** The text and symbol settings that annotate a component or line.

You can also create and rename class definitions and delete those that are not used in a project drawing.

In the following exercise, you create a new pump from an existing pump, change the class definitions for the new pump, and then add the new pump...
to the Equipment tab of the tool palette. This is just one way you can add new components and lines to your library of symbols.

**To create a pump from an existing pump and add it to the tool palette**

1. In the Project Manager tree view, right-click *Test Drawing 1* and click Open.
2. If the P&ID PIP tool palette is not already displayed, on the ribbon, click View tab ➤ Palettes panel ➤ Tool Palettes. Click the Equipment tab.
3. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ Project Setup.
4. In the Project Setup dialog box, in the tree view on the left, click *P&ID DWG Settings*. 
5 Click P&ID Class Definitions ➤ Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.
6 On the Class Settings pane, under Symbol, click Add Symbol.
7 In the Symbol Settings dialog box, do the following:

- Under Symbol Properties, in the Symbol Name box, enter **Centrifugal Sump Pump Style2**.
- Under Other Properties, click Scale On Insert, and in the drop-down list, click Yes. When you place the pump in a drawing, you are prompted to scale the symbol.
- Under Other Properties, click Tagging Prompt, and in the drop-down list, click Automatically Assign an Auto-Generated Tag. When you use the pump in a drawing, you are not prompted to add tagging information.
- Click OK.
8 On the Class Settings pane, under Symbol, do the following:
   ■ In the drop-down list, click Centrifugal Sump Pump Style2.
   ■ Click Add to Tool Palette.

9 In the Create Tool message, click OK.
The new component is added to the bottom of the active tab on the tool palette and contains the styles you just defined. It can be used just like the default components provided with AutoCAD P&ID and is included in reports.
10  In the Project Setup dialog box, click OK.

NOTE  You can move the pump tool you just added to the tool palette by dragging it and placing it in its new location in the palette. You can also copy or cut it and paste it onto another P&ID tool palette.

11  In the drawing area, in the lower-right corner of the tool palette, click the centrifugal sump pump you just created (Centrifugal Sump Pump Style2) and click in the drawing to place it.

As you just defined in step 7 of this procedure, you are prompted to set the scale, but you are not prompted to add tagging information.

Set Up Tag Formatting

Set up tag formats to help designers apply tag elements consistently throughout a project cycle.
You can set up tag formats for equipment, valves, nozzles, instrumentation, pipe lines, and pipe line groups. You can create new tag formats or modify existing formats.

Tag formats are assigned to a class definition. Typically, parts of the tag are also class definitions (for example, a definition type, such as equipment). You can also use a property of a drawing or project in the tag numbering format. For example, at the drawing level, you might want to set tag formatting to reflect a property such as the drawing number.

In this exercise, you set up tag formatting for the new pump to be
_Type-Area._Number.

**To create a new tag format**

1. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ Project Setup.
2. In the Project Setup dialog box, in the tree view on the left, click *P&ID DWG Settings*.
3 Click P&ID Class Definitions ➤ Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.

4 On the Class Settings pane, under Tag Format, click New.
5 In the Tag Format Setup dialog box, do the following:
- In the Format Name box, enter **Pump Tag**.
- In the Number of Subparts box, click the Up arrow until the number 3 is displayed.
- In the first row of icons, click Select Class Properties.

6 In the Select Class Property dialog box, do the following:
- In the Class tree view, click Equipment.
In the Property list, click Type.
Select the check box labeled Use Target Object’s Property.
Click OK.

In the Tag Format Setup dialog box, in the second row, click Select Drawing Properties.

In the Select Drawing Property dialog box, do the following:
- Under Category, click General.
- Under Drawing Properties, click Drawing Area.
- Click OK.

In the Tag Format Setup dialog box, in the third row, click Define Expression.

In the Define Expression dialog box, under Expression, do the following:
- Click Numbers.
- Select Fixed Length.
- In the Fixed Length box, click the Up arrow to display the number 3.
- Click OK.
In the Tag Format Setup dialog box, set the Delimiter fields as follows:
- Leave the dash (-) in the first Delimiter field.
- Enter a period (.) in place of the dash in the second Delimiter field.
- Leave the third Delimiter field blank.
- Click OK.
12 In the Project Setup dialog box, in the Class Settings pane, under Properties, scroll to the bottom of the table. In the Property Name column, locate the TagFormatName row. To the right of TagFormatName, in the Default Value column, select Pump Tag in the drop-down list.

13 In the Project Setup dialog box, click OK to save the changes and close the dialog box. You have created a new Pump Tag format and assigned it to the centrifugal sump pump. When you use this pump in a drawing, the Assign Tag dialog box prompts you to enter tag data for the three-part tag you created (Type-Area.Number).
For more information about assigning tags, see Tag and Annotate Components and Lines (page 62).

## Set Up Annotations

Annotation is used to describe a component or line in a drawing.

You can change the following information for annotations:

- **Symbol Properties.** Sets the name of the annotation style and defines the block that is displayed when the style is used.
- **General Style Properties.** Sets the layer, color, linetype, linetype scale, plot style, and lineweight for the annotation.
- **Other Properties.** Sets the scale factor used for the symbol, whether the annotation inherits the component’s properties, is linked to a class, is automatically inserted, and the X and Y offset distance from a component.

### To create a new annotation style from an existing annotation style

1. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ Project Setup.
2. In the Project Setup dialog box, in the tree view on the left, click *P&ID DWG Settings.*
3 Click P&ID Class Definitions ➤ Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.

4 On the Class Settings pane, under Annotation, do the following:
   - In the drop-down list, click Pump Infotag.
   - Click Add Annotation.
In the Symbol Settings dialog box, do the following:

- Under Symbol Properties, in the Symbol Name box, enter Pump Infotag2.
- Under Other Properties, click Linked. In the drop-down list, click No. When you use the annotation in a drawing, the annotation does not move with the pump when the pump is moved.
- Under Other Properties, click Auto Insert. In the drop-down list, click Auto Insert With Prompt. When you use the annotation in a drawing, you are prompted to annotate the pump.
- Click OK.
6 On the Class Settings pane, under Properties, scroll to the bottom of the table. In the Property Name column, locate the AnnotationStyleName row. In the Default Value column, in the drop-down list, select Pump InfoTag2.

7 In the Project Setup dialog box, click OK.

8 In the active drawing, on the tool palette, click the Equipment tab. Click the centrifugal sump pump, and click the drawing area to place it.

9 In the Assign Tag dialog box, do the following:
   ■ In the General box, enter 1.
   ■ Click in the Expression box, and click the button to the right of it. Based on the way you set up the annotation’s insertion behavior in step 5, you are prompted to specify the annotation position.

10 Click the drawing area to place the annotation.

11 In the drawing area, click and drag the pump to move it. Because of the way you set up the annotation linking behavior in step 5, the annotation does not move with the pump.

Set Up Layers and Colors for Components and Lines

You can set up layers and colors for individual P&ID components and lines.
In the following exercise, you edit the layer and color of an existing symbol. You can modify an existing symbol or create a new symbol (to make sure that
the original symbol is not modified). To modify the layer and color of a symbol later, modify the original style.

**To modify an existing component's layer and color**

**NOTE** Before you start this exercise, make sure that the P&ID PIP tool palette is displayed in your drawing and that the Equipment tab is active. The component you create is added to that tool palette tab at the end of this exercise.

1. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ Project Setup.
2. In the Project Setup dialog box, in the tree view on the left, expand P&ID DWG Settings.
3 Click P&ID Class Definitions ➤ Engineering Items ➤ Equipment ➤ Pumps ➤ Centrifugal Sump Pump.

4 On the Class Settings pane, under Symbol, do the following:
   ■ In the drop-down list, click Centrifugal Sump Pump Style.
   ■ Click Edit Symbol.
In the Symbol Settings dialog box, under General Style Properties, do the following:

- Click Layer. In the drop-down list, click Use Current.
- Click Color. In the drop-down list, click Red.
- Click OK.

On the Class Settings pane, under Symbol, click Add to Tool Palette.

In the Create Tool message, click OK.

In the Project Setup dialog box, click OK.

In the drawing, on the tool palette, the new Centrifugal Sump Pump Style component is added to the lower-right corner of the Equipment tab.

On the Equipment tab of the tool palette, click the new pump and click in the drawing area to place it. When you place the component, its color is red, and it is placed on the current layer.

Any other instances of a centrifugal sump pump in the drawing also inherit the layer and color properties you set here.

Set Up Properties for Components and Lines

Properties are the individual attributes that make up a class definition.

For example, the class definition of Hand Valves includes such properties as manufacturer, supplier, model number, size, spec, and so on. You can modify existing properties, add custom properties, or set up a property so that it acquires its value from another property.

Class definitions are divided into the following categories:

- **Engineering items**. (Includes equipment, inline assets, instrumentation, lines, and nozzles)
- **Non-engineering items**. (Includes items that are not counted in reports, including actuators, annotation, connectors, flow arrow, flag, gap, line breakers, and others)
- **Pipe line group**.
- **Signal line group**.

The following exercise explains how to change properties for a gate valve. You can use the same general steps to set the properties for any component or line.
To change default properties for a component or line

1. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ Project Setup.

2. In the Project Setup dialog box, in the tree view on the left, click P&ID DWG Settings.

3. Click P&ID Class Definitions ➤ Engineering Items ➤ Inline Assets ➤ Hand Valves ➤ Gate Valve.
4 On the Class Settings pane, under Properties, do the following:

- In the Display Name column, add the number 1 to the end of the Class Name and Description fields.
- In the Read Only column, select the check box for Description to make this field read-only.

5 In the Project Setup dialog box, click OK.

The following exercise illustrates how to set up a new acquisition property for Hand Valves called *PipeLinesInsulationType*, a property that the Gate Valve inherits.

**To set up a new acquisition property**

1 On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ Project Setup.

2 In the Project Setup dialog box, in the tree view on the left, click P&ID DWG Settings.
3 Click P&ID Class Definitions ➤ Engineering Items ➤ Inline Assets ➤ Hand Valves.

4 On the Class Settings pane, under Properties, click Add.

5 In the Add Property dialog box, do the following:
   ■ In the Property name box, enter PipelinesInsulationType.
   ■ Under Choose a Type, click Acquisition.
   ■ Click OK.
In the Select Data Source dialog box, on the Class Properties tab, do the following:

- In the Categories tree view, expand Engineering Items.
- Locate and click Lines ➤ Pipe Line Segments.
- In the Properties list, click Insulation Type.
- Click OK.
7 On the Class Settings pane, under Properties, in the Property Name column, locate PipelinesInsulationType. In the Acquisition column, notice that the property is set to acquire its value from PipeLines (the class name for Pipe Line Segments).

8 In the Project Setup dialog, click OK.

9 If 01-Test Drawing 1 is not already open, in the Project Manager, right-click the drawing name. Click Open.

10 In the drawing area, do the following:
   ■ Add a pump.
   ■ Add a tank.
   ■ Add a pipe line that connects the pump to the tank.
   ■ Place a gate valve on the pipe line.

   **NOTE** The procedures for adding a pump, adding a tank, connecting the pump to the tank, and placing a gate valve on the pipe line are included in the exercises from Design a P&ID Drawing.

In the next exercise, you add property values to Pipe Line Segments. After you enter the values, the gate valve's acquired property values are updated as well.
To add values and view property changes in the Data Manager

In this exercise, you open the Data Manager, add values to Pipe Line Segments, and see the results of all property changes you have made.

1. On the ribbon, click Home tab ➤ P&ID panel ➤ Data Manager.
2. In the Data Manager tree view, click Engineering Items ➤ Lines ➤ Pipe Line Segments.

3. On the right pane (the data view), do the following:
   - Locate the Size column. Double-click the Size box. In the drop-down list, select 1/4”.
   - Locate the Insulation Type column (scroll to the right, if necessary). Double-click the Insulation Type box. In the drop-down list, select IS-Safety.

4. In the tree view, expand Engineering Items until you locate and click Inline Assets ➤ Hand Valves ➤ Gate Valve.
5. On the toolbar, click Hide Blank Columns.
6. In the data view, view the changes you made to the properties:
   - The column header *Class Name* is changed to *Class Name1*.
   - The column *Description* is changed to *Description1* and is read-only (editable).
   - Size displays an acquired value of 1/4”.
   - *PipelinesInsulationType* displays an acquired value of IS.

### Set Up a Customized View for the Data Manager

In the Data Manager, the default tree view mirrors the P&ID class hierarchy, starting with Engineering Items at the top level, followed by Equipment, Inline Assets, Lines, and so on.

By creating a customized Data Manager view, you can view drawing data with the focus on properties instead of classes. For example, you can set up existing
properties, such as Manufacturer and Supplier, as the basis of the new view. You can also create and use new properties for a view.

In this exercise, you set up a customized view based on two properties: Manufacturer and Supplier. At the end of the exercise, compare the new tree view with the one representing the typical class hierarchy.

**To set up a customized view for the Data Manager**

1. In the Project Manager, in the Current Project list, click My Project. This is the project you created previously.

2. On the ribbon, click Home tab ➤ Project panel ➤ Project Manager ➤ Project Setup.
3 In the Project Setup dialog box, in the tree view, click P&ID DWG Settings.

4 Click Data Manager Configuration. On the Customized Views pane, click Create View.
5 Under A New Customized View - Drawing Data, do the following:
   ■ In the Name box, enter Manufacturer and Supplier View.
   ■ To define the scope of your view, in the Scope list, click Drawing Data.
   ■ Click New Level.
6 In the Select Class Property dialog box, do the following:
   ■ In the Class tree view, click Engineering Items.
   ■ Under Properties, click Manufacturer.
   ■ Click OK. In the Customized View pane, under Manufacturer and Supplier View - Drawing Data, Level 1, ENGINEERINGITEMS.Manufacturer, is displayed.

7 Click New Level.

8 In the Select Class Property dialog box, do the following:
   ■ In the Class tree view, click Engineering Items.
   ■ In the Properties list, click Supplier.
   ■ Click OK. Level 2, ENGINEERINGITEMS.Supplier, is displayed.
9 On the Project Setup dialog box, click OK.
10 In the Project Manager, right-click drawing 001 and click Data Manager.
11 In the Data Manager, in the tree view, click Engineering Items.
12 On the toolbar, click Show Blank Columns.

13 In the data view table, in the Manufacturer column, do the following:
   ■ In the first cell, enter Bausch.
   ■ In the second cell, enter Adams.
   ■ In the third cell, enter 3Tier.
   ■ Continue to add manufacturer names until the Manufacturer column has a name in every cell.

14 In the Supplier column, do the following:
   ■ In the first cell, enter Kendall.
   ■ In the second cell, enter Johnson.
   ■ Continue to add supplier names until the Supplier column has a name in every cell.
15 In the Data Manager drop-down list, click Drawing Custom Views.

16 Expand the new view by expanding each node. Click the Manufacturer - Bausch node.

The customized view displays the data in a property-based hierarchy. Level one is Manufacturer, and level two is Supplier. When you click the level one node, Manufacturer - Bausch, you see the details about those components or lines manufactured by Bausch. Click the various nodes in the tree to view the relevant detail in the data view. This customized view is different from one that is based on the typical component and line class hierarchy. See the illustration of a class hierarchy at the beginning of this section for comparison.

All other brand names, product names or trademarks belong to their respective holders.

**Disclaimer**

THIS PUBLICATION AND THE INFORMATION CONTAINED HEREIN IS MADE AVAILABLE BY AUTODESK, INC. "AS IS." AUTODESK, INC. DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS.

**Notices**

**P&ID Symbols**

The symbols in this product are used by Autodesk under license from PIP (Process Industry Practices), ISA, ISO (International Organization for Standardization), and DIN (Deutsches Institut Fur Normung e. V.).

110 | Chapter 6 Trademarks
PIP

The PIP symbols in this Autodesk product are used with permission granted by license agreement from Process Industry Practices (PIP).

Process Industry Practices (PIP)
3925 West Braker Lane (R4500)
Austin, TX 78759, USA
Phone: (512) 232-3042
www.pip.org

ISA

The ISA symbols in this product are used by Autodesk under license from ISA.

ISA
67 Alexander Drive
PO Box 12277
Research Triangle Park, NC 27709, USA
Phone: (919) 549-8411
Fax: (919) 549-8288
Email: info@isa.org
www.isa.org

ISO

The ISO symbols in this product are used by Autodesk under license from The International Organization for Standardization (ISO). ISO standards can be purchased from American National Standards Institute (ANSI/ISO)

ISO
25 West 43rd Street
New York, NY 10036
Tel: (212) 642-4900
http://webstore.ansi.org/default.aspx
ISO 10628:1997 Symbols © The International Organization for Standardization (ISO)
ISO 14617-5:2002 Symbols © The International Organization for Standardization (ISO)

ISO 14617-6:2002 Symbols © The International Organization for Standardization (ISO)

ISO 3511-1:1977 Symbols © The International Organization for Standardization (ISO)

ISO 3511-2:1984 Symbols © The International Organization for Standardization (ISO)

ISO 3511-3:1984 Symbols © The International Organization for Standardization (ISO)

ISO 3511-4: 1985 Symbols © The International Organization for Standardization (ISO)

DIN

(Deutsches Institut Fur Normung e. V.)

The data from DIN Standards are used by permission of DIN Deutsches Institut für Normung e. V. They conform with the current version of the DIN Standards concerned (Date).

DIN Deutsches Institut für Normung e. V.,
Burggrafenstraße 6,
10787 Berlin,
Germany

DIN 2481:1979-06 Symbols © Deutsches Institut für Normung e. V. (DIN)

JIS

The JIS symbols in this product are used by Autodesk under permission from JIS.
Index