Asset Tracking Dialog
 
 
 
Bottom of the Page

Application menu Manage Asset Tracking

Keyboard Shift+T

With the Asset Tracking dialog, you can check files in and out, add files to the Asset Tracking System (ATS), get different versions of files, and so on, all from 3ds Max Design without the need to use separate client software.

Another important function of the Asset Tracking dialog is for repathing; locating missing files. For example, if you move bitmap files used by materials in your scene to the same folder as the scene file, the bitmaps will be loaded when you open the scene file, but the materials will still use the original, no-longer-valid path for the bitmap files, and the Asset Tracking dialog will show the files as missing. To resolve the incorrect paths, you can use the tools available from the Paths menu.

Asset tracking provides full support for the Autodesk Vault data-management solution, and basic version-control support for other providers, such as Perforce and Microsoft SourceSafe. In general, asset tracking supports version-control providers that are capable of integrating into Microsoft Visual Studio, sometimes referred to as MSSCC support. This topic assumes usage of Autodesk Vault.

The Asset Tracking dialog provides the principal functionality for working with the Vault data-management solution from within 3ds Max Design, but you can also work directly with Vault using the Vault Explorer client software, which is included with 3ds Max Design. To run Vault Explorer, go to Windows Start menu Autodesk Autodesk Data Management and choose Autodesk Vault Explorer. To learn more about using Vault Explorer, open the Autodesk Vault Explorer Help menu and choose Autodesk Vault Help Topics, or simply press F1 while the Vault Explorer window is active.

See Also

Filtering Files

You can configure individual asset-tracking-system providers via the provider configuration file, ATSProviders.xml, which resides in \plugcfg in the 3ds Max Design install folder. 3ds Max Design reads this file, but doesn't write to it.

The primary configuration function is filtering. Filters define criteria 3ds Max Design uses to determine whether a file should be excluded from a provider’s control. If a file is determined to be excluded from a provider, the file is never sent to the provider for status check or any other action. This feature is useful when using multiple providers within the same pipeline or if your studio still uses file servers for certain file types.

When a file is excluded, its icon is grayed out and its status message indicates that it is excluded. You can also toggle the display of excluded files in the dialog window with the Display Excluded Files option.

A example filter file, \plugcfg\ATSProviders_Example.xml is included with 3ds Max Design, in the 3ds Max Design install folder. The file includes comments, so you can load it into a text editor to see how it works and edit it. If you're using Autodesk Vault as your provider, you can rename the provider field (in the <Provider> section, near the beginning of the file) to Autodesk Vault, as follows:

Change:

<Name>Sample Provider Name Example</Name>

to:

<Name>Autodesk Vault</Name>

One of the effects of the example file is to exclude FX files, as shown in the following illustration:

Procedures

If you are using Vault as your asset management system, you will need to login into the Vault the first time you access it, otherwise you will not be able to check files in and out.

To start and login into the Vault from 3ds Max Design:

  1. In 3ds Max Design, choose Application menu Manage Asset Tracking.
  2. Select the version of Autodesk Vault that you want to login to from the Autodesk Vault Version box.

  3. In the Asset Tracking dialog choose Server Log in.
  4. In the Log in dialog box enter the following:
    User Name The name for the vault account. Default= Administrator
    Password The password associated with the vault account. Default=<left blank>
    Server The name of the computer on which the vault server is installed. Use “localhost” if the server is installed on the same machine as the client. See your system administrator if this does not work.
    Database The name of a vault database located on the specified server. The default is “Vault”. Click the browse button to select from a list of available databases on the server. Default=Vault
    NoteEnable Use this settings next session if you want to be automatically logged in future sessions.

    Click OK when you have entered values in all fields.

    NoteYour system administrator may provide you with your own account values which you will use instead of the defaults. If you are experiencing problems, speak with your system administrator.

To set up a local working folder when using Vault:

When you are working with files in Autodesk Vault you need to have a working folder set up. The working folder houses your files while you are working on them (between checking files out of the vault and checking them back in to the Vault). The working folder can be a folder on your local machine or a folder on the network. Typically a system administrator will set up the working folder on the network.

NoteIf your system administrator has enforced a network working folder, you may receive a message notifying you of this. You will not need to set your working folder, though you may need to map the drive location that has been set up for your working folder. For further information, speak with your system administrator.
  1. In 3ds Max Design choose Server Login and login to the Vault.
    NoteMake sure the version of Vault that you want to work with is selected in the Autodesk Vault Version box.

  2. Choose Server Options.
  3. Browse to the folder that you want to use and click OK to confirm.

To coordinate local files with Vault files:

For optimal coordination between your files and those in the Vault, you need to maintain a one-to-one correspondence between the folder structure in the database and the structure in your working folder and its subdirectories.

Create a local folder structure for Vault files and then use Options to map the top of the local structure to the top of the Vault structure (i.e., Vault($)).

  1. Create a working folder on a local drive to contain all files to be coordinated with other users via the Vault. For example, you could call the working folder My_Vault.
  2. Open the Asset Tracking dialog and log in to the tracking database if necessary.
  3. On the Asset Tracking dialog, choose Server menu Options.
  4. On the Vault Options dialog, click the Change button and then use the Browse For Folder dialog to choose the folder you created in step 1.
    TipYou can also use the Browse For Folder dialog to create this folder.

    Now, when you open a file from the Vault, the folder structure in which the file resides in the Vault is replicated in your local folder, if necessary. Likewise, when you add a file to the Vault, the local structure is replicated in the Vault, if necessary. For example, if you open a character mesh from Vault($)\max_files\characters\ and the file uses a bitmap stored inVault($)\max_files\characters\face_maps\, the character mesh is stored locally in My_Vault\max_files\characters\ and the map file is stored locally in My_Vault\max_files\characters\face_maps\.

Interface

Menu bar

The menu bar provides access to most Asset Tracking functions. Most of the menu functions are also available from the right-click menu available in the dialog window.

NoteIf you highlight and then Ctrl+right-click one or more assets all of which reside in the same directory, a version of the Windows Explorer context menu opens. This lets you perform such functions as cutting or copying the file, or sending it to the desktop as a shortcut for easy access.

Server menu

Log in

Displays the Vault Log In dialog. Enter your user name, password, server name, and database, and then click OK. After entering a server name, you can click the ellipsis (...) button display all available databases and choose one from the dialog.

You can log in automatically in future sessions without having to use the Vault Log In dialog if you turn on “Use these settings next session.” This also turns on Options Log in using saved settings.

The login settings are stored in the file plugcfg\ATSVaultLogin.ini in the 3ds Max Design install folder.

Log out

Logs you out of the database.

Options

Opens the Vault Options dialog, where you can view the working folder and specify a new one (click the Change button). Available only when logged in.

ImportantThe working folder is a folder on your local drive that mirrors the top-level folder of the provider database structure. For further information, see this procedure.

You can log in automatically in future sessions, bypassing the Vault Log In dialog, if you turn on “Log in using saved settings.” This also turns on Vault Log In Use these settings next session.

Launch Provider

Opens the database client program. This is the same as running the client program from the Start menu. It doesn't necessarily open to the same database you're using in 3ds Max Design.

File menu

Most of the File menu commands are available only when you're logged in.

Checkout

Lets you check out the highlighted assets in the Asset Tracking dialog list of assets, if the assets are available for checking out. This opens a dialog that lets you confirm the checkout, specify whether to replace the local copies with the checked-out version, and enter a comment.

If you enter a comment, it's copied to the Working Comment dialog.

TipAlways be sure to check out an asset before modifying it, even if you have a writable version on a local drive. This prevents other users from modifying the file at the same time, and lets you maintain strict version control over the asset.
Checkin

Lets you check in the highlighted assets in the Asset Tracking dialog list of assets. This opens a dialog that lets you confirm the checkin, specify whether to keep the assets checked out, and enter a comment. Also, if the assets have been edited but not saved locally, you're prompted to save first.

Checking in an asset increments the current version number of the asset as stored in the database, and saves the current Comment text along with the asset.

Undo Checkout

Reverses a checkout, setting the highlighted assets' status to checked in, without saving any changes.

Add Files

Lets you add files in the scene, such as bitmaps used in materials, to the provider database. To add a file, load it (such as a scene file) or add it to the scene (such as a bitmap used in a material), highlight it in the Asset Tracking dialog, and then use Add Files.

You can add multiple files at the same time.

NoteYou cannot add a file that doesn't exist on a local drive, such as an unsaved scene file. Also, you cannot add a file that's not in the working folder, as specified via Options. For best results, before adding a file, make sure it exists in a local folder within a structure that mirrors the one in the Vault. For details, see this procedure.
Get Latest

Downloads the most recent (highest-numbered) version of the highlighted asset from the database. Use this when a teammate has updated an asset such as a bitmap.

History

Opens a History dialog from which you can get any version of the highlighted asset. When the dialog opens, highlight the version to get by clicking it and then click Get Version. You can also right-click the asset and choose Get Version from the context menu.

Properties

Opens a read-only dialog that shows information about the highlighted asset such as vault and local locations, versions, and check-out status.

Get From Provider

Lets you copy files from the database to the local working folder. Use the Get Files dialog to navigate to the folder from which to get files, highlight any number of files, and then click Open. The highlighted files and any dependent files, such as bitmaps and XRefs, are copied to the local folder, using the same folder hierarchy as that of the database.

Working Comment

Opens a dialog that containing a common text buffer for the current session.

When you check out a file, any comment you enter in the Asset Tracking dialog is copied to the Working Comment dialog. You can edit this text at any point during the session. When you check a file back in, all Working Comment text appears in the Asset Tracking dialog; you can edit it as necessary without affecting the original text before completing the check in. The checked-in comments remain with that version of the file in the Vault.

Browse

Lets you browse the local directories for missing files such as bitmaps. Use the Browse dialog to find the file, and then click Open.

View Image File

Opens a window showing the highlighted image file. The file must be present in a local directory.

Reveal In Explorer

Opens a Windows Explorer dialog showing the location of the highlighted asset.

Custom Dependencies

Opens a dialog that lets you specify files to be dependents of the current scene; files that aren't necessarily present in the current scene but should be associated with it. On the Custom Dependencies dialog, click the Add button and then use the Add Custom Dependencies file browser to open dependent files.

The Custom Dependencies function lets you associate files that aren’t true scene dependencies. A true dependent file is required for rendering, animation, exporting, and so on. A custom dependency might be reference art work, a text file with scene documentation or tasks to accomplish, custom scripts, and so on. Basically, any collection of files that should “travel along” with the scene.

One potential use for a custom dependency is as a way to perform simple project management. For example, you could add a file called GameTitle-A.txt as a custom dependency to any scene file associated with GameTitle-A. You could then instruct the provider client, such as Vault Explorer, to display all files that are dependent on GameTitle-A.txt, which would give you a list of files associated with that project.

Refresh

Reloads the asset listing from the local scene and updates the window contents.

Paths menu

The tools on this menu help you resolve file-path issues such as missing files. They include functionality also available in the Bitmap/Photometric Path Editor Utility, but their integration into the Asset Tracking dialog helps speed the workflow of managing scene assets.

Highlight Editable Assets

Highlights all assets whose paths can be affected by the remaining commands on this menu.

For example, if your scene materials use bitmaps from a number of different folders, you could copy all the bitmaps to a common directory within your working folder, use Highlight Editable Assets to highlight all the bitmap assets, and then use Set Path (see following) to designate the common directory.

Set Path

Opens a dialog for editing the scene's record of the highlighted asset's or assets' path and, in the case of a single asset, the file name. Both versions of the dialog include drop-down history lists for reverting to a previous path or file name.

The primary function for this command is to change the path pointed to by 3ds Max Design for existing assets whose locations have changed. However, for output files such as rendered images and render elements, you can also use Set Path to create and use new output directories. If you change an output path to one that doesn't exist, you're prompted to confirm that you want to create the folder(s). if you confirm, the output paths are changed in all appropriate locations, such as the Render Setup dialog.

The version of the dialog that appears depends on the number of highlighted assets:

  • If a single asset is highlighted, you can change the path and the file name. The following dialog appears.

    To change the path, edit the Path field or use the ellipsis [...] button to browse for a new path. This changes the path only.

    To revert to a previous path, choose it from the drop-down list.

    To change the file name, edit the File field or choose a name from the drop-down history list. Note that this changes only the name of the asset file as pointed to in the scene; it doesn't change the actual asset file name. Use this to update the scene if the asset file name has changed.

  • If multiple assets are highlighted, you can change the path but not file names. The following dialog appears.

    The dialog shows the portion of the current path that the highlighted assets and lets you specify a new one, either by editing the Specify Path field contents or by clicking the ellipsis [...] button and browsing to a different path.

    For example, if two assets are highlighted, and one asset's path is c:\max_files\maps1\ while the other's is c:\max_files\maps2\, the Specify Path field will show c:\max_files\. Changing this changes the complete path for all highlighted assets. Of course, they must all be present there for Asset Tracking to find them.

    To revert to a previous path, choose it from the drop-down list.

    To change only the portion of the path that all highlighted assets have in common, use Retarget Common Root (see following).

Retarget Common Root

Lets you change only the part of the path that all highlighted assets have in common. This command opens a version of the Specify Assets path dialog that shows the common path prefix for the highlighted assets and lets you specify a new one, either by editing the Specify New Common Path Prefix field contents or by clicking the ellipsis [...] button and browsing to a different path. Use Retarget Common Root for repathing multiple files, particularly those in different directories within the common root.

For example, if all maps were originally in various subdirectories within c:\maps\ and the entire subdirectory structure was moved to d:\resources\maps\, you could repath all files simultaneously using Retarget Common Root.

To revert to a previous path, choose it from the drop-down list.

If you change the common root for output files to a path that doesn't exist, you're prompted to confirm that you want to create the folder(s). if you confirm, the output paths are changed in all appropriate locations, such as the Render Setup dialog.

Strip Path

Strips all path information from the highlighted assets, leaving only the file names.

Stripped path information is saved in the Set Paths dialog drop-down list. To restore stripped paths, highlight the assets, choose Paths menu Set Paths, and then choose the desired path to restore from the drop-down list.

Make Path Absolute

Gives the complete path of the found asset file. This is useful when a relative path is displayed and you want to see the entire path.

Make Path Relative to Project Folder

This takes the current path of the found asset file and makes it relative to your project folder.

Resolve Path to UNC Location

Resolves highlighted paths that point to mapped drives to Universal Naming Convention (UNC) format.

Set Project Folder
Configure User Paths

Opens the Configure User Paths dialog, which you can use to resolve locations for support files such as bitmaps.

NoteThis option makes it simple to share files between different users, even if you are not using the same project folder. If user A loads a file from user B and they do not have the same project folder, this will not be a problem.
Preferences

Use this submenu to toggle these options:

  • Convert file paths to UNCWhen on, paths shown in the Asset Tracking dialog for any added assets present on a mapped drive use Universal Naming Convention (UNC) format. When off, each path starts with the mapped drive letter (e.g., w:\).

    This switch is linked to the Convert file paths to UNC switch on the Preferences dialog Files panel. Toggling either one toggles both.

    NoteThis switch affects only newly added paths. Toggling it has no effect on existing paths. For example, if you add an asset from a mapped drive with the switch on, turning it off does not change the path to the mapped version.
  • Convert local file paths to RelativeWhen on, converts the file paths of all newly added assets in a scene so that they are relative to the project folder. Default=off.

    This switch is linked to the Convert local paths to Relative switch on the Preferences dialog Files panel. Toggling either one toggles both.

Bitmap Performance And Memory menu

The Proxy system lets you determine how 3ds Max Design should create and use proxy versions of bitmaps incorporated in materials. Proxies are intended for use primarily in the viewports when building and editing scenes to reduce the amount of memory required by the bitmapped textures, but you can also use them at render time. This menu also gives you control over bitmap paging.

Enable Proxy System

Toggles the Proxy system globally. When on, 3ds Max Design replaces all bitmaps used in materials with proxies as specified on the Bitmap Proxies dialog. When off, the original bitmaps are used.

Enable Bitmap paging

When on, enables bitmap paging for large texture maps and large rendered output. Default=on.

This toggle is a shortcut to the Page Large Images To Disk option on the Bitmap Proxies dialog.

Global Settings
Set Proxy Resolution

Opens the Per-Bitmap version of the Bitmap Proxies dialog for setting the resolution for proxies of only those bitmap assets highlighted in the Asset Tracking dialog. Available only when one or more bitmap assets are highlighted.

Generate Selected/Stale Proxies

Generates the proxy image files as specified. When one or more image assets are highlighted in the Asset Tracking dialog list, the command is Generate Selected Proxies, and applies only to those assets. When no asset is highlighted, the command is Generate Stale Proxies, and applies to all assets whose settings, such as proxy resolution, have changed since the previous generation, as well as any assets whose proxies are missing.

Options menu

Disable Asset Tracking

Turns off asset-tracking functionality. Choosing this command logs you out of the database and makes most asset-tracking functions unavailable. To restore asset tracking, turn off Disable Asset Tracking and then log back in.

Prompts

Opens the Prompts dialog, which lets you toggle two different options for each of various actions in the Asset Tracking dialog: actions and prompts.

Auto Login

Logs you in to the Vault, if necessary, whenever you cause a MAX scene file to be present in memory; for example when you load or save a scene. You can bypass the Vault Log In dialog If you've turned on Options dialog Log in using saved settings or Vault Log In Use these settings next session.

Display Excluded Files

Displays files that are set to Excluded status. When off, these files aren't shown in the dialog window. For information about excluding files, see Filtering Files. You can also set output files to Excluded status; see following.

Exclude Output Files

Sets output files such as rendered images to Excluded status; you can prevent the dialog from displaying such files by turning off Display Excluded Files (see preceding).

Tree View

Displays a simplified, hierarchical listing of the assets in the current scene. You can expand and collapse hierarchy branches by clicking the + and - icons to the left of the branch names.

Table View

Displays listing of the assets in the current scene in tabular format along with the full path and for the local version of each asset. The branches are hierarchical, but cannot be expanded or collapsed.

Toolbar

Refresh

Reloads the asset listing from the local scene and updates the window contents.

Status Log

Opens a read-only window showing all status messages received from the Vault during the current session.

Tree View

Displays a simplified, hierarchical listing of the assets in the current scene without path or status information. You can expand and collapse hierarchy branches by clicking the + and - icons to the left of the branch names.

Table View

Displays listing of the assets in the current scene in tabular format along with the full path and status for the local version of each asset. The branches are hierarchical, but cannot be expanded or collapsed.

Folders

[folders]

If the system administrator created files folders in Autodesk Vault, they appear in the Asset Tracking dialog and help you maintain organization of files.

[library folders]

If your system administrator set library folders up in Autodesk Vault, they appear in the Asset Tracking dialog. The system administrator sets these folders up on the network and they can act as multiple network workspaces for a team. Your team can use them to organize different types of files. For example, you may have a library folder for materials, for maps, for animations, and so on. Since these library folders are stored on the network, files that are shared between team members can reside on the network at all times, rather than on a user's local workspace. Library folders can also be used to protect files because the system administrator can set up read/write permissions so that only certain users can make changes to files. See your system administrator for further details.

NoteA regular folder looks the same as a library folder from the Asset Tracking dialog. Different icons distinguish the two types of folders inside Autodesk Vault.

[window]

Left: Asset Tracking dialog window in Tree View

Rightt: Asset Tracking dialog window in Table View

The Asset Tracking dialog window lists all assets in the current scene in a tree or table view, depending on the current setting. Listed assets include the scene file, any images used by the scene in materials, and so on, XRefs, and photometric files. By default, output files such as rendered images also appear in the window listing; you can turn off display of these if you wish.

Also shown are icons for each assets showing the type of asset (3ds Max Design scene file, map branch, and so on) and status, as appropriate. Most status icons are documented in the Vault Explorer Help Autodesk Vault Explorer Icon Reference topic. For a reference to the most common icons, see Asset Tracking Dialog Icons.

NoteNo status icons appear if you don't have any version-control provider installed.

In general, status errors can be resolved by being careful to coordinate the local folder/file structure with that of the Vault, as described in the above procedure.

You can access most dialog commands by right-clicking an asset in the window; the commands applicable to the asset are available in the context menu. These commands are the same as those documented above.