Schematic View Menus
 
 
 
Bottom of the Page

Menu bar Graph Editors menu New Schematic View Menu bar

Menu bar Graph Editors menu Saved Schematic Views Choose a saved schematic view. Menu bar

Main toolbar (Schematic View) Menu bar

Schematic View has several menus, which appear on the menu bar of the Schematic View window.

Edit menu

Connect

Activates the connect tool. The connect tool in Schematic View can be used to create any relationship or constraint, are can be used to assign modifiers.

Unlink Selected

Disconnects the selected entities.

Delete

Removes entities from Schematic View and from the scene. Disconnects selected relationships.

Assign Controller

Lets you assign controllers to transform nodes. Only available when controller entities are selected. Opens the standard assign controller dialog.

Wire Parameters

Lets you wire parameters using Schematic View. This is active only when entities are selected. This launches the standard Wire Parameters dialog.

Object Properties

Displays the Object Properties dialog for the selected nodes. Has no effect when no node is selected.

Select menu

Select Tool

Activates the Select tool when in Always Arrange mode and Select and Move tool when not.

Select All

Selects all entities in the current Schematic View.

Select None

Deselects all entities in the current Schematic View.

Select Invert

Deselects selected entities and selects unselected entities in the current Schematic View.

Select Children

Selects all children of currently selected entities.

Deselect Children

Deselects children of all selected entities. Parent and child must be selected for child to become unselected.

Select to Scene

Selects in viewport all nodes that are selected in Schematic View.

Select from Scene

Selects in Schematic View all nodes that are selected in viewport.

Sync Selection

When on, selecting objects in Schematic View also selects them in the viewport, and vice-versa.

List Views menu

See Schematic View List Views.

Layout menu

Align

Lets you define the following alignment options for selected entities in the Schematic View window:

  • LeftAligns selected entities to the left edge of the selection, leaving vertical positioning intact.
  • RightAligns selected entities to the right edge of the selection, leaving vertical positioning intact.
  • TopAligns selected entities to the top edge of the selection, leaving horizontal positioning intact.
  • BottomAligns selected entities to the bottom edge of the selection, leaving horizontal positioning intact.
  • Center HorizontalAligns selected entities to the horizontal center of the selection, leaving vertical positioning intact.
  • Center VerticalAligns selected entities to the vertical center of the selection, leaving horizontal positioning intact.
Arrange Children

Arranges the display of children based on set arrangement rules (align options) below the selected parent.

Arrange Selected

Arranges the display of children based on set arrangement rules (align options) below the selected parent.

Free Selected

Frees all selected entities from arrangement rules, tags them with a hole icon on their left end and leaves them in place. Use this to freely arrange selected objects.

Free All

Frees all entities from arrangement rules, tags them with a hole icon on their left end and leaves them in place. Use this to freely arrange all objects.

Shrink Selected

Hides all selected entities’ boxes, keeping arrangement and relationships visible.

UnShrink Selected

Makes all selected shrunk entities visible.

UnShrink All

Makes all shrunk entities visible.

Toggle Shrink

When on, shrinking entities works normally. When off, shrunk entities are fully visible, but not unshrunk. Default=on.

Options Menu

Always Arrange

Causes Schematic View always to arrange all entities based on the chosen arrangement preference. Displays a pop-up warning before doing so. Choosing this activates the toolbar button.

Hierarchy Mode

Sets Schematic View to display entities as a hierarchy instead of reference graph. Children appear indented below the parent. Switching between Hierarchy and Reference mode is nondestructive.

Reference Mode

Sets Schematic View to display entities as a reference graph instead of hierarchy. Switching between Hierarchy and Reference mode is nondestructive.

Move Children

Sets Schematic View to move all children of parent being moved. When this mode is on, the toolbar button is activated.

Preferences

Opens the Schematic View Preferences Dialog, which lets you control what displays in the window by filtering for categories and setting display options.

Display menu

Display Floater

Displays or hides the Display Floater which controls what is displayed in the Schematic View window.

Hide Selected

Performs the action of hiding whatever is selected in the Schematic View window.

Unhide All

Reveals any hidden items.

Expand Selected

Displays all child entities of selected entity.

Collapse Selected

Hides all children of selected entity, leaving the selected entity visible.

View Menu

Pan

Activates the Pan tool, which lets you move horizontally and vertically in the window by dragging the mouse.

Pan to Selected

Centers selected entities in the window. If no entity is selected, centers all entities in the window.

Zoom

Activates the zoom tool. Lets you move closer to or further from the Schematic display by dragging the mouse.

Zoom Region

Lets you zoom to a specific area by dragging a rectangle in the window.

Zoom Extents

Zooms the window so all the nodes in the Schematic View are visible.

Zoom Extents Selected

Zooms the window so that all selected nodes are visible in the display.

Show Grid

Displays a grid in the background of the Schematic View window. Default=on.

Show Background

Displays an image in the background of the Schematic View window. Set the image via Preferences.

Refresh View

Redraws the contents of the Schematic View window with all changes made to it or with changes made in the scene.