Quads Panel
 
 
 
Bottom of the Page

Customize menu Customize User Interface Quads tab

The Quads panel lets you customize the quad menus. You can create your own quad menu sets, or you can edit existing sets. In the Quads panel, you can customize menu labels, functionality, layout, and shortcuts. The advanced quad menu options let you modify the color and behavior of the quad menu system. You can also save and load custom menu sets.

See Also

Procedures

To create a quad set:

  1. Choose Customize menu Customize User Interface Quads tab.
  2. Click New.

    The New Quad Set dialog appears.

  3. Enter the name of the quad set and click OK.

    The new set appears in the Quad set list.

To add a command to a quad set:

  1. Choose Customize menu Customize User Interface Quads tab.
  2. Choose the quad set you want to edit from the upper-right drop-down list.

    If you want to change the name of the quad set, click Rename and enter a new name in the Rename Quad Set dialog.

  3. Select the quadrant where you want to place the command.

    You can edit the name of the quadrant by changing the text in the Label area.

  4. Choose the appropriate Group and Category from the respective drop-down lists.
  5. Choose a command from the action list and drag it into the Quad Menu window.

    Use the same procedure to add menus and separators to your quad set.

To delete a quad set:

NoteYou cannot delete any of the default quad sets.
  1. Choose Customize menu Customize User Interface Quads tab.
  2. Choose the quad set you want to delete from the upper-right drop-down list.
  3. Click Delete.

To remove a command from a quad set:

  1. Choose Customize menu Customize User Interface Quads tab.
  2. Choose the quad set you want to edit from the upper-right drop-down list.
  3. Choose the command you want to remove.
  4. Click the Delete button.

    Use the same procedure to remove menus and separators from your quad set.

To move a command in a quad set:

Interface

Group

Displays a drop-down list that lets you select the context you want to customize, such as Main UI, Track View, Material Editor, and so on.

Category

Displays a drop-down list of the available categories of user interface actions for the selected context.

Action list

Displays all the available actions for the selected group and category. To add an action to a specific quad set, select it and drag it to the quad menu window on the right side of this dialog. Right-click an action in this window to edit the macro script that defines the action (if there is one).

Separator list

Displays a separator line that you can use to separate groups of menu items in a quadrant. To add a separator line to a specific quad set, select it and drag it to the quad menu window on the right side of this dialog.

Menus list

Displays the names of all 3ds Max Design menus. To add a menu to a specific quad set, select it and drag it to the quad menu window on the right side of this dialog. Right-click a menu in this window to delete the menu, rename it, or create a new, empty menu.

Quad set list

Displays the available quad sets.

Additional quad menus appear in this list. They can be edited, renamed, and reorganized; however, they cannot be deleted.

New

Opens the New Quad Set dialog. Enter the name of the quad set you want to create and click OK. The new quad set appears in the Quad set list.

Delete

Deletes the item displayed in the Quad set list. Available only for user-generated quad sets.

Rename

Opens the Rename Quad Set dialog. To activate the Rename button, choose a quad set from the list. To change the name, click Rename, edit the name of the quad set, and then click OK.

Quad Shortcut

Allows you to define a keyboard shortcut for displaying the quad set. Enter the shortcut and click Assign to make the change.

Show All Quads

When on, a viewport right-click shows all four quad menus. When off, a viewport right-click shows only one quad at a time.

Label

Displays the label for the highlighted quadrant (shown in yellow to the left of the Label).

Quad Menu Window

Displays the menu options for the currently selected quad menu and quad set. To add menus and commands, drag options from the Action and Menus windows to this window.

Items included in the quad menu are displayed only when they are available. For example, if your quad menu contains Track View Selected, the command will display only if a selection exists when you open the quad menu. if none of the commands are available when you open the quad menu, the quadrant does not appear.

When you right-click an item in the quad menu window, several actions become available:

Delete Menu Item

Removes the highlighted action, separator, or menu from the quad menu.

Edit Menu Item Name

Opens the Edit Menu Item Name dialog. To edit the name, the Customize Name check box must be on. Enter the desired name in the name text field and click OK. The item name is changed in the quad menu, but not in the quad menu window.

Flatten Sub-Menu

Displays contents of selected submenu on top level of quad. If you choose this item, the menu name is followed by the string: [FLAT].

Edit MacroScript

Opens the macro script for the selected action in a MAXScript editor window.

Advanced Options
Load

Displays the Load Menu File dialog. Allows you to load custom menu files into your scene.

Save

Displays the Save Menu File As dialog. Allows you to save changes to the quad menus in a MNU file.

Reset

Restores the default setup (defaultui.mnu).