Overview of Bringing In Data

 
 
 

A map file in AutoCAD Map 3D is a specialized drawing (DWG) file in which you can combine data from many sources. A map file holds all the information required to create, edit, view, and publish your map, including the following:

AutoCAD Map 3D is your window onto all this data. You have two ways to access data: you can connect to drawing files, geospatial files, or other data sources and view and edit entities in their original sources, saving your changes in the native format; or you can convert the data to DWG format, breaking any connection to the original source.

To do this... Use this method... To get this result...
Edit features from the following sources in their native format:
  1. In Display Manager, click DataConnect To Data.
  2. Select the data source and feature classes.
All features in the selected feature class appear in the map. Any edits you make are saved back to the original source.
Use formats that are not listed in the Data Connect window If you use a provider to connect to the data, you can edit it directly in its native format. If you convert and import it, you edit a copy of the data in DWG format.
Join attribute data to features from Oracle, SDF, etc.
  1. Connect to the source of attribute data (for example, connect to an ODBC source such as a Microsoft Access table) from the Task Pane. Click DataConnect To Data.
  2. Right-click a layer and click Create A Join.
  3. Specify the connected attribute data source.
Both the original data for the feature layer and the joined data appear in the Data Table.
Add DWG objects from the current drawing
  1. In Display Manager, click DataAdd Drawing DataQuery Current Drawing.
  2. Define a query to retrieve objects.
Only the objects that match your query are added to the map.
Add drawing objects from other drawings
  1. Attach the drawings to the current drawing..
  2. In Display Manager, click DataAdd Drawing DataQuery Source Drawing.
  3. Define a query to retrieve objects. See Accessing Drawing Objects.
Only the objects that match your query are added to the map. When you edit the objects, you can choose to update the original drawings or not.
Convert geospatial data to drawing data
  • Click Insert tabImport panelMap Import .
A copy of the data is added to the map in DWG format. The connection to the original source is broken, and changes are not saved back to that source.
Convert SDF files to drawing data
  • Click Insert tabImport panelMap Import . Use this method for the current version of SDF. See Overview of Importing.
  • In the Planning And Analysis workspace, click Insert tab Import panel SDF2. Use this method for the version supported by MapGuide 6.5 and earlier. See Importing Maps from SDF 2.
A copy of the data is added to the map in DWG format. The connection to the original source is broken, and changes are not saved back to that source.
Add attribute data to use with drawing objects
  1. Add the data source to the map. See Setting Up Data Sources for Drawings.
  2. Define a link template for the data. See Creating a Link Template.
  3. Link records to drawing objects. See Manually Linking Database Records to Objects.
You can view or edit the data by double-clicking the table name in Map Explorer.
Add raster images in the following formats:

DEM, ESRI Grid, DTED, JPEG and JPEG2K , PNG, MrSID, TIFF, ECW

  1. In Display Manager, click DataConnect To Data.
  2. Specify the folder that contains the raster and select the raster.
The image appears in your map, where you can style it or move it behind other features.
Add raster images in other formats
  1. Click Home tabData panelInsert An Image.At the Command prompt, enter mapiinsert.
  2. Select the image and specify the image placement and settings.
The image appears in your map, where you can clip it or change its transparency, brightness and other settings.
Connect to data from Civil 3D
  1. From Civil 3D, export feature data (such as parcels and alignments) in SDF format and save surfaces in DEM format.
  2. Connect to the resulting files in AutoCAD Map 3D.
The data appears in your map like any other SDF or DEM data.
Add survey data

The survey points appear in your map and are stored in a new survey data store.

See Also