To switch between Tool-based, Task-based, and Map Classic workspaces
Concept Procedure Quick Reference
 
 
 

To create a new workspace

  1. In the Tool-based Ribbon Workspace, click Tools tab Customization panel User Interface.
  2. In the Customize User Interface dialog box, under Customizations In All CUI FILES, right-click the Workspaces node and select New Workspace, or right-click an existing workspace and select duplicate.
  3. Select the new workspace.
  4. Under Workspace Contents, click Customize Workspace.
  5. In the Customizations In All CUI Files tree, check the items you want to include.
  6. Click Done.
  7. Click OK.

To add ribbon, menu, and toolbar options

  1. In the Customize User Interface dialog box, under Customizations In All CUI Files, select the workspace you want to modify.
  2. Under Customizations In All CUI Files, expand the item you want to customize so that you can see all the items underneath it.

    For example, expand the Topology menu to see the topology options underneath.

  3. Under Command List, click and drag the tool you want to include to the item in Customizations In All CUI Files.
  4. Click Apply.
  5. Click OK.

To add entire ribbon tabs, menus, or toolbars to a workspace

  1. In the Customize User Interface dialog box, under Customizations In All CUI Files, select the workspace you want to modify.
  2. Under Workspace Contents, click Customize Workspace.
  3. In the Customizations In All CUI Files tree, check the items you want to include.
  4. Click Done.
  5. Click OK.

To switch between Tool-based, Task-based, and Map Classic workspaces

  1. Click the Workspace Switching button in the bottom-right corner of the application window.

    A floating toolbar opens with all workspace options available. You can either dock this toolbar, leave it floating or close it.

  2. In the toolbar, use the drop-down list to select the workspace you want. Unless you specify otherwise, AutoCAD Map 3D opens with the Tool-based workspace.

For more information, see Workspaces.

To restore the default colors

  1. Click Options.
  2. In the Options dialog box, click the Display tab, and then click Colors.
  3. In the Color Options dialog box, select the element you want to change by clicking the images for the Model tab or Layout tabs.

    As you click areas of the images, the selection is displayed in the Window Element list. You can also change an attribute by selecting it from the Window Element list. For example, for the Map background, select Model Tab Background.

  4. From the Color list, click Select Color.
  5. In the Select Color dialog box, click the Color Books tab, and then select AutoCAD Map 3D Colors from the Color Book list.

    The AutoCAD Map 3D color book displays the default colors used in the application. You can select a color or use the color book as a reference. It does do not control the defaults in the application; do not attempt to modify it.

  6. Select a color by clicking a color chip.

    For example, click the blue Map Background chip to use the new map background color (model tab).

  7. Click OK.
  8. In the Color Options dialog box, click Apply and Close to record the current option settings in the system registry and close the dialog box.
  9. In the Options dialog box, click OK.

To show the command line interface for a particular workspace

  1. In the Tool-based Ribbon Workspace, click Tools tab Customization panel User Interface.
  2. In the Customize User Interface dialog box, select a workspace.
  3. In the Workspace Contents area, expand Palettes, scroll to the bottom of the list, and then click Command Line.
  4. In the Properties area under Appearance, click Show, and then select Yes from the drop-down list.
  5. Under Workspace Contents, click the Customize Workspace button.
  6. Click OK.

To hide the map status bar

  1. At the Command prompt, enter mapstatusbar.
  2. Enter hide.

To enable Update Edits Automatically by default

  1. At the Command prompt, enter mapeditsetautodefault
  2. Enter active.

To disable connection pooling by default

  1. At the Command prompt, enter mapconnectionpooling.
  2. Enter deactive.

To turn file selection dialog boxes on or off

NoteIf you use scripts to automate some AutoCAD Map 3D functions, you may find it useful to turn off dialog boxes .
  1. At the Command prompt, enter filedia.
  2. To turn on dialog boxes , enter 1. To turn off dialog boxes , enter 0.

To turn other dialog boxes on or off

  1. At the Command prompt, enter cmddia.
  2. To turn on dialog boxes , enter 1. To turn off dialog boxes , enter 0.