Export dialog box
 
 
 

Use this dialog box to select the drawing objects to export, and specify export options. You cannot export feature data.

To export drawing objects to other file formats

In the Tool-based Ribbon Workspace, click Output tabMap Data Transfer panelMap 3D Export.

If you have previously saved your settings in this dialog box, click Load to reload those settings. To save the current settings for use later or to use in a script, click Save.

The dialog box has the following tabs:

If you export to SDF, Oracle, or ArcSDE, the Export dialog box substitutes Feature Class Tab for the Data Tab.

Selection Tab

Specify the objects to export.

Object Type

For some formats, select the object type to export. Objects of other types are filtered out of the export. To export the other object types, run Export again. Some objects may be exported as more than one type.

Select Objects To Export

Select the objects to export.

Select All

Select all objects.

Select Manually

Individually select the objects to export. To modify the selection set, click Select Objects or Quick Select .

Filter Selection area

Filter the selected objects based on layer or object class. Enter the names of the layers or object classes to include, or click the button to select from a list. Objects that are not on the selected layers and in the selected object classes are filtered out of the export. The status line shows how many objects are selected and how many have been filtered out.

Select Polygon Topology To Export

Name

Select the polygon topology to convert to polygon objects and export. These objects are in addition to any objects selected above.

Group Complex Polygons

Group nested polygons into a single balanced polygon. Each nested polygon must have a centroid.

If you do not select this option, AutoCAD Map 3D will create separate polygons, one for each centroid.

Preview Filtered Selection

See which objects will be exported. Objects that will be exported are highlighted. To leave the preview and return to this dialog, press ESC.

Feature Class Tab

Choose a method for organizing the selected drawing objects into logical feature classes.

DWG to Feature Class Mapping

Specify how DWG objects map to FDO feature classes.

Create A Single Class From All Selected Objects

Create a single FDO feature class for all selected DWG objects. This is the default selection.

Create Multiple Classes Based On A Drawing Object

Create multiple feature classes based on a drawing object. Select the drawing object on which to base the feature classes from the Drawing Object To Use list.

Select Attributes

Select specific attributes to export. You can select attributes for both single-class and multiclass export operations. For multiclass export operations, these attributes will be added to every feature class.

Drawing Object

Select the drawing objects to export.

Feature Class

The feature class to which you are exporting your data. If you are exporting to an existing FDO data store, use the drop-down list to map your data to existing fields. Existing feature classes are in blue text. You can map more than one drawing object to a single feature class.

To map drawing properties to feature class properties, click in the Feature Class field.

Geometry

Select the geometry data to export for each drawing property. Click in the appropriate field, then click the down arrow. For pre-existing classes, this field displays the geometry type already associated with that class.

Show Schema Names

Display the schemas of the feature class to which you are mapping your data.

Data Tab

Data

To include data with the exported objects, select the data fields to export. The selected fields appear in the table. You can also enter an expression.

NoteIf you are exporting to SHP format using object classification to create feature classes, you may not want to specify attributes here, as all feature classes will then receive all attributes you check on this tab. If you don’t select attributes here, properties for those feature classes are defined by the original object classes.
Select Attributes

Select properties, object properties, topology information, object class information, or fields from link template data, object data, or block attributes.

Tip To export only key values, select the fields in the Link Templates section. Since the key values are stored in the drawing as link data, selecting only key fields improves performance.

In the list of attributes, Object Data is map-specific and includes the attributes of any objects in the map that have object data tables associated with them. Object Properties are the properties of each entity type. These are the same attributes that appear in the Properties palette. Properties are attributes that apply to every DWG object in the map.

Source Field

Lists the data you selected to export. Click Select Attributes to select additional data, or enter an expression.

Output Field

Enter a name for the field in the output file for the associated field. Output field names can use any alpha-numeric character and the underscore symbol ("_").

Create Unique Key Field

Create a unique value for each exported object. You can specify a name for this field.

The unique ID numbers increment within a single AutoCAD Map 3D session, but restart when you restart AutoCAD Map 3D. To extend the unique key across multiple files you are exporting, export all the files in the same AutoCAD Map 3D session.

Options Tab

Coordinate Conversion

To convert the exported objects to a different coordinate system, check Convert Coordinates To. Enter the coordinate system code for the export file or click to select one from a list.

If the conversion controls are not available, there is no coordinate system assigned to your current drawing. Click Cancel, assign a coordinate system to the current drawing, and re-run Export.

Other

The options that appear in this section depend on your choice of export format.

Treat Closed Polylines as Polygons

Export closed polylines as polygons. If this check box is not selected, only polygon objects will be exported as polygons.

Note If you export a polygon topology that includes closed polylines and those closed polylines are part of the selection set, selecting this check box may create duplicate polygons in the exported file.
Additional Settings

The Options tab may include more settings for the format you chose. For some formats, the Driver Options button is also available.

For information about the options for a particular format, see Supported Import Formats.

Additional Notes