Bringing In Features from ArcSDE
Concept Procedure Quick Reference
 
 
 

When you view and edit features from an ArcSDE data source, you can do the following:

Supported Versions

AutoCAD Map 3D supports ArcSDE 9.1 and 9.2. To use ArcSDE, install the following DLL files on the computer on which you run AutoCAD Map 3D:

For version 9.1 For version 9.2
pe91.dll pe.dll
sde91.dll sde.dll
sg91.dll sg.dll

The provider for this data store checks for the 9.2 versions of the DLL files first, and uses them if they are found. If the 9.2 versions are not found, it checks for (and uses) the 9.1 versions. The client DLL version should match the server version that is being used.

If the client and server versions of ArcSDE do not match (for example if you use the 9.1 client and you access the ArcSDE 9.2 server), set up your system for the server version you are using.

Set up the services and hosts files for the appropriate version, and then use these names when you connect to the data in the Data Connect dialog box. For example, specify arcsdehost\esri_sde_nv, and not the values. Setup instructions are on the Procedure tab of this topic.

The PATH environment variable must reference the local folder containing these DLL files. To accomplish this, you can install an ArcGIS 9.1 Desktop application or the ArcSDE SDK. For more information about ArcGIS 9.1 Desktop applications and the ArcSDE SDK, refer to the ESRI documentation.

Note For information on customizing this provider, refer to the FDO API Reference and the FDO Provider for ArcSDE API Reference.
See Also