Overview of Setting Up
 
 
 

You can customize AutoCAD Map 3D and set up each map file you create to make your work easier and more productive.

The following tables summarize your setup options on a product-wide and map-wide basis.

On a product-wide level... Use this method... To get this result...
Set up user access.

Click Map Setup tabMap panel User Administration. At the Command prompt, enter mapuseradmin.

The system administrator assigns login names and passwords to users, and specifies what each user can do within the product.

See Setting Up Users and Assigning Rights.

Set up your workspace. In the Tool-based Ribbon Workspace, click Tools tab Customization panel User Interface. Customize the ribbons, menus, toolbars, and dockable windows.

See Customizing Your Work Environment.

Create new coordinate systems. Click Map Setup tabCoordinate System panelDefine Global Coordinate System. At the Command prompt, enter ADEDEFCRDSYS. Create a new coordinate system or use a predefined coordinate system as a basis for creating your own.

See Defining Coordinate Systems.

Set up object classification.
  1. Select a sample object for the object class.
  2. Attach an object definition file.
  3. On the Map Explorer tab of the Task Pane, right-click Object Classes. Click Define Object Class.
Define a set of standard objects for your organization so that new objects of that type use the properties you defined.

See Overview of Setting Up Object Classification.

Set up for digitizing
  1. Configure the digitizer in the AutoCAD Options dialog box.
  2. Register the map using the TABLET command.
  3. Set digitizing specifications in the Digitize Setup dialog box.
  4. Use the MAPDIGITIZE command to digitize the objects.
Convert paper-based graphical information into a digital format using drawing commands to trace data from the paper map into a DWG file.

See Setting Up for Digitizing and Overview of Digitizing Objects.

Set default values and settings. In the Tool-based Ribbon Workspace, click Map Setup tabMap panelangle-arrow. Change settings that affect the work environment, how the program starts up, whether users must log in, and settings for your current drawings, data sources, and more.

See Setting Options.

Set options related to images you added with Raster Extension. In the Tool-based Ribbon Workspace, click Insert tabImage panelangle-arrow. Changes settings related to the Raster Extension, such as where image-related files are stored, how images display in maps, and memory usage options. These options do not affect images you added with Data Connect.

Setting Raster Image Options

Customize and automate import and export operations. Edit the mapexport.ini file using a text editor such as WordPad. Modify the .ini files that specify import and export settings.

See Customizing the Import and Export .ini Files.

On a map-wide basis... Use this method... To get this result...
Assign a coordinate system. Click Map Setup tabCoordinate System panelAssign. At the Command prompt, enter ADESETCRDSYS. Specify the coordinate system used for attached drawings and for the current drawing.

See Assigning Coordinate Systems

Attach drawings. Drag the drawing file from Windows Explorer to the Map Explorer tab of the Task Pane. Work with objects from other drawings by attaching those drawings to the current map and querying in the objects.

See Overview of Attaching Drawings

Modify the settings for attached drawings. At the Command prompt, enter adedrawings. Specify how attached drawings work with the current drawing and view information about attached drawings.

See Modifying Attached Drawing Settings.

Set up queries.
  1. To save the current query, click Home tabData panelDefine Query. To save the current query, at the Command prompt, enter adequery.
  2. To run a saved query, click Create tabObject Query panelRun. To run a saved query, at the Command prompt, enter aderunquery.
Save and reuse queries in a library.

See Overview of Using the Query Library.

Define annotation templates. Click Annotate tabMap Annotation panelDefine Template. At the Command prompt, enter mapanntemplate. Define the information to display in an annotation and the layout of that information. Then you can insert instances of the annotation into your drawing.

See Defining Annotation Templates

Set up object data. Click Map Setup tabAttribute Data panelDefine Object Data. At the Command prompt, enter adedefdata. Create tables with fields for text and numerical information. Attach records from the table to objects.

See Creating an Object Data Table.

Set up data sources for drawings. Drag the database file from Windows Explorer to the Map Explorer tab of the Task Pane. Attach a database to your map and link records from that table to objects in your map.

See Attaching a Data Source.