Keyword(s) for which to search:
Sort results by title
Keyword Index
Direct Link
Autodesk.Civil Namespace
AccelerationUnitType Enumeration
AlignmentDesignCheck Class
AlignmentDesignCheck Members
AlignmentDesignCheck Properties
DesignCheckType Property
AlignmentDesignCheckCollection Class
AlignmentDesignCheckCollection Members
AlignmentDesignCheckCollection Methods
Add Method
Clear Method
Remove Method
RemoveAt Method
AlignmentDesignCheckCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
AlignmentDesignCheckRoot Class
AlignmentDesignCheckRoot Members
AlignmentDesignCheckRoot Constructor
AlignmentDesignCheckRoot Properties
CurveDesignChecks Property
LineDesignChecks Property
SpiralDesignChecks Property
SuperelevationDesignChecks Property
TangentIntersectionDesignChecks Property
AlignmentDesignCheckType Enumeration
AlignmentDividedPivotType Enumeration
AlignmentLockModeType Enumeration
AlignmentMedianTreatmentType Enumeration
AlignmentPointType Enumeration
AlignmentTransitionSegmentType Enumeration
AlignmentUndividedPivotType Enumeration
AlignmentUpdateModeType Enumeration
AnchorLocationType Enumeration
AnchorPointType Enumeration
AngleFormatType Enumeration
AngleUnitType Enumeration
AreaUnitType Enumeration
ArrowHeadFitType Enumeration
ArrowHeadSizeType Enumeration
ArrowHeadType Enumeration
AssemblyDisplayStyleType Enumeration
AssemblyGroupNameType Enumeration
BandLocationType Enumeration
BandType Enumeration
BearingQuadrantType Enumeration
BlockAttachmentType Enumeration
CantPivotMethodType Enumeration
CantPointType Enumeration
CantStationRoundingType Enumeration
CantViewDisplayStyleType Enumeration
CapitalizationType Enumeration
CatchmentObjectType Enumeration
CatchmentRainfallTravelTimeUnitType Enumeration
CatchmentShallowConcentratedFlowSurfaceType Enumeration
CatchmentTimeOfConcentrationMethodType Enumeration
CatchmentWatershedObjectType Enumeration
CivilException Class
CivilException Members
CivilException Constructor
CivilException Constructor
CivilException Constructor (String)
CivilException Constructor (ErrorStatus)
CivilException Constructor (String, Exception)
CivilException Constructor (ErrorStatus, String)
CivilException Constructor (ErrorStatus, String, Exception)
CivilException Methods
ErrorHandler Method
ErrorHandler Method
ErrorHandler Method (String)
ErrorHandler Method (ErrorStatus)
ErrorHandler Method (ErrorStatus, String)
CivilVersion Enumeration
Constant Class
Constant Members
Constant Constructor
Constant Fields
VerticalGrade Field
CorridorRegionLockType Enumeration
CrossingBreaklinesElevationType Enumeration
CrossSectionShapeType Enumeration
CurbReturnType Enumeration
DecimalCharacterType Enumeration
DeprecatedVersionAttribute Class
DeprecatedVersionAttribute Members
DeprecatedVersionAttribute Constructor
DeprecatedVersionAttribute Constructor
DeprecatedVersionAttribute Constructor (CivilVersion)
DeprecatedVersionAttribute Properties
Version Property
DesignCheck Class
DesignCheck Members
DesignCheck Properties
Description Property
Expression Property
Name Property
DesignCheckCollection<Autodesk::Civil::AlignmentDesignCheck ^> Class
DesignCheckCollection<Autodesk::Civil::AlignmentDesignCheck ^> Members
DesignCheckCollection<Autodesk::Civil::AlignmentDesignCheck ^> Methods
Add Method
Clear Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
DesignCheckCollection<Autodesk::Civil::AlignmentDesignCheck ^> Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
DesignCheckCollection<Autodesk::Civil::ProfileDesignCheck ^> Class
DesignCheckCollection<Autodesk::Civil::ProfileDesignCheck ^> Members
DesignCheckCollection<Autodesk::Civil::ProfileDesignCheck ^> Methods
Add Method
Clear Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
DesignCheckCollection<Autodesk::Civil::ProfileDesignCheck ^> Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
DesignSpeedLookupMethodType Enumeration
DimensionAnchorOptionType Enumeration
DimensionAnchorType Enumeration
DirectionDisplayType Enumeration
DirectionNameDisplayType Enumeration
DistanceScaleFactorType Enumeration
DrivingDirectionType Enumeration
DropDecimalWholeType Enumeration
DropLeadingZeroType Enumeration
ElevationSourceType Enumeration
ElevationToUseType Enumeration
EntityNotFoundException Class
EntityNotFoundException Members
EntityNotFoundException Constructor
EntityNotFoundException Constructor
EntityNotFoundException Constructor (String)
EntityNotFoundException Constructor (ErrorStatus)
EntityNotFoundException Constructor (String, Exception)
EntityNotFoundException Constructor (ErrorStatus, String)
EntitySideType Enumeration
ErrorStatus Enumeration
ErrorStatusText Class
ErrorStatusText Members
ErrorStatusText Properties
Text Property
ExportDetermineElevationType Enumeration
FeatureLineConnectDirectionType Enumeration
FeatureLineLayerSettingType Enumeration
FeatureLineLayerType Enumeration
FeatureLinePointType Enumeration
FlowUnitType Enumeration
FreeHaulDisplayType Enumeration
GeometryPointLabelOption(T) Class
GeometryPointLabelOption(T) Members
GeometryPointLabelOption(T) Constructor
GeometryPointLabelOption(T) Properties
PointType Property
Selected Property
GeometryPointSelector(T) Class
GeometryPointSelector(T) Members
GeometryPointSelector(T) Constructor
GeometryPointSelector(T) Methods
SelectAll Method
UnSelectAll Method
GeometryPointSelector(T) Properties
Item Property
GradeFormatType Enumeration
GradeSlopeFormatType Enumeration
GradingDistanceProjectionType Enumeration
GradingElevationProjectionType Enumeration
GradingInteriorCornerOverlapSolutionType Enumeration
GradingRelativeElevationProjectionType Enumeration
GradingSearchOrderType Enumeration
GradingSlopeFormatType Enumeration
GradingSurfaceProjectionType Enumeration
GradingTargetType Enumeration
HighsideLocationType Enumeration
HighSideShoulderMethodType Enumeration
ImpliedPointOfIntersectionDisplayType Enumeration
IProperty Interface
IProperty Members
IProperty Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
KrigingSemivariogramType Enumeration
LabelContentDisplayType Enumeration
LabelingPromptType Enumeration
LabelInsertionType Enumeration
LabelInsideCurveType Enumeration
LabelMaskType Enumeration
LabelRotationType Enumeration
LabelStyleLengthType Enumeration
LabelTextAttachmentType Enumeration
LandXMLImportAlignmentType Enumeration
LatLongDirectionType Enumeration
LayoutModeType Enumeration
LeaderAttachmentBehaviorType Enumeration
LeaderAttachmentType Enumeration
LeaderShapeType Enumeration
LeaderTailVisibilityType Enumeration
LeaderVisibilityType Enumeration
LinearUnitType Enumeration
LinkCreationType Enumeration
LowSideShoulderMethodType Enumeration
MassHaulLineDisplayStyleType Enumeration
MassHaulLineHatchDisplayStyleType Enumeration
MassHaulViewDisplayStyleType Enumeration
MatchLineLabelLocationType Enumeration
NetworkDefaultLayoutCommandType Enumeration
OrientationReferenceType Enumeration
ParcelAnalysisType Enumeration
ParcelRemainderDistributionType Enumeration
ParcelSelectionType Enumeration
ParcelSolutionType Enumeration
PipeNetworkPartDisplayType Enumeration
PipeSectionLabelPlacementType Enumeration
PlacementOptionType Enumeration
PlanViewAlignType Enumeration
PlottedUnitDisplayType Enumeration
PointCloudDefaultFileExtensionType Enumeration
PointCloudDisplayStyleType Enumeration
PointCloudElevationRangeCreationType Enumeration
PointCloudRangeColorSchemeType Enumeration
PointCloudRegionType Enumeration
PointCloudSurfaceType Enumeration
PointCouldColorSchemeType Enumeration
PointFileFormatType Enumeration
PointNamesExistType Enumeration
PointNotOnEntityException Class
PointNotOnEntityException Members
PointNotOnEntityException Constructor
PointNotOnEntityException Constructor
PointNotOnEntityException Constructor (String)
PointNotOnEntityException Constructor (ErrorStatus)
PointNotOnEntityException Constructor (String, Exception)
PointNotOnEntityException Constructor (ErrorStatus, String)
PointNumbersAssignedType Enumeration
PointNumbersExistType Enumeration
PointNumbersSuppliedType Enumeration
PressureUnitType Enumeration
ProfileApplyCurveType Enumeration
ProfileCircularVerticalConstraintType Enumeration
ProfileCurveType Enumeration
ProfileDesignCheck Class
ProfileDesignCheck Members
ProfileDesignCheck Properties
DesignCheckType Property
ProfileDesignCheckCollection Class
ProfileDesignCheckCollection Members
ProfileDesignCheckCollection Methods
Add Method
Clear Method
Remove Method
RemoveAt Method
ProfileDesignCheckCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
ProfileDesignCheckRoot Class
ProfileDesignCheckRoot Members
ProfileDesignCheckRoot Constructor
ProfileDesignCheckRoot Properties
CurveDesignChecks Property
LineDesignChecks Property
ProfileDesignCheckType Enumeration
ProfileParabolicVerticalConstraintType Enumeration
ProfilePointType Enumeration
ProfileViewDatumType Enumeration
ProfileViewPlotType Enumeration
ProfileViewSplitDatumType Enumeration
ProfileViewSplitStationType Enumeration
ProfileViewStartCornerType Enumeration
ProjecitonPercentageType Enumeration
ProjecitonRule Enumeration
ProjectionUtil Class
ProjectionUtil Members
ProjectionUtil Constructor
ProjectionUtil Methods
IsProfileProjectionObject Method
IsSectionProjectionObject Method
Property<Autodesk::AutoCAD::Colors::Color ^,AcCmColor,Autodesk::Civil::CastOp<Autodesk::AutoCAD::Colors::Color ^,AcCmColor> > Class
Property<Autodesk::AutoCAD::Colors::Color ^,AcCmColor,Autodesk::Civil::CastOp<Autodesk::AutoCAD::Colors::Color ^,AcCmColor> > Members
Property<Autodesk::AutoCAD::Colors::Color ^,AcCmColor,Autodesk::Civil::CastOp<Autodesk::AutoCAD::Colors::Color ^,AcCmColor> > Methods
InternalGetValue Method
InternalSetValue Method
Property<Autodesk::AutoCAD::Colors::Color ^,AcCmColor,Autodesk::Civil::CastOp<Autodesk::AutoCAD::Colors::Color ^,AcCmColor> > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
Property<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId> > Class
Property<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId> > Members
Property<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId> > Methods
InternalGetValue Method
InternalSetValue Method
Property<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectId,AcDbObjectId> > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
Property<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> >,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> > > > Class
Property<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> >,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> > > > Members
Property<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> >,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> > > > Methods
InternalGetValue Method
InternalSetValue Method
Property<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> >,Autodesk::Civil::CastOp<Autodesk::AutoCAD::DatabaseServices::ObjectIdCollection ^,std::vector<AeccAttribute,std::allocator<AeccAttribute> > > > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
Property<bool,bool,Autodesk::Civil::CastOp<bool,bool> > Class
Property<bool,bool,Autodesk::Civil::CastOp<bool,bool> > Members
Property<bool,bool,Autodesk::Civil::CastOp<bool,bool> > Methods
InternalGetValue Method
InternalSetValue Method
Property<bool,bool,Autodesk::Civil::CastOp<bool,bool> > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
Property<double,double,Autodesk::Civil::CastOp<double,double> > Class
Property<double,double,Autodesk::Civil::CastOp<double,double> > Members
Property<double,double,Autodesk::Civil::CastOp<double,double> > Methods
InternalGetValue Method
InternalSetValue Method
Property<double,double,Autodesk::Civil::CastOp<double,double> > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
Property<int,int,Autodesk::Civil::CastOp<int,int> > Class
Property<int,int,Autodesk::Civil::CastOp<int,int> > Members
Property<int,int,Autodesk::Civil::CastOp<int,int> > Methods
InternalGetValue Method
InternalSetValue Method
Property<int,int,Autodesk::Civil::CastOp<int,int> > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
Property<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> > Class
Property<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> > Members
Property<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> > Methods
InternalGetValue Method
InternalSetValue Method
Property<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
Property<unsigned int,int,Autodesk::Civil::CastOp<unsigned int,int> > Class
Property<unsigned int,int,Autodesk::Civil::CastOp<unsigned int,int> > Members
Property<unsigned int,int,Autodesk::Civil::CastOp<unsigned int,int> > Methods
InternalGetValue Method
InternalSetValue Method
Property<unsigned int,int,Autodesk::Civil::CastOp<unsigned int,int> > Properties
IsOverridable Property
Locked Property
Overridden Property
Value Property
PropertyAnchorPoint Class
PropertyAnchorPoint Members
PropertyAnchorPoint Methods
PropertyAnchorPoint Properties
Value Property
PropertyAngle Class
PropertyAngle Members
PropertyAngle Methods
PropertyAngle Properties
Value Property
PropertyArrowhead Class
PropertyArrowhead Members
PropertyArrowhead Methods
PropertyArrowhead Properties
Value Property
PropertyBlock Class
PropertyBlock Members
PropertyBlock Methods
PropertyBlock Properties
Value Property
PropertyBoolean Class
PropertyBoolean Members
PropertyBoolean Methods
PropertyBoolean Properties
PropertyColor Class
PropertyColor Members
PropertyColor Methods
PropertyColor Properties
PropertyDouble Class
PropertyDouble Members
PropertyDouble Methods
PropertyDouble Properties
PropertyEnum(T) Class
PropertyEnum(T) Members
PropertyEnum(T) Methods
PropertyEnum(T) Properties
Value Property
PropertyExpression Class
PropertyExpression Members
PropertyExpression Methods
PropertyExpression Properties
Value Property
PropertyFeatureLineStylePriority Class
PropertyFeatureLineStylePriority Members
PropertyFeatureLineStylePriority Methods
PropertyFeatureLineStylePriority Properties
Value Property
PropertyInt Class
PropertyInt Members
PropertyInt Methods
PropertyInt Properties
PropertyLayer Class
PropertyLayer Members
PropertyLayer Methods
PropertyLayer Properties
Value Property
PropertyLinetype Class
PropertyLinetype Members
PropertyLinetype Methods
PropertyLinetype Properties
Value Property
PropertyMaterial Class
PropertyMaterial Members
PropertyMaterial Methods
PropertyMaterial Properties
Value Property
PropertyMText Class
PropertyMText Members
PropertyMText Methods
PropertyMText Properties
Value Property
PropertyNameTemplate Class
PropertyNameTemplate Members
PropertyNameTemplate Methods
PropertyNameTemplate Properties
Value Property
PropertyObjectId Class
PropertyObjectId Members
PropertyObjectId Methods
PropertyObjectId Properties
Value Property
PropertyObjectName Class
PropertyObjectName Members
PropertyObjectName Methods
PropertyObjectName Properties
Value Property
PropertyString Class
PropertyString Members
PropertyString Methods
PropertyString Properties
Value Property
PropertyTextStyle Class
PropertyTextStyle Members
PropertyTextStyle Methods
PropertyTextStyle Properties
Value Property
PropertyUInt Class
PropertyUInt Members
PropertyUInt Methods
PropertyUInt Properties
QuantityTakeoffLengthComputeType Enumeration
QuantityTakeoffPipeLengthType Enumeration
QuantityTakeoffReportExtentType Enumeration
QuantityTakeoffReportType Enumeration
RadiusLookupMethodType Enumeration
RailAlignmentPivotType Enumeration
RoadwaySideType Enumeration
RotationDirType Enumeration
RoundingType Enumeration
ROWCleanupType Enumeration
SectionViewElevationRangeType Enumeration
SheetCreateType Enumeration
SheetSetType Enumeration
ShoulderMethodType Enumeration
SignType Enumeration
SlopeFormatType Enumeration
SlopePatternLengthType Enumeration
SlopePatternOffsetType Enumeration
SlopePatternStartType Enumeration
SlopePatternSymbolType Enumeration
SpeedUnitType Enumeration
SpiralType Enumeration
StationDelimiterCharacterType Enumeration
StationDelimiterPositionType Enumeration
StationFormatType Enumeration
StructureColumnComponentType Enumeration
StructureProfileLabelPlacementType Enumeration
StyleConflictResolverType Enumeration
SubassemblyNameType Enumeration
SuperelevationAttainmentRegionType Enumeration
SuperelevationCorridorType Enumeration
SuperelevationCriticalStationType Enumeration
SuperelevationCrossSegmentType Enumeration
SuperelevationPointType Enumeration
SuperelevationStationRoundingType Enumeration
SuperelevationTransitionRegionType Enumeration
SuperElevationViewDisplayStyleType Enumeration
SurfaceBoundaryType Enumeration
SurfaceBreaklineType Enumeration
SurfaceDrawObjectType Enumeration
SurfaceException Class
SurfaceException Members
SurfaceException Constructor
SurfaceException Constructor
SurfaceException Constructor (String)
SurfaceException Constructor (SurfaceStatus)
SurfaceException Constructor (String, Exception)
SurfaceException Constructor (SurfaceStatus, String)
SurfaceExtractionSettingsType Enumeration
SurfaceOpeartionStatusType Enumeration
SurfacePointOutputLocationsType Enumeration
SurfacePointSelectionType Enumeration
SurfaceRegionOptionsType Enumeration
SurfaceSimplifyType Enumeration
SurfaceSmoothType Enumeration
SurfaceStatus Enumeration
SurfaceStatusText Class
SurfaceStatusText Members
SurfaceStatusText Properties
Text Property
SurfaceSurveyQueryType Enumeration
SurfaceType Enumeration
SurveyException Class
SurveyException Members
SurveyException Constructor
SurveyException Constructor
SurveyException Constructor (String)
SurveyException Constructor (SurveyStatus)
SurveyException Constructor (String, Exception)
SurveyException Constructor (SurveyStatus, String)
SurveyProject Class
SurveyProject Members
SurveyProject Methods
Close Method
GetSurveyQueryCollection Method
IsOpen Method
Open Method
SurveyProject Properties
ProjectGUID Property
ProjectName Property
SurveyProjectCollection Class
SurveyProjectCollection Members
SurveyProjectCollection Methods
GetCurrentProject Method
GetEnumerator Method
GetItem Method
GetItem Method (Guid)
GetItem Method (String)
GetObjectEnumerator Method
SurveyProjectCollection Properties
Count Property
Item Property
WorkingFolder Property
SurveyQuery Class
SurveyQuery Members
SurveyQuery Properties
Description Property
GUID Property
Name Property
SurveyQueryCollection Class
SurveyQueryCollection Members
SurveyQueryCollection Methods
GetEnumerator Method
GetItem Method
GetItem Method (Guid)
GetItem Method (String)
GetObjectEnumerator Method
SurveyQueryCollection Properties
Count Property
Item Property
SurveyStatus Enumeration
SurveyStatusText Class
SurveyStatusText Members
SurveyStatusText Properties
Text Property
SweptCurveLocation Enumeration
TableSegmentDataType Enumeration
TableTitleDirectionType Enumeration
TaperInputType Enumeration
TextBorderType Enumeration
TextJustificationType Enumeration
TimeUnitType Enumeration
TransitionInputType Enumeration
TransitionType Enumeration
Utility Class
Utility Members
Utility Methods
PolarPoint Method
PolarPoint Method (Point3d, Double, Double)
PolarPoint Method (Double[], Double, Double)
VectorMeasurementType Enumeration
ViewFrameAngleType Enumeration
ViewFrameLabelLocationType Enumeration
VolumeSurfaceType Enumeration
VolumeUnitType Enumeration
WaterdropObjectType Enumeration
WatershedType Enumeration
WideningByMethod Enumeration
WideningSide Enumeration
Autodesk.Civil.ApplicationServices Namespace
CivilApplication Class
CivilApplication Members
CivilApplication Properties
ActiveDocument Property
ActiveProduct Property
SurveyProjects Property
CivilDocument Class
CivilDocument Members
CivilDocument Methods
GetAlignmentIds Method
GetAlignmentTableIds Method
GetAllPointIds Method
GetCivilDocument Method
GetGeneralSegmentLabelIds Method
GetIntersectionIds Method
GetLegendTableIds Method
GetNoteLabelIds Method
GetParcelSegmentTableIds Method
GetParcelTableIds Method
GetPipeNetworkIds Method
GetPointTableIds Method
GetSiteIds Method
GetSitelessAlignmentId Method
GetSitelessAlignmentIds Method
GetSurfaceIds Method
GetViewFrameGroupIds Method
CivilDocument Properties
AssemblyCollection Property
CogoPoints Property
CorridorCollection Property
CorridorState Property
IsCorridorSectionViewActive Property
IsDriveActive Property
NetworkState Property
PointGroups Property
PointUDPClassifications Property
PointUDPs Property
Settings Property
Styles Property
SubassemblyCollection Property
ProductType Enumeration
Autodesk.Civil.DatabaseServices Namespace
AdditionalAppliedAssemblyInfo Class
AdditionalAppliedAssemblyInfo Members
AdditionalAppliedAssemblyInfo Constructor
AdditionalAppliedAssemblyInfo Properties
Description Property
Station Property
Alignment Class
Alignment Members
Alignment Methods
CopyToSite Method
CopyToSite Method (ObjectId)
CopyToSite Method (String)
Create Method
Create Method (CivilDocument, String, ObjectId, ObjectId, ObjectId, ObjectId)
Create Method (CivilDocument, String, String, String, String, String)
Create Method (CivilDocument, PolylineOptions, String, ObjectId, ObjectId, ObjectId, ObjectId)
Create Method (CivilDocument, PolylineOptions, String, String, String, String, String)
Create Method (CorridorFeatureLine, String, ObjectId, ObjectId, ObjectId, ObjectId, AlignmentType)
CreateOffsetAlignment Method
CreateOffsetAlignment Method (Double)
CreateOffsetAlignment Method (String, ObjectId, Double, ObjectId)
CreateOffsetAlignment Method (Database, String, String, Double, String)
CreateOffsetAlignment Method (String, ObjectId, Double, ObjectId, Double, Double)
CreateOffsetAlignment Method (Database, String, String, Double, String, Double, Double)
DistanceToAlignment Method
DistanceToAlignment Method (Double, Alignment, Double, Double)
DistanceToAlignment Method (Double, Alignment, AlignmentSide, Double, Double)
GetAlignmentLabelGroupIds Method
GetAlignmentLabelIds Method
GetChildOffsetAlignmentIds Method
GetChildOffsetAlignmentIds Method
GetChildOffsetAlignmentIds Method (Boolean)
GetCrossSlopeAtStation Method
GetInstantaneousRadius Method
GetLabelGroupIds Method
GetLabelIds Method
GetNextUniqueName Method
GetPolyline Method
GetProfileIds Method
GetProfileViewIds Method
GetRegions Method
GetSampleLineGroupIds Method
GetStationSet Method
GetStationSet Method (StationTypes)
GetStationSet Method (StationTypes, Double)
GetStationSet Method (StationTypes, Double, Double)
GetStationStringWithEquations Method
ImportLabelSet Method
ImportLabelSet Method (ObjectId)
ImportLabelSet Method (String)
PointLocation Method
PointLocation Method (Double, Double, Double, Double)
PointLocation Method (Double, Double, Double, Double, Double, Double)
Reverse Method
StationOffset Method
StationOffset Method (Double, Double, Double, Double)
StationOffset Method (Double, Double, Double, Double, Double)
Update Method
Alignment Properties
AlignmentType Property
CreationMode Property
CriteriaFileName Property
DesignCheckSetId Property
DesignCheckSetName Property
DesignSpeeds Property
EndingStation Property
EndingStationWithEquations Property
Entities Property
HasRoundabout Property
IsOffsetAlignment Property
IsSiteless Property
Length Property
OffsetAlignmentInfo Property
RailAlignmentInfo Property
ReferencePoint Property
ReferencePointStation Property
SiteId Property
SiteName Property
StartingStation Property
StationEquations Property
StationIndexIncrement Property
StyleId Property
StyleName Property
SuperelevationCriticalStations Property
SuperelevationCurves Property
UpdateMode Property
UseDesignCheckSet Property
UseDesignCriteriaFile Property
UseDesignSpeed Property
AlignmentArc Class
AlignmentArc Members
AlignmentArc Methods
AlignmentArc Properties
CenterPoint Property
ChordDirection Property
ChordLength Property
Clockwise Property
Constraint2 Property
CurveGroupIndex Property
CurveGroupSubEntityIndex Property
DeflectedAngle Property
Delta Property
DirectionAtPoint1 Property
DirectionAtPoint2 Property
EndDirection Property
ExternalSecant Property
ExternalTangent Property
GreaterThan180 Property
Item Property
Length Property
MidOrdinate Property
MinimumRadius Property
PassThroughPoint1 Property
PassThroughPoint2 Property
PassThroughPoint3 Property
PIStation Property
Radius Property
ReverseCurve Property
StartDirection Property
AlignmentArcConstraintType Enumeration
AlignmentCantLabelGroup Class
AlignmentCantLabelGroup Members
AlignmentCantLabelGroup Methods
Create Method
Create Method (ObjectId)
Create Method (ObjectId, ObjectId)
GetAvailableLabelGroupIds Method
GetGeometryPointsOptions Method
SetGeometryPointsOptions Method
AlignmentCantLabelGroup Properties
AlignmentCCRC Class
AlignmentCCRC Members
AlignmentCCRC Methods
AlignmentCCRC Properties
Arc1 Property
Arc2 Property
Arc3 Property
Constraint2 Property
AlignmentCCRCConstraintType Enumeration
AlignmentCRC Class
AlignmentCRC Members
AlignmentCRC Methods
AlignmentCRC Properties
Arc1 Property
Arc2 Property
Constraint2 Property
AlignmentCRCConstraintType Enumeration
AlignmentCreationType Enumeration
AlignmentCTC Class
AlignmentCTC Members
AlignmentCTC Methods
AlignmentCTC Properties
Arc1 Property
Arc2 Property
Constraint2 Property
Tangent Property
AlignmentCTCConstraintType Enumeration
AlignmentCurve Class
AlignmentCurve Members
AlignmentCurve Methods
AlignmentCurve Properties
EndPoint Property
EndStation Property
HighestDesignSpeed Property
Length Property
StartPoint Property
StartStation Property
AlignmentCurveLabel Class
AlignmentCurveLabel Members
AlignmentCurveLabel Methods
Create Method
Create Method (AlignmentArc, ObjectId)
Create Method (AlignmentSubEntityArc, ObjectId)
AlignmentCurveLabel Properties
AlignmentDesignSpeedLabelGroup Class
AlignmentDesignSpeedLabelGroup Members
AlignmentDesignSpeedLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
AlignmentDesignSpeedLabelGroup Properties
AlignmentEntity Class
AlignmentEntity Members
AlignmentEntity Methods
DesignChecks Method
Equals Method
ValidateDesignCheck Method
AlignmentEntity Properties
Constraint1 Property
EntityAfter Property
EntityBefore Property
EntityId Property
EntityType Property
Item Property
SubEntityCount Property
AlignmentEntityCollection Class
AlignmentEntityCollection Members
AlignmentEntityCollection Methods
AddFixedCurve Method
AddFixedCurve Method (Int32, Point3d)
AddFixedCurve Method (Point3d, Point3d, Vector3d)
AddFixedCurve Method (Point3d, Point3d, Boolean)
AddFixedCurve Method (Point3d, Vector3d, Point3d)
AddFixedCurve Method (Point3d, Double, Boolean)
AddFixedCurve Method (Point3d, Point3d, Double, Boolean)
AddFixedCurve Method (Point3d, Vector3d, Double, Boolean)
AddFixedCurve Method (Int32, Point3d, Point3d, Point3d)
AddFixedCurve Method (Int32, Point3d, Point3d, Double, Boolean, Boolean)
AddFixedLine Method
AddFixedLine Method (Point3d, Point3d)
AddFixedLine Method (Int32, Double)
AddFixedLine Method (Int32, Point3d, Point3d)
AddFixedSpiral Method
AddFixedSpiral Method (Int32, Point3d, Point3d, Point3d, SpiralType)
AddFixedSpiral Method (Int32, Double, Double, SpiralCurveType, SpiralType)
AddFixedSpiral Method (Int32, Double, Double, Double, SpiralType)
AddFixedSpiral Method (Int32, Point3d, Point3d, Double, Double, SpiralCurveType, Boolean, SpiralType)
AddFixedSpiral Method (Int32, Point3d, Point3d, Double, Double, Double, Boolean, SpiralType)
AddFloatingArcWithSpiral Method
AddFloatingArcWithSpiral Method (Int32, EntityAttachType, Double, SpiralParamType, Double, Point3d, Boolean, SpiralType)
AddFloatingArcWithSpiral Method (Int32, EntityAttachType, Double, SpiralParamType, Double, Double, Boolean, SpiralType)
AddFloatingCSS Method
AddFloatingCSS Method (Int32, Point3d, Point3d, Double, Double, SpiralParamType, SpiralType)
AddFloatingCSS Method (Int32, Double, Point3d, Double, Double, SpiralParamType, SpiralType)
AddFloatingCurve Method
AddFloatingCurve Method (Point3d, Int32)
AddFloatingCurve Method (Int32, Point3d)
AddFloatingCurve Method (Point3d, Vector3d, Int32)
AddFloatingCurve Method (Int32, Point3d, Vector3d)
AddFloatingCurve Method (Point3d, Double, Boolean, CurveType, Int32)
AddFloatingCurve Method (Int32, Point3d, Double, Boolean, CurveType)
AddFloatingCurve Method (Int32, Double, Double, CurveParamType, Boolean)
AddFloatingCurve Method (Double, Double, CurveParamType, Boolean, Int32)
AddFloatingLine Method
AddFloatingLine Method (Point3d, Int32)
AddFloatingLine Method (Int32, Point3d)
AddFloatingLine Method (Int32, Double)
AddFloatingLine Method (Double, Int32)
AddFloatingLineWithSpiral Method
AddFloatingLineWithSpiral Method (Int32, EntityAttachType, Double, SpiralParamType, Point3d, SpiralType)
AddFloatingLineWithSpiral Method (Int32, EntityAttachType, Double, SpiralParamType, Double, SpiralType)
AddFloatingSSC Method
AddFloatingSSC Method (Int32, Double, Double, SpiralParamType, Point3d, Point3d, SpiralType)
AddFloatingSSC Method (Int32, Double, Double, SpiralParamType, Double, Point3d, SpiralType)
AddFloatSpiral Method
AddFloatSpiral Method (Int32, Double, Double, Boolean, SpiralType)
AddFloatSpiral Method (Double, Double, Int32, Boolean, SpiralType)
AddFreeCurve Method
AddFreeCurve Method (Int32, Int32, Point3d)
AddFreeCurve Method (Int32, Int32, Double, CurveParamType, Boolean, CurveType)
AddFreeLine Method
AddFreeSCS Method
AddFreeSCSCS Method
AddFreeSCSSCS Method
AddFreeSpiral Method
AddFreeSSBetweenCurves Method
AddFreeSSBetweenTangents Method
AddFreeSTS Method
AddFreeSTS Method (Int32, Int32, Double, SpiralType)
AddFreeSTS Method (Int32, Int32, Double, Double, SpiralParamType, SpiralType)
Clear Method
EntityAtId Method
EntityAtStation Method
GetEntityByOrder Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
AlignmentEntityCollection Properties
Count Property
FirstEntity Property
Item Property
LastEntity Property
AlignmentEntityConstraintType Enumeration
AlignmentEntityType Enumeration
AlignmentGeometryPointLabelGroup Class
AlignmentGeometryPointLabelGroup Members
AlignmentGeometryPointLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
GetGeometryPointsOptions Method
SetGeometryPointsOptions Method
AlignmentGeometryPointLabelGroup Properties
AlignmentGeometryPointStationType Enumeration
AlignmentIndexedPILabel Class
AlignmentIndexedPILabel Members
AlignmentIndexedPILabel Methods
Create Method
Create Method (AlignmentArc, ObjectId)
Create Method (AlignmentLine, ObjectId)
Create Method (AlignmentSCS, ObjectId)
AlignmentIndexedPILabel Properties
AlignmentLabelGroup Class
AlignmentLabelGroup Members
AlignmentLabelGroup Methods
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
AlignmentLabelGroup Properties
AlignmentLine Class
AlignmentLine Members
AlignmentLine Methods
AlignmentLine Properties
Constraint2 Property
CurveGroupIndex Property
CurveGroupSubEntityIndex Property
Direction Property
Item Property
Length Property
MidPoint Property
PassThroughPoint1 Property
PassThroughPoint2 Property
AlignmentLineConstraintType Enumeration
AlignmentMinorStationLabelGroup Class
AlignmentMinorStationLabelGroup Members
AlignmentMinorStationLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
SetRange Method
AlignmentMinorStationLabelGroup Properties
MajorStationLabelGroup Property
RangeEnd Property
RangeEndFromFeature Property
RangeStart Property
RangeStartFromFeature Property
AlignmentMultipleSegments Class
AlignmentMultipleSegments Members
AlignmentMultipleSegments Methods
AlignmentMultipleSegments Properties
Constraint2 Property
Item Property
SubEntityCount Property
AlignmentMultipleSegmentsConstraintType Enumeration
AlignmentPILabel Class
AlignmentPILabel Members
AlignmentPILabel Methods
Create Method
Create Method (AlignmentArc, ObjectId)
Create Method (AlignmentLine, ObjectId)
Create Method (AlignmentSCS, ObjectId)
AlignmentPILabel Properties
AlignmentRegion Class
AlignmentRegion Members
AlignmentRegion Methods
Split Method
AlignmentRegion Properties
EndStation Property
EntryTransition Property
ExitTransition Property
IncreasedWidth Property
Length Property
Offset Property
OffsetDist Property
RegionType Property
StartStation Property
WideningCriteria Property
AlignmentRegionCollection Class
AlignmentRegionCollection Members
AlignmentRegionCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
MergeToNeighborRegion Method
Remove Method
AlignmentRegionCollection Properties
Count Property
Item Property
AlignmentRegionType Enumeration
AlignmentSCS Class
AlignmentSCS Members
AlignmentSCS Methods
AlignmentSCS Properties
Arc Property
Constraint2 Property
SpiralIn Property
SpiralOut Property
AlignmentSCSConstraintType Enumeration
AlignmentSCSCS Class
AlignmentSCSCS Members
AlignmentSCSCS Methods
AlignmentSCSCS Properties
Arc1 Property
Arc2 Property
Constraint2 Property
Spiral1 Property
Spiral2 Property
Spiral3 Property
AlignmentSCSCSConstraintType Enumeration
AlignmentSCSSCS Class
AlignmentSCSSCS Members
AlignmentSCSSCS Methods
AlignmentSCSSCS Properties
Arc1 Property
Arc2 Property
Constraint2 Property
Spiral1 Property
Spiral2 Property
Spiral3 Property
Spiral4 Property
AlignmentSCSSCSConstraintType Enumeration
AlignmentSide Enumeration
AlignmentSpiral Class
AlignmentSpiral Members
AlignmentSpiral Methods
AlignmentSpiral Properties
A Property
Compound Property
Constraint2 Property
CurveGroupIndex Property
CurveGroupSubEntityIndex Property
CurveType Property
Delta Property
Direction Property
EndDirection Property
Item Property
K Property
Length Property
LongTangent Property
MinimumTransitionLength Property
P Property
RadialPoint Property
RadiusIn Property
RadiusOut Property
ShortTangent Property
SPIAngle Property
SPIPoint Property
SpiralDefinition Property
SPIStation Property
StartDirection Property
TotalX Property
TotalY Property
AlignmentSpiralConstraintType Enumeration
AlignmentSpiralLabel Class
AlignmentSpiralLabel Members
AlignmentSpiralLabel Methods
Create Method
Create Method (AlignmentSpiral, ObjectId)
Create Method (AlignmentSubEntitySpiral, ObjectId)
AlignmentSpiralLabel Properties
AlignmentSSCSS Class
AlignmentSSCSS Members
AlignmentSSCSS Methods
AlignmentSSCSS Properties
Arc Property
Constraint2 Property
Spiral1 Property
Spiral2 Property
Spiral3 Property
Spiral4 Property
AlignmentSSCSSConstraintType Enumeration
AlignmentStationEquationLabelGroup Class
AlignmentStationEquationLabelGroup Members
AlignmentStationEquationLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
AlignmentStationEquationLabelGroup Properties
AlignmentStationLabelGroup Class
AlignmentStationLabelGroup Members
AlignmentStationLabelGroup Methods
Create Method
CreateMajor Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
AlignmentStationLabelGroup Properties
Increment Property
RangeEnd Property
RangeStart Property
AlignmentSTS Class
AlignmentSTS Members
AlignmentSTS Methods
AlignmentSTS Properties
Constraint2 Property
SpiralIn Property
SpiralOut Property
Tangent Property
AlignmentSTSConstraintType Enumeration
AlignmentSubEntity Class
AlignmentSubEntity Members
AlignmentSubEntity Methods
DesignChecks Method
Equals Method
ValidateDesignCheck Method
AlignmentSubEntity Properties
CurveGroupIndex Property
CurveGroupSubEntityIndex Property
EndPoint Property
EndStation Property
Length Property
StartPoint Property
StartStation Property
SubEntityType Property
AlignmentSubEntityArc Class
AlignmentSubEntityArc Members
AlignmentSubEntityArc Methods
AlignmentSubEntityArc Properties
CenterPoint Property
ChordDirection Property
ChordLength Property
Clockwise Property
DeflectedAngle Property
Delta Property
DirectionAtPoint1 Property
DirectionAtPoint2 Property
EndDirection Property
ExternalSecant Property
ExternalTangent Property
GreaterThan180 Property
MidOrdinate Property
MinimumRadius Property
PassThroughPoint1 Property
PassThroughPoint2 Property
PassThroughPoint3 Property
PIPoint Property
PIStation Property
Radius Property
ReverseCurve Property
StartDirection Property
SubEntityType Property
AlignmentSubEntityLine Class
AlignmentSubEntityLine Members
AlignmentSubEntityLine Methods
AlignmentSubEntityLine Properties
Direction Property
MidPoint Property
PassThroughPoint1 Property
PassThroughPoint2 Property
SubEntityType Property
AlignmentSubEntitySpiral Class
AlignmentSubEntitySpiral Members
AlignmentSubEntitySpiral Methods
AlignmentSubEntitySpiral Properties
A Property
Compound Property
CurveType Property
Delta Property
Direction Property
EndDirection Property
K Property
LongTangent Property
MinimumTransitionLength Property
P Property
RadialPoint Property
RadiusIn Property
RadiusOut Property
ShortTangent Property
SPIAngle Property
SPIPoint Property
SpiralDefinition Property
SPIStation Property
StartDirection Property
SubEntityType Property
TotalX Property
TotalY Property
AlignmentSubEntityType Enumeration
AlignmentSuperelevationLabelGroup Class
AlignmentSuperelevationLabelGroup Members
AlignmentSuperelevationLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
GetGeometryPointsOptions Method
SetGeometryPointsOptions Method
AlignmentSuperelevationLabelGroup Properties
AlignmentTable Class
AlignmentTable Members
AlignmentTable Properties
AlignmentTangentLabel Class
AlignmentTangentLabel Members
AlignmentTangentLabel Methods
Create Method
Create Method (AlignmentLine, ObjectId)
Create Method (AlignmentSubEntityLine, ObjectId)
AlignmentTangentLabel Properties
AlignmentTransition Class
AlignmentTransition Members
AlignmentTransition Methods
Slim Method
AlignmentTransition Properties
NextRegion Property
PreviousRegion Property
TransitionDescription Property
TransitionType Property
AlignmentTransitionCollection Class
AlignmentTransitionCollection Members
AlignmentTransitionCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
AlignmentTransitionCollection Properties
Count Property
Item Property
AlignmentType Enumeration
AlignmentUpdateType Enumeration
AlignmentVerticalGeometryPointLabelGroup Class
AlignmentVerticalGeometryPointLabelGroup Members
AlignmentVerticalGeometryPointLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
GetGeometryPointsOptions Method
SetGeometryPointsOptions Method
AlignmentVerticalGeometryPointLabelGroup Properties
VerticalAlignment Property
AnchorInfo Class
AnchorInfo Members
AnchorInfo Constructor
AnchorInfo Fields
CenterOfCurve Field
DirectionAtLocation Field
IsOnCurve Field
Location Field
AppliedAssembly Class
AppliedAssembly Members
AppliedAssembly Methods
GetAppliedSubassemblies Method
GetLinksByCode Method
GetPointsByCode Method
GetShapesByCode Method
AppliedAssembly Properties
AssemblyId Property
CorridorId Property
Links Property
LinksByCode Property
Points Property
PointsByCode Property
Shapes Property
ShapesByCode Property
AppliedAssemblyCollection Class
AppliedAssemblyCollection Members
AppliedAssemblyCollection Methods
GetEnumerator Method
GetItemAt Method
GetObjectEnumerator Method
Stations Method
AppliedAssemblyCollection Properties
CorridorId Property
Count Property
Item Property
AppliedAssemblySetting Class
AppliedAssemblySetting Members
AppliedAssemblySetting Properties
AdditionalAppliedAssemblies Property
AppliedAdjacentToOffsetTargetStartEnd Property
AppliedAtHorizontalGeometryPoints Property
AppliedAtOffsetTargetGeometryPoints Property
AppliedAtProfileGeometryPoints Property
AppliedAtProfileHighLowPoints Property
AppliedAtSuperelevationCriticalPoints Property
FrequencyAlongCurves Property
FrequencyAlongProfileCurves Property
FrequencyAlongSpirals Property
FrequencyAlongTangents Property
AppliedSubassembly Class
AppliedSubassembly Members
AppliedSubassembly Methods
Contains Method
GetParameter(T) Method
AppliedSubassembly Properties
BaselineHookedTo Property
CorridorId Property
Links Property
OriginStationOffsetElevationToBaseline Property
Parameters Property
Points Property
Shapes Property
SubassemblyId Property
AppliedSubassemblyCollection Class
AppliedSubassemblyCollection Members
AppliedSubassemblyCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
ObjectIds Method
AppliedSubassemblyCollection Properties
CorridorId Property
Count Property
Item Property
AppliedSubassemblyParam(T) Class
AppliedSubassemblyParam(T) Members
AppliedSubassemblyParam(T) Methods
ClearOverride Method
AppliedSubassemblyParam(T) Properties
Comment Property
DesignValue Property
DesignValueAsObject Property
DisplayName Property
IsOverriden Property
KeyName Property
Value Property
ValueAsObject Property
ValueType Property
Assembly Class
Assembly Members
Assembly Methods
AddSubassembly Method
AddSubassembly Method (ObjectId)
AddSubassembly Method (ObjectId, Point)
CopySubassembly Method
CopySubassembly Method (ObjectId)
CopySubassembly Method (ObjectId, Point)
GetOffsetBaselineNames Method
InsertSubassemblyAfter Method
InsertSubassemblyBefore Method
MirrorSubassembly Method
MirrorSubassembly Method (ObjectId)
MirrorSubassembly Method (ObjectId, Point)
ReplaceSubassembly Method
Assembly Properties
CodeSetStyleId Property
CodeSetStyleName Property
Groups Property
Location Property
OffsetAssemblies Property
StyleId Property
StyleName Property
Type Property
AssemblyCollection Class
AssemblyCollection Members
AssemblyCollection Methods
Add Method
Add Method (String, AssemblyType, Point3d)
Add Method (String, AssemblyType, Point3d, ObjectId, ObjectId)
GetEnumerator Method
GetObjectEnumerator Method
ImportAssembly Method
ImportAssembly Method (String, Database, String, Point3d)
ImportAssembly Method (String, String, String, Point3d)
AssemblyCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
AssemblyGroup Class
AssemblyGroup Members
AssemblyGroup Methods
GetSubassemblyIds Method
AssemblyGroup Properties
Name Property
AssemblyGroupCollection Class
AssemblyGroupCollection Members
AssemblyGroupCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (String)
Remove Method (AssemblyGroup)
RemoveAt Method
AssemblyGroupCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
AssemblyType Enumeration
AttributeTypeInfo Class
AttributeTypeInfo Members
AttributeTypeInfo Properties
DefaultValue Property
Description Property
Name Property
UseDefaultValue Property
AttributeTypeInfoBool Class
AttributeTypeInfoBool Members
AttributeTypeInfoBool Constructor
AttributeTypeInfoBool Properties
DefaultValue Property
AttributeTypeInfoDouble Class
AttributeTypeInfoDouble Members
AttributeTypeInfoDouble Constructor
AttributeTypeInfoDouble Constructor (String)
AttributeTypeInfoDouble Constructor (String, AttributeTypeInfoDoubleDataType)
AttributeTypeInfoDouble Properties
DataType Property
DefaultValue Property
LowerBoundInclusive Property
LowerBoundValue Property
UpperBoundInclusive Property
UpperBoundValue Property
AttributeTypeInfoDoubleDataType Enumeration
AttributeTypeInfoEnum Class
AttributeTypeInfoEnum Members
AttributeTypeInfoEnum Constructor
AttributeTypeInfoEnum Methods
GetEnumValues Method
AttributeTypeInfoEnum Properties
DefaultValue Property
AttributeTypeInfoInt Class
AttributeTypeInfoInt Members
AttributeTypeInfoInt Constructor
AttributeTypeInfoInt Properties
DefaultValue Property
LowerBoundInclusive Property
LowerBoundValue Property
UpperBoundInclusive Property
UpperBoundValue Property
AttributeTypeInfoString Class
AttributeTypeInfoString Members
AttributeTypeInfoString Constructor
AttributeTypeInfoString Properties
DefaultValue Property
AutoFeatureLabelGroup Class
AutoFeatureLabelGroup Members
AutoFeatureLabelGroup Methods
SetRange Method
AutoFeatureLabelGroup Properties
RangeEnd Property
RangeEndFromFeature Property
RangeStart Property
RangeStartFromFeature Property
AutoWideningCriteriaInfo Class
AutoWideningCriteriaInfo Members
AutoWideningCriteriaInfo Constructor
AutoWideningCriteriaInfo Properties
AttainmentMethod Property
CriteriaFileName Property
LaneWidth Property
LeftLanesCount Property
MinimumRadiusTableName Property
RightLanesCount Property
SpiralPercentForSC Property
TangentPercentForTC Property
TransitionLengthTableName Property
WheelbaseLength Property
WideningMethod Property
WideningSide Property
AutoWideningInfo Class
AutoWideningInfo Members
AutoWideningInfo Constructor
AutoWideningInfo Properties
IncreasedWidth Property
Side Property
TransitionLength Property
BaseBaseline Class
BaseBaseline Members
BaseBaseline Methods
GetDirectionAtStation Method
SetAlignmentAndProfile Method
SortedStations Method
StationOffsetElevationToXYZ Method
BaseBaseline Properties
AlignmentId Property
BaselineType Property
CorridorId Property
DirectionAtStation Property
EndStation Property
ProfileId Property
StartStation Property
Baseline Class
Baseline Members
Baseline Methods
GetAppliedAssemblyAtIndex Method
GetAppliedAssemblyAtStation Method
GetTargets Method
SetTargets Method
SortedStations Method
Baseline Properties
AlignmentId Property
AppliedAssembly Property
AppliedAssembly Property (Double)
AppliedAssembly Property (Int32)
BaselineRegions Property
BaselineType Property
IsProcessed Property
MainBaselineFeatureLines Property
Name Property
NeedsProcessing Property
OffsetBaselineFeatureLinesCol Property
ProfileId Property
BaselineCollection Class
BaselineCollection Members
BaselineCollection Methods
Add Method
Add Method (String, ObjectId, ObjectId)
Add Method (String, String, String)
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (String)
Remove Method (Baseline)
RemoveAt Method
BaselineCollection Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
BaselineFeatureLines Class
BaselineFeatureLines Members
BaselineFeatureLines Methods
CodeNames Method
BaselineFeatureLines Properties
CorridorId Property
FeatureLineCollectionMap Property
HardcodedOffsetBaselineName Property
IsMainBaseline Property
OffsetAlignmentId Property
BaselineFeatureLinesCollection Class
BaselineFeatureLinesCollection Members
BaselineFeatureLinesCollection Methods
CodeNames Method
GetEnumerator Method
GetObjectEnumerator Method
BaselineFeatureLinesCollection Properties
CorridorId Property
Count Property
Item Property
BaseLineRange Structure
BaseLineRange Members
BaseLineRange Methods
CheckStationRange Method
BaseLineRange Properties
BaseLineId Property
EndStation Property
StartStation Property
BaselineRegion Class
BaselineRegion Members
BaselineRegion Methods
AdditionalStations Method
AddStation Method
ClearAdditionalStations Method
DeleteStation Method
GetOverriddenStations Method
GetTargets Method
Match Method
Merge Method
RemoveOverriddenStation Method
SetTargets Method
SortedStations Method
Split Method
BaselineRegion Properties
AppliedAssemblies Property
AppliedAssemblySetting Property
AssemblyId Property
CorridorId Property
EndStation Property
IsProcessed Property
Name Property
NeedsProcessing Property
OffsetBaselines Property
StartStation Property
BaselineRegionCollection Class
BaselineRegionCollection Members
BaselineRegionCollection Methods
Add Method
Add Method (String, ObjectId)
Add Method (String, String)
Add Method (String, ObjectId, Double, Double)
Add Method (String, String, Double, Double)
AddRegion Method
AddRegion Method (String, ObjectId)
AddRegion Method (String, String)
GetEnumerator Method
GetObjectEnumerator Method
IndexOf Method
Remove Method
Remove Method (String)
Remove Method (BaselineRegion)
RemoveAt Method
BaselineRegionCollection Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
BoundingShapeType Enumeration
CalculatedLink Class
CalculatedLink Members
CalculatedLink Properties
CalculatedPoints Property
CorridorCodes Property
DrawOverride Property
CalculatedLinkCollection Class
CalculatedLinkCollection Members
CalculatedLinkCollection Methods
Add Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
CalculatedLinkCollection Properties
CorridorId Property
Count Property
Item Property
CalculatedPoint Class
CalculatedPoint Members
CalculatedPoint Properties
CorridorCodes Property
NormalToBaseline Property
NormalToSubassembly Property
StationOffsetElevationToBaseline Property
StationOffsetElevationToSubassembly Property
CalculatedPointCollection Class
CalculatedPointCollection Members
CalculatedPointCollection Methods
Add Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
CalculatedPointCollection Properties
CorridorId Property
Count Property
Item Property
CalculatedShape Class
CalculatedShape Members
CalculatedShape Properties
Area Property
CalculatedLinks Property
CorridorCodes Property
CalculatedShapeCollection Class
CalculatedShapeCollection Members
CalculatedShapeCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
CalculatedShapeCollection Properties
CorridorId Property
Count Property
Item Property
CalculatedSubentity Class
CalculatedSubentity Members
CalculatedSubentity Properties
CorridorCodes Property
CorridorId Property
SubassemblyBelongedTo Property
Catchment Class
Catchment Members
Catchment Methods
GetAvailableCatchmentLabelIds Method
GetAvailableFlowSegmentLabelIds Method
GetFlowPath Method
Catchment Properties
CatchmentLabel Class
CatchmentLabel Members
CatchmentLabel Methods
Create Method
Create Method (ObjectId)
Create Method (ObjectId, ObjectId)
GetAvailableLabelIds Method
CatchmentLabel Properties
CodeCollection Class
CodeCollection Members
CodeCollection Methods
Add Method
Add Method (String)
Add Method (String[])
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
TryAdd Method
TryAdd Method (String)
TryAdd Method (String[])
CodeCollection Properties
Count Property
Item Property
CogoPoint Class
CogoPoint Members
CogoPoint Methods
ApplyDescriptionKeys Method
ClearAllLabelTextComponentOverrides Method
ClearLabelTextComponentOverrides Method
GetLabelTextComponentIds Method
GetLabelTextComponentJustificationOverride Method
GetLabelTextComponentOverride Method
GetUDPValue Method
GetUDPValue Method (UDPBoolean)
GetUDPValue Method (UDPDouble)
GetUDPValue Method (UDPEnumeration)
GetUDPValue Method (UDPInteger)
GetUDPValue Method (UDPString)
IsLabelTextComponentOverriden Method
Renumber Method
Renumber Method (UInt32)
Renumber Method (UInt32, PointNumberResolveType)
ResetLabel Method
ResetLabelLocation Method
ResetLabelRotation Method
SetLabelTextComponentJustificationOverride Method
SetLabelTextComponentOverride Method
SetUDPValue Method
SetUDPValue Method (UDPBoolean, Boolean)
SetUDPValue Method (UDPDouble, Double)
SetUDPValue Method (UDPEnumeration, String)
SetUDPValue Method (UDPInteger, Int32)
SetUDPValue Method (UDPString, String)
CogoPoint Properties
Convergence Property
DescriptionFormat Property
Easting Property
Elevation Property
ElevationOverride Property
FullDescription Property
FullDescriptionOverride Property
GridEasting Property
GridNorthing Property
IsCheckedOut Property
IsLabelDragged Property
IsLabelPinned Property
IsLabelVisible Property
IsLocked Property
IsMovable Property
IsProjectPoint Property
IsSurveyPoint Property
LabelLocation Property
LabelRotation Property
LabelStyleId Property
LabelStyleIdOverride Property
Latitude Property
LeaderAttachment Property
LeaderTailVisibility Property
LeaderVisibility Property
Location Property
Longitude Property
MarkerRotation Property
Northing Property
PointName Property
PointNumber Property
PrimaryPointGroupId Property
ProjectVersion Property
RawDescription Property
RawDescriptionOverride Property
Scale Property
ScaleXY Property
ScaleZ Property
ShowToolTip Property
StyleId Property
StyleIdOverride Property
CogoPointCollection Class
CogoPointCollection Members
CogoPointCollection Methods
Add Method
Add Method (Point3d, Boolean)
Add Method (Point3dCollection, Boolean)
Add Method (Point3d, String, Boolean)
Add Method (Point3dCollection, String, Boolean)
Add Method (Point3d, String, Boolean, Boolean, Boolean)
Add Method (Point3dCollection, String, Boolean, Boolean, Boolean)
Clear Method
Contains Method
ExportPoints Method
ExportPoints Method (String, PointFileFormat)
ExportPoints Method (String, PointFileFormat, ObjectId)
ExportPoints Method (String, PointFileFormat, Boolean, Boolean, Boolean)
ExportPoints Method (String, PointFileFormat, Boolean, Boolean, Boolean, ObjectId)
GetCogoPoints Method
GetEnumerator Method
GetObjectEnumerator Method
GetPointByPointNumber Method
ImportPoints Method
ImportPoints Method (String, PointFileFormat)
ImportPoints Method (String, PointFileFormat, ObjectId)
ImportPoints Method (String, PointFileFormat, Boolean, Boolean, Boolean)
ImportPoints Method (String, PointFileFormat, Boolean, Boolean, Boolean, ObjectId)
Remove Method
Remove Method (ObjectId)
Remove Method (UInt32)
SetDescriptionFormat Method
SetDescriptionFormat Method (ObjectId, String)
SetDescriptionFormat Method (IEnumerable(ObjectId), IEnumerable(String))
SetDescriptionFormat Method (IEnumerable(ObjectId), String)
SetEasting Method
SetEasting Method (ObjectId, Double)
SetEasting Method (IEnumerable(ObjectId), IEnumerable(Double))
SetEasting Method (IEnumerable(ObjectId), Double)
SetElevation Method
SetElevation Method (ObjectId, Double)
SetElevation Method (IEnumerable(ObjectId), IEnumerable(Double))
SetElevation Method (IEnumerable(ObjectId), Double)
SetElevationByOffset Method
SetElevationByOffset Method (ObjectId, Double)
SetElevationByOffset Method (IEnumerable(ObjectId), IEnumerable(Double))
SetElevationByOffset Method (IEnumerable(ObjectId), Double)
SetElevationBySurface Method
SetElevationBySurface Method (ObjectId, ObjectId)
SetElevationBySurface Method (IEnumerable(ObjectId), ObjectId)
SetIsLocked Method
SetIsLocked Method (ObjectId, Boolean)
SetIsLocked Method (IEnumerable(ObjectId), Boolean)
SetIsLocked Method (IEnumerable(ObjectId), IEnumerable(Boolean))
SetLabelRotation Method
SetLabelRotation Method (ObjectId, Double)
SetLabelRotation Method (IEnumerable(ObjectId), IEnumerable(Double))
SetLabelRotation Method (IEnumerable(ObjectId), Double)
SetLabelStyleId Method
SetLabelStyleId Method (ObjectId, ObjectId)
SetLabelStyleId Method (IEnumerable(ObjectId), ObjectId)
SetLabelStyleId Method (IEnumerable(ObjectId), IEnumerable(ObjectId))
SetMarkerRotation Method
SetMarkerRotation Method (ObjectId, Double)
SetMarkerRotation Method (IEnumerable(ObjectId), IEnumerable(Double))
SetMarkerRotation Method (IEnumerable(ObjectId), Double)
SetNorthing Method
SetNorthing Method (ObjectId, Double)
SetNorthing Method (IEnumerable(ObjectId), IEnumerable(Double))
SetNorthing Method (IEnumerable(ObjectId), Double)
SetPointName Method
SetPointName Method (ObjectId, String)
SetPointName Method (IEnumerable(ObjectId), IEnumerable(String))
SetPointNumber Method
SetPointNumber Method (ObjectId, UInt32)
SetPointNumber Method (IEnumerable(ObjectId), Int32)
SetRawDescription Method
SetRawDescription Method (ObjectId, String)
SetRawDescription Method (IEnumerable(ObjectId), IEnumerable(String))
SetRawDescription Method (IEnumerable(ObjectId), String)
SetScaleXY Method
SetScaleXY Method (ObjectId, Double)
SetScaleXY Method (IEnumerable(ObjectId), IEnumerable(Double))
SetScaleXY Method (IEnumerable(ObjectId), Double)
SetScaleZ Method
SetScaleZ Method (ObjectId, Double)
SetScaleZ Method (IEnumerable(ObjectId), IEnumerable(Double))
SetScaleZ Method (IEnumerable(ObjectId), Double)
SetShowTooltips Method
SetShowTooltips Method (ObjectId, Boolean)
SetShowTooltips Method (IEnumerable(ObjectId), Boolean)
SetShowTooltips Method (IEnumerable(ObjectId), IEnumerable(Boolean))
SetStyleId Method
SetStyleId Method (ObjectId, ObjectId)
SetStyleId Method (IEnumerable(ObjectId), ObjectId)
SetStyleId Method (IEnumerable(ObjectId), IEnumerable(ObjectId))
CogoPointCollection Properties
Count Property
CogoPointEnumerator Class
CogoPointEnumerator Members
CogoPointEnumerator Methods
Dispose Method
MoveNext Method
Reset Method
CogoPointEnumerator Properties
Current Property
CurrentObject Property
ConnectorPositionType Enumeration
Corridor Class
Corridor Members
Corridor Methods
ExportFeatureLinesAsCogoPoints Method
ExportFeatureLinesAsCogoPoints Method (String, CorridorPointCodeSelector)
ExportFeatureLinesAsCogoPoints Method (String, CorridorPointCodeSelector, ValueType)
GetLinkCodes Method
GetPointCodes Method
GetShapeCodes Method
GetTargets Method
Rebuild Method
SetTargets Method
Corridor Properties
Baselines Property
CodeSetStyleId Property
CodeSetStyleName Property
CorridorSurfaces Property
FeatureLineCodeInfos Property
IsOutOfDate Property
MaximumTriangleSideLength Property
RebuildAutomatic Property
RegionLockMode Property
SlopePatterns Property
CorridorBaselineType Enumeration
CorridorCodeCollection Class
CorridorCodeCollection Members
CorridorCodeCollection Methods
Add Method
Clear Method
GetEnumerator Method
GetObjectEnumerator Method
CorridorCodeCollection Properties
CorridorId Property
Count Property
Item Property
CorridorCollection Class
CorridorCollection Members
CorridorCollection Methods
Add Method
Add Method (String)
Add Method (String, String, ObjectId, ObjectId)
Add Method (String, String, ObjectId, ObjectId, String, ObjectId)
GetEnumerator Method
GetObjectEnumerator Method
CorridorCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
CorridorFeatureLine Class
CorridorFeatureLine Members
CorridorFeatureLine Methods
ExportAsAlignment Method
ExportAsGradingFeatureLine Method
ExportAsGradingFeatureLine Method (ObjectId, Boolean)
ExportAsGradingFeatureLine Method (ObjectId, Boolean, String, ObjectId, ObjectId, GradingSmoothOption)
ExportAsPolyline3d Method
ExportAsPolyline3dCollection Method
ExportAsProfile Method
CorridorFeatureLine Properties
CodeName Property
CorridorId Property
FeatureLinePoints Property
StyleId Property
StyleName Property
CorridorLinkDisplay Enumeration
CorridorLinkDrawOverride Enumeration
CorridorPointCodeOption Class
CorridorPointCodeOption Members
CorridorPointCodeOption Constructor
CorridorPointCodeOption Properties
CodeName Property
Selected Property
CorridorPointCodeSelector Class
CorridorPointCodeSelector Members
CorridorPointCodeSelector Constructor
CorridorPointCodeSelector Methods
GetAllCodes Method
GetEnumerator Method
GetObjectEnumerator Method
SelectAll Method
UnSelectAll Method
CorridorPointCodeSelector Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
CorridorSection Class
CorridorSection Members
CorridorSection Methods
GetCorridor Method
GetLinkCodes Method
GetPointCodes Method
GetShapeCodes Method
SetCorridor Method
SetCorridor Method (ObjectId)
SetCorridor Method (String)
CorridorSection Properties
StyleId Property
StyleName Property
CorridorSlopePattern Class
CorridorSlopePattern Members
CorridorSlopePattern Properties
BaselineId Property
CorridorId Property
EndStation Property
FeatureLine1 Property
FeatureLine2 Property
StartStation Property
StyleId Property
StyleName Property
CorridorSlopePatternCollection Class
CorridorSlopePatternCollection Members
CorridorSlopePatternCollection Methods
Add Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
CorridorSlopePatternCollection Properties
CorridorId Property
Count Property
Item Property
CorridorSurface Class
CorridorSurface Members
CorridorSurface Methods
AddFeatureLineCode Method
AddLinkCode Method
FeatureLineCodeIsBreak Method
FeatureLineCodes Method
FindElevationAtXY Method
GetSampleElevations Method
IsLinkCodeAsBreakLine Method
LinkCodes Method
PointCodes Method
RemoveFeatureLineCode Method
RemoveLinkCode Method
SetLinkCodeAsBreakLine Method
CorridorSurface Properties
Boundaries Property
CorridorId Property
Description Property
IsBuild Property
IsDraw Property
Masks Property
Name Property
OverhangCorrection Property
RenderMaterialId Property
SectionStyleId Property
SurfaceId Property
SurfaceStyleId Property
CorridorSurfaceBaseMask Class
CorridorSurfaceBaseMask Members
CorridorSurfaceBaseMask Methods
PolygonPoints Method
CorridorSurfaceBaseMask Properties
CorridorId Property
Description Property
FeatureLineComponents Property
IsDefinedFromPolygon Property
Name Property
CorridorSurfaceBoundary Class
CorridorSurfaceBoundary Members
CorridorSurfaceBoundary Methods
CorridorSurfaceBoundary Properties
BoundaryType Property
IsCorridorExtents Property
CorridorSurfaceBoundaryCollection Class
CorridorSurfaceBoundaryCollection Members
CorridorSurfaceBoundaryCollection Methods
Add Method
Add Method (String)
Add Method (String, ObjectId)
Add Method (String, Point3dCollection)
Add Method (String, String)
AddCorridorExtentsBoundary Method
BoundaryNames Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (String)
Remove Method (CorridorSurfaceBoundary)
RemoveAt Method
CorridorSurfaceBoundaryCollection Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
CorridorSurfaceBoundaryType Enumeration
CorridorSurfaceCollection Class
CorridorSurfaceCollection Members
CorridorSurfaceCollection Methods
Add Method
Add Method (String)
Add Method (String, ObjectId)
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (String)
Remove Method (CorridorSurface)
RemoveAt Method
SurfaceNames Method
CorridorSurfaceCollection Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
CorridorSurfaceMask Class
CorridorSurfaceMask Members
CorridorSurfaceMask Methods
CorridorSurfaceMask Properties
RenderMaterialId Property
CorridorSurfaceMaskCollection Class
CorridorSurfaceMaskCollection Members
CorridorSurfaceMaskCollection Methods
Add Method
Add Method (String)
Add Method (String, ObjectId)
Add Method (String, Point3dCollection)
Add Method (String, String)
GetEnumerator Method
GetObjectEnumerator Method
MaskNames Method
Remove Method
Remove Method (String)
Remove Method (CorridorSurfaceMask)
RemoveAt Method
CorridorSurfaceMaskCollection Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
CurbReturnJoiningType Enumeration
CurveCurveReverseCurveTransitionDescription Class
CurveCurveReverseCurveTransitionDescription Members
CurveCurveReverseCurveTransitionDescription Properties
FirstCurveRadius Property
ReverseCurveRadius Property
SecondCurveRadius Property
CurveLineCurveTransitionDescription Class
CurveLineCurveTransitionDescription Members
CurveLineCurveTransitionDescription Properties
EntryCurveRadius Property
ExitCurveRadius Property
CurveParamType Enumeration
CurveReverseCurveTransitionDescription Class
CurveReverseCurveTransitionDescription Members
CurveReverseCurveTransitionDescription Properties
EntryCurveRadius Property
ReverseCurveRadius Property
CurveType Enumeration
CustomPointGroupQuery Class
CustomPointGroupQuery Members
CustomPointGroupQuery Constructor
CustomPointGroupQuery Properties
QueryString Property
DatumRoundingType Enumeration
DBObject Class
DBObject Members
DBObject Properties
Application Property
Description Property
Document Property
Name Property
DesignSpeed Class
DesignSpeed Members
DesignSpeed Properties
Comment Property
SpeedNumber Property
Station Property
Value Property
DesignSpeedCollection Class
DesignSpeedCollection Members
DesignSpeedCollection Methods
Add Method
GetDesignSpeed Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (Double)
Remove Method (Int32)
DesignSpeedCollection Properties
Count Property
Item Property
DomainType Enumeration
ElevationRangeType Enumeration
Entity Class
Entity Members
Entity Properties
Application Property
Description Property
DisplayName Property
Document Property
IsReferenceObject Property
IsReferenceStale Property
IsReferenceSubObject Property
IsReferenceValid Property
Name Property
ShowToolTip Property
StyleId Property
StyleName Property
EntityAttachType Enumeration
EntityVerticalConstraintType Enumeration
Feature Class
Feature Members
Feature Methods
IsEditableFeature Method
Feature Properties
IsEditable Property
FeatureLabel Class
FeatureLabel Members
FeatureLabel Methods
GetAvailableLabelsByFeatureId<AeccDbCatchmentAreaLabel> Method
GetAvailableLabelsByFeatureId<AeccDbFlowSegmentLabel> Method
GetAvailableLabelsByFeatureId<AeccDbIntersectionLocationLabel> Method
GetAvailableLabelsByFeatureId<AeccDbParcelFaceLabel> Method
FeatureLabel Properties
FeatureLine Class
FeatureLine Members
FeatureLine Methods
AssignElevationsFromSurface Method
Create Method
DeleteElevationPoint Method
DeletePIPoint Method
Get3dDistanceAtPoint Method
GetBulge Method
GetDeflectionAngleAtPoint Method
GetGradeInAtPoint Method
GetGradeOutAtPoint Method
GetPoints Method
InsertElevationPoint Method
InsertPIPoint Method
MoveToSite Method
SetBulge Method
SetPointElevation Method
FeatureLine Properties
ElevationPointsCount Property
Length2D Property
Length3D Property
MaxElevation Property
MaxGrade Property
MinElevation Property
MinGrade Property
PIPointsCount Property
PointsCount Property
SiteId Property
StyleId Property
StyleName Property
FeatureLineCodeInfo Class
FeatureLineCodeInfo Members
FeatureLineCodeInfo Properties
CodeName Property
CorridorId Property
IsConnect Property
IsConnected Property
IsDraw Property
PayItems Property
FeatureLineCodeInfoCollection Class
FeatureLineCodeInfoCollection Members
FeatureLineCodeInfoCollection Methods
CodeNames Method
GetConnectedFeatureLineCodeInfos Method
GetEnumerator Method
GetObjectEnumerator Method
FeatureLineCodeInfoCollection Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
FeatureLineCollection Class
FeatureLineCollection Members
FeatureLineCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
FeatureLineCollection Properties
ConnectDirection Property
CorridorId Property
Count Property
FeatureLineCodeInfo Property
IsConnectExtraPoints Property
Item Property
FeatureLineCollectionMap Class
FeatureLineCollectionMap Members
FeatureLineCollectionMap Methods
CodeNames Method
GetEnumerator Method
GetObjectEnumerator Method
FeatureLineCollectionMap Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
FeatureLineComponent Class
FeatureLineComponent Members
FeatureLineComponent Properties
BaselineAlignmentId Property
CorridorId Property
EndStation Property
FeatureLine Property
IsReversed Property
StartStation Property
UseEndStation Property
UseStartStation Property
FeatureLineComponentCollection Class
FeatureLineComponentCollection Members
FeatureLineComponentCollection Methods
Add Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
Swap Method
SwapAt Method
Validate Method
FeatureLineComponentCollection Properties
CorridorId Property
Count Property
Item Property
FeatureLinePoint Class
FeatureLinePoint Members
FeatureLinePoint Properties
CorridorId Property
IsBreak Property
Offset Property
Station Property
XYZ Property
FeatureLinePointCollection Class
FeatureLinePointCollection Members
FeatureLinePointCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
FeatureLinePointCollection Properties
CorridorId Property
Count Property
Item Property
FlowDirectionMethodType Enumeration
FlowDirectionType Enumeration
FlowPath Class
FlowPath Members
FlowPath Methods
GetFlowSegmentAt Method
FlowPath Properties
FlowSegmentCount Property
FlowSegment Class
FlowSegmentLabel Class
FlowSegmentLabel Members
FlowSegmentLabel Methods
Create Method
Create Method (FlowSegment)
Create Method (FlowSegment, ObjectId)
GetAvailableLabelIds Method
FlowSegmentLabel Properties
FlowSegmentIndex Property
Ratio Property
GeneralSegmentLabel Class
GeneralSegmentLabel Members
GeneralSegmentLabel Methods
Create Method
Create Method (ObjectId, Double)
Create Method (ObjectId, Double, ObjectId, ObjectId)
GetAvailableLabelIds Method
GeneralSegmentLabel Properties
CurveLabelStyleId Property
LineLabelStyleId Property
Ratio Property
StyleName Property
GeneralSurfaceProperties Class
GeneralSurfaceProperties Members
GeneralSurfaceProperties Properties
MaximumCoordinateX Property
MaximumCoordinateY Property
MaximumElevation Property
MeanElevation Property
MinimumCoordinateX Property
MinimumCoordinateY Property
MinimumElevation Property
NumberOfPoints Property
RevisionNumber Property
GeoEntity Class
GeoEntity Members
GeoEntity Properties
Grading Class
Grading Members
Grading Properties
GradingSmoothOption Structure
GradingSmoothOption Members
GradingSmoothOption Constructor
GradingSmoothOption Properties
ArcInclusionDistance Property
HorizDeviation Property
NeedSmooth Property
WeedingDistance Property
Graph Class
Graph Members
Graph Methods
GetLabelIdsByType<AeccDbOffsetElevLabel> Method
GetLabelIdsByType<AeccDbPipeProfileLabel> Method
GetLabelIdsByType<AeccDbPipeSectionLabel> Method
GetLabelIdsByType<AeccDbSectionGradeBreakLabeling> Method
GetLabelIdsByType<AeccDbSectionMinorOffsetLabeling> Method
GetLabelIdsByType<AeccDbSectionOffsetLabeling> Method
GetLabelIdsByType<AeccDbSectionSegmentLabeling> Method
GetLabelIdsByType<AeccDbSectionViewDepthLabel> Method
GetLabelIdsByType<AeccDbSpanningPipeProfileLabel> Method
GetLabelIdsByType<AeccDbStructureProfileLabel> Method
GetLabelIdsByType<AeccDbStructureSectionLabel> Method
Graph Properties
Location Property
GraphBandSet Class
GraphBandSet Members
GraphBandSet Methods
ImportBandSetStyle Method
SaveAsBandSetStyle Method
GraphBandSet Properties
MatchIncrementToGridIntervals Property
GraphOverride Class
GraphOverride Members
GraphOverride Properties
Draw Property
OverrideStyleId Property
OverrideStyleName Property
UseOverrideStyle Property
GraphOverrideCollection(ItemType) Class
GraphOverrideCollection(ItemType) Members
GraphOverrideCollection(ItemType) Methods
GetEnumerator Method
GetObjectEnumerator Method
GraphOverrideCollection(ItemType) Properties
ClipGridAt Property
Count Property
Item Property
GridLocation Structure
GridLocation Members
GridLocation Constructor
GridLocation Methods
Equals Method
GridLocation Properties
ColumnIndex Property
RowIndex Property
GridSurface Class
GridSurface Members
GridSurface Methods
AddPoint Method
Create Method
Create Method (Database, String, Double, Double, Double)
Create Method (String, Double, Double, Double, ObjectId)
CreateFromDEM Method
CreateFromDEM Method (Database, String)
CreateFromDEM Method (String, ObjectId)
DeleteLine Method
DeleteLines Method
DeletePoint Method
DeletePoints Method
ExtractBorder Method
ExtractContours Method
ExtractContours Method (Double)
ExtractContours Method (Double, ContourSmoothingType, Int32)
ExtractContours Method (Double, Double, Double)
ExtractContours Method (Double, Double, Double, ContourSmoothingType, Int32)
ExtractContoursAt Method
ExtractContoursAt Method (Double)
ExtractContoursAt Method (Double, ContourSmoothingType, Int32)
ExtractGridded Method
ExtractMajorContours Method
ExtractMajorContours Method (SurfaceExtractionSettingsType)
ExtractMajorContours Method (SurfaceExtractionSettingsType, ContourSmoothingType, Int32)
ExtractMinorContours Method
ExtractMinorContours Method (SurfaceExtractionSettingsType)
ExtractMinorContours Method (SurfaceExtractionSettingsType, ContourSmoothingType, Int32)
ExtractWatershed Method
FindCellAtXY Method
FindEdgeAtXY Method
FindVertexAtXY Method
GetCells Method
GetGridProperties Method
GetTerrainProperties Method
GetVertices Method
RaisePoints Method
RaiseSurface Method
SampleElevations Method
SetPointElevation Method
SetPointsElevation Method
GridSurface Properties
Cells Property
DEMFilesDefinition Property
Vertices Property
GridSurfaceCell Class
GridSurfaceCell Members
GridSurfaceCell Methods
Equals Method
GetHashCode Method
GridSurfaceCell Properties
BottomEdge Property
BottomLeftVertex Property
BottomRightVertex Property
GridLocation Property
LeftEdge Property
RightEdge Property
TopEdge Property
TopLeftVertex Property
TopRightVertex Property
GridSurfaceCellCollection Class
GridSurfaceCellCollection Members
GridSurfaceCellCollection Methods
Contains Method
GetAt Method
GetEnumerator Method
GetIndexRange Method
GetObjectEnumerator Method
GridSurfaceCellCollection Properties
Count Property
GridSurfaceCellEnumerator Class
GridSurfaceCellEnumerator Members
GridSurfaceCellEnumerator Methods
Dispose Method
MoveNext Method
Reset Method
GridSurfaceCellEnumerator Properties
Current Property
CurrentObject Property
GridSurfaceEdge Class
GridSurfaceEdge Members
GridSurfaceEdge Methods
Equals Method
GetHashCode Method
GridSurfaceEdge Properties
Cell1 Property
Cell2 Property
IsValid Property
Vertex1 Property
Vertex2 Property
GridSurfaceObject Class
GridSurfaceObject Members
GridSurfaceObject Methods
Dispose Method
GridSurfaceObject Properties
IsValid Property
Surface Property
GridSurfaceProperties Class
GridSurfaceProperties Members
GridSurfaceProperties Properties
Orientation Property
SpacingX Property
SpacingY Property
GridSurfaceVertex Class
GridSurfaceVertex Members
GridSurfaceVertex Methods
Equals Method
GetHashCode Method
GridSurfaceVertex Properties
GridLocation Property
Location Property
GridSurfaceVertexCollection Class
GridSurfaceVertexCollection Members
GridSurfaceVertexCollection Methods
Contains Method
GetAt Method
GetEnumerator Method
GetIndexRange Method
GetObjectEnumerator Method
GridSurfaceVertexCollection Properties
Count Property
GridSurfaceVertexEnumerator Class
GridSurfaceVertexEnumerator Members
GridSurfaceVertexEnumerator Methods
Dispose Method
MoveNext Method
Reset Method
GridSurfaceVertexEnumerator Properties
Current Property
CurrentObject Property
GridVolumeSurface Class
GridVolumeSurface Members
GridVolumeSurface Methods
Create Method
Create Method (String, ObjectId, ObjectId, Double, Double, Double)
Create Method (String, ObjectId, ObjectId, Double, Double, Double, ObjectId)
GetGridProperties Method
GetVolumeProperties Method
GridVolumeSurface Properties
CutFactor Property
FillFactor Property
HardcodedOffsetBaseline Class
HardcodedOffsetBaseline Members
HardcodedOffsetBaseline Methods
SortedStations Method
HardcodedOffsetBaseline Properties
AlignmentId Property
BaselineType Property
Name Property
OffsetElevationFromMainBaseline Property
ProfileId Property
RelatedOffsetBaselineFeatureLines Property
HatchCriteriaBoundaryType Enumeration
HoldOnResizeType Enumeration
HorizontalGeometryBandLabelGroup Class
HorizontalGeometryBandLabelGroup Members
HorizontalGeometryBandLabelGroup Methods
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
HorizontalGeometryBandLabelGroup Properties
IAppliedSubassemblyParam Interface
IAppliedSubassemblyParam Members
IAppliedSubassemblyParam Methods
ClearOverride Method
IAppliedSubassemblyParam Properties
Comment Property
DesignValueAsObject Property
DisplayName Property
IsOverriden Property
KeyName Property
ValueAsObject Property
ValueType Property
ICommonLabel Interface
ICommonLabel Members
ICommonLabel Methods
ClearAllTextComponentOverrides Method
GetReferenceTextTarget Method
GetTextComponentIds Method
GetTextComponentJustificationOverride Method
GetTextComponentOverride Method
IsTextComponentOverriden Method
Reset Method
ResetLocation Method
ResetProperties Method
SetReferenceTextTarget Method
SetTextComponentJustificationOverride Method
SetTextComponentOverride Method
SetTextComponentOverride Method (ObjectId, String)
SetTextComponentOverride Method (ObjectId, String, TextJustificationType)
ICommonLabel Properties
AnchorInfo Property
AnchorMarkerRotationAngle Property
AnchorMarkerStyleId Property
CanRotate Property
DimensionAnchorInfo Property
DimensionAnchorOption Property
DimensionAnchorValue Property
Dragged Property
DraggedOffset Property
Flipped Property
LeaderAttachment Property
LeaderTailVisibility Property
LeaderVisibility Property
Pinned Property
Reversed Property
RotationAngle Property
StyleId Property
ICommonLabelOptions Interface
ICommonLabelOptions Members
ICommonLabelOptions Properties
AllowsAnchorMarker Property
AllowsDimensionAnchors Property
AllowsDragging Property
AllowsFlipping Property
AllowsLeaderAttachment Property
AllowsPinning Property
AllowsReversing Property
DefaultDimensionAnchorOption Property
DefaultDimensionAnchorValue Property
RotationType Property
IGridSurface Interface
IGridSurface Members
IGridSurface Methods
GetGridProperties Method
Interference Class
Interference Members
Interference Properties
Network1Id Property
Network2Id Property
InterferenceCheck Class
InterferenceCheck Members
InterferenceCheck Properties
Intersection Class
Intersection Members
Intersection Methods
GetIntersectionLocaitonLabelIds Method
Intersection Properties
CorridorId Property
GradeRuleType Property
IntersectionRegions Property
IntersectionRoads Property
Location Property
RoadwayDrivingDirection Property
IntersectionCorridorType Enumeration
IntersectionLocationLabel Class
IntersectionLocationLabel Members
IntersectionLocationLabel Methods
Create Method
Create Method (ObjectId)
Create Method (ObjectId, ObjectId)
GetAvailableLabelIds Method
IntersectionLocationLabel Properties
IntersectionRegion Class
IntersectionRegion Members
IntersectionRegion Properties
Angle Property
CurbReturnAlignmentId Property
CurbReturnProfileId Property
InAlignmentId Property
Name Property
OutAlignmentId Property
IntersectionRegionCollection Class
IntersectionRegionCollection Members
IntersectionRegionCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
IntersectionRegionCollection Properties
Count Property
Item Property
IntersectionRoad Class
IntersectionRoad Members
IntersectionRoad Properties
CenterlineAlignmentId Property
CenterlineProfileId Property
OffsetLeftAlignmentId Property
OffsetLeftProfileId Property
OffsetRightAlignmentId Property
OffsetRightProfileId Property
IntersectionRoadCollection Class
IntersectionRoadCollection Members
IntersectionRoadCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
IntersectionRoadCollection Properties
Count Property
Item Property
IPoint Interface
IPoint Members
IPoint Properties
Codes Property
Elevation Property
Index Property
Offset Property
Station Property
ITerrainSurface Interface
ITerrainSurface Members
ITerrainSurface Methods
ExtractBorder Method
ExtractContours Method
ExtractContours Method (Double)
ExtractContours Method (Double, ContourSmoothingType, Int32)
ExtractContours Method (Double, Double, Double)
ExtractContours Method (Double, Double, Double, ContourSmoothingType, Int32)
ExtractContoursAt Method
ExtractContoursAt Method (Double)
ExtractContoursAt Method (Double, ContourSmoothingType, Int32)
ExtractGridded Method
ExtractMajorContours Method
ExtractMajorContours Method (SurfaceExtractionSettingsType)
ExtractMajorContours Method (SurfaceExtractionSettingsType, ContourSmoothingType, Int32)
ExtractMinorContours Method
ExtractMinorContours Method (SurfaceExtractionSettingsType)
ExtractMinorContours Method (SurfaceExtractionSettingsType, ContourSmoothingType, Int32)
ExtractWatershed Method
GetTerrainProperties Method
RaiseSurface Method
SampleElevations Method
ITerrainSurface Properties
DEMFilesDefinition Property
ITinSurface Interface
ITinSurface Members
ITinSurface Methods
GetTinProperties Method
IVolumeSurface Interface
IVolumeSurface Members
IVolumeSurface Methods
GetVolumeProperties Method
IVolumeSurface Properties
CutFactor Property
FillFactor Property
KrigingMethodOptions Class
KrigingMethodOptions Members
KrigingMethodOptions Constructor
KrigingMethodOptions Properties
NuggetEffect Property
SampleVertices Property
SemivariogramModel Property
VariogramParamA Property
VariogramParamC Property
Label Class
Label Members
Label Methods
ClearAllTextComponentOverrides Method
GetReferenceTextTarget Method
GetTextComponentIds Method
GetTextComponentJustificationOverride Method
GetTextComponentOverride Method
IsTextComponentOverriden Method
Reset Method
ResetLocation Method
ResetProperties Method
SetReferenceTextTarget Method
SetTextComponentJustificationOverride Method
SetTextComponentOverride Method
SetTextComponentOverride Method (ObjectId, String)
SetTextComponentOverride Method (ObjectId, String, TextJustificationType)
Label Properties
AnchorInfo Property
AnchorMarkerRotationAngle Property
AnchorMarkerStyleId Property
CanRotate Property
DimensionAnchorInfo Property
DimensionAnchorOption Property
DimensionAnchorValue Property
Dragged Property
DraggedOffset Property
Flipped Property
LabelLocation Property
LeaderAttachment Property
LeaderTailVisibility Property
LeaderVisibility Property
Pinned Property
Reversed Property
RotationAngle Property
StyleId Property
StyleName Property
LabelBase Class
LabelBase Members
LabelBase Properties
AllowsAnchorMarker Property
AllowsDimensionAnchors Property
AllowsDragging Property
AllowsFlipping Property
AllowsLeaderAttachment Property
AllowsPinning Property
AllowsReversing Property
AutoStagger Property
DefaultDimensionAnchorOption Property
DefaultDimensionAnchorValue Property
FeatureId Property
Mask Property
RotationType Property
ViewId Property
LabelGroup Class
LabelGroup Members
LabelGroup Methods
GetAt Method
ResetAllSubCommonLabelLocations Method
ResetAllSubCommonLabelProperties Method
ResetAllSubCommonLabels Method
LabelGroup Properties
DefaultDimensionAnchorOption Property
DefaultDimensionAnchorValue Property
StyleId Property
StyleName Property
SubEntities Property
SubEntityCount Property
LabelGroupSubEntity Class
LabelGroupSubEntity Members
LabelGroupSubEntity Methods
ClearAllTextComponentOverrides Method
GetReferenceTextTarget Method
GetTextComponentIds Method
GetTextComponentJustificationOverride Method
GetTextComponentOverride Method
IsTextComponentOverriden Method
Reset Method
ResetLocation Method
ResetProperties Method
SetReferenceTextTarget Method
SetTextComponentJustificationOverride Method
SetTextComponentOverride Method
SetTextComponentOverride Method (ObjectId, String)
SetTextComponentOverride Method (ObjectId, String, TextJustificationType)
LabelGroupSubEntity Properties
AllowsAnchorMarker Property
AllowsDimensionAnchors Property
AllowsDragging Property
AllowsFlipping Property
AllowsLeaderAttachment Property
AllowsPinning Property
AllowsReversing Property
AnchorInfo Property
AnchorMarkerRotationAngle Property
AnchorMarkerStyleId Property
CanRotate Property
DefaultDimensionAnchorOption Property
DefaultDimensionAnchorValue Property
DimensionAnchorInfo Property
DimensionAnchorOption Property
DimensionAnchorValue Property
Dragged Property
DraggedOffset Property
Flipped Property
Index Property
LabelLocation Property
LeaderAttachment Property
LeaderTailVisibility Property
LeaderVisibility Property
Parent Property
Pinned Property
Reversed Property
RotationAngle Property
RotationType Property
StyleId Property
Visibility Property
LabelSelectionProperties Class
LabelSelectionProperties Members
LabelSelectionProperties Constructor
LabelSelectionProperties Methods
Dispose Method
Instance Method
LabelSelectionProperties Properties
ClearLabelText Property
ClearMultiLabelText Property
EditLabelText Property
FlipLabel Property
Leader Property
LeaderTail Property
ResetLabel Property
ReverseLabel Property
TagLabel Property
ToggleLabelPin Property
LabelType Enumeration
LegendTable Class
LegendTable Members
LegendTable Properties
LinearTransitionDescription Class
LinearTransitionDescription Members
LinearTransitionDescription Properties
TaperInput Property
TaperRatio Property
Link Class
Link Members
Link Properties
Codes Property
Index Property
IsHidden Property
Points Property
LinkCollection Class
LinkCollection Members
LinkCollection Methods
Add Method
Add Method (IPoint[], String)
Add Method (IPoint[], String[])
Add Method (IPoint, IPoint, String)
Add Method (IPoint, IPoint, String[])
Add Method (IPoint[], String, CorridorLinkDisplay)
Add Method (IPoint[], String[], CorridorLinkDisplay)
Add Method (IPoint, IPoint, String, CorridorLinkDisplay)
Add Method (IPoint, IPoint, String[], CorridorLinkDisplay)
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (Int32)
Remove Method (Link)
LinkCollection Properties
Count Property
Item Property
MassHaulLine Class
MassHaulLine Members
MassHaulLine Properties
MassHaulView Class
MassHaulView Members
MassHaulView Properties
MassHaulLineId Property
MatchLine Class
MatchLine Members
MatchLine Properties
GroupId Property
IsLeftLabelVisible Property
IsRightLabelVisible Property
LeftLabelAnchorPosition Property
LeftLabelStyleId Property
RightLabelAnchorPosition Property
RightLabelStyleId Property
MatchLineLabelGroup Class
MatchLineLabelGroup Members
MatchLineLabelGroup Methods
Create Method
Create Method (ObjectId, EntitySideType)
Create Method (ObjectId, EntitySideType, ObjectId, MatchLineLabelLocationType)
GetAvailableLabelGroupIds Method
GetLabelGroupIdBySide Method
MatchLineLabelGroup Properties
Side Property
MaterialConditionType Enumeration
MaterialFactorType Enumeration
MaterialItemType Enumeration
MaterialQuantityType Enumeration
MaterialSection Class
MaterialSection Members
MaterialSection Properties
StyleId Property
StyleName Property
MaterialSectionSource Class
MaterialSectionSource Members
MaterialSectionSource Methods
GetMaterialSectionIds Method
MaterialSectionSource Properties
IsSampled Property
Material Property
SourceType Property
StyleId Property
UpdateMode Property
MaterialSectionSourceCollection Class
MaterialSectionSourceCollection Members
MaterialSectionSourceCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
MaterialSectionSourceCollection Properties
Count Property
Item Property
MaterialVolumeCalculationMethodType Enumeration
MultipleProfileViewsCreationOptions Class
MultipleProfileViewsCreationOptions Members
MultipleProfileViewsCreationOptions Constructor
MultipleProfileViewsCreationOptions Properties
DrawOrder Property
GapBetweenViewsInColumn Property
GapBetweenViewsInRow Property
LengthOfEachView Property
MaxViewInRowOrColumn Property
StartCorner Property
Network Class
Network Members
Network Methods
AddCurvePipe Method
AddLinePipe Method
AddStructure Method
AddStructure Method (ObjectId)
AddStructure Method (ObjectId, ObjectId, Point3d, Double, ObjectId, Boolean)
BreakPipe Method
Create Method
FindShortestNetworkPath Method
GetPipeIds Method
GetSpanningPipePlanLabelIds Method
GetSpanningPipeProfileLabelIds Method
GetStructureIds Method
MoveParts Method
Network Properties
PartsListId Property
PartsListName Property
PipeNameTemplate Property
PipeNetworkSectionLayerId Property
PipeNetworkSectionLayerName Property
PipePlanLabelStyleId Property
PipePlanLabelStyleName Property
PipePlanLayerId Property
PipePlanLayerName Property
PipeProfileLabelStyleId Property
PipeProfileLabelStyleName Property
PipeProfileLayerId Property
PipeProfileLayerName Property
ReferenceAlignmentId Property
ReferenceAlignmentName Property
ReferenceSurfaceId Property
ReferenceSurfaceName Property
StructureNameTemplate Property
StructurePlanLabelStyleId Property
StructurePlanLabelStyleName Property
StructurePlanLayerId Property
StructurePlanLayerName Property
StructureProfileLabelStyleId Property
StructureProfileLabelStyleName Property
StructureProfileLayerId Property
StructureProfileLayerName Property
NetworkCatalogDef Class
NetworkCatalogDef Members
NetworkCatalogDef Methods
DeclareNewParameter Method
DeclarePartProperty Method
NetworkRule Class
NetworkRule Members
NetworkRule Properties
ParamsDouble Property
ParamsLong Property
NoteLabel Class
NoteLabel Members
NoteLabel Methods
Create Method
Create Method (Database, Point3d)
Create Method (Point3d, ObjectId, ObjectId)
GetAvailableLabelIds Method
NoteLabel Properties
OffsetAlignmentInfo Class
OffsetAlignmentInfo Members
OffsetAlignmentInfo Methods
AddAutoWidenings Method
AddAutoWidenings Method (AutoWideningCriteriaInfo, AlignmentSubEntityArc[])
AddAutoWidenings Method (AutoWideningCriteriaInfo, SweptCurveLocation)
AddAutoWidenings Method (AutoWideningInfo, AlignmentSubEntityArc[])
AddAutoWidenings Method (AutoWideningInfo, SweptCurveLocation)
AddWidening Method
OffsetAlignmentInfo Properties
LockMode Property
LockToEndStation Property
LockToStartStation Property
NominalOffset Property
ParentAlignmentId Property
Regions Property
Side Property
Transitions Property
UpdateMode Property
OffsetAlignmentWideningCriteria Class
OffsetAlignmentWideningCriteria Members
OffsetAlignmentWideningCriteria Properties
AttainmentMethod Property
LaneWidth Property
LeftLanesCount Property
MinimumRadiusTableName Property
RightLanesCount Property
SpiralPercentForSC Property
TangentPercentForTC Property
TransitionLengthTableName Property
WheelbaseLength Property
WideningMethod Property
WideningSide Property
OffsetAssembly Class
OffsetAssembly Members
OffsetAssembly Methods
AddSubassembly Method
AddSubassembly Method (ObjectId)
AddSubassembly Method (ObjectId, Point)
CopySubassembly Method
CopySubassembly Method (ObjectId)
CopySubassembly Method (ObjectId, Point)
Dispose Method
InsertSubassemblyAfter Method
InsertSubassemblyBefore Method
MirrorSubassembly Method
MirrorSubassembly Method (ObjectId)
MirrorSubassembly Method (ObjectId, Point)
ReplaceSubassembly Method
OffsetAssembly Properties
AssemblyId Property
Groups Property
Name Property
Offset Property
OffsetAssemblyCollection Class
OffsetAssemblyCollection Members
OffsetAssemblyCollection Methods
Add Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (String)
Remove Method (OffsetAssembly)
RemoveAt Method
OffsetAssemblyCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
OffsetBaseline Class
OffsetBaseline Members
OffsetBaseline Methods
GetOffsetElevationFromMainBaselineStation Method
MainBaselineStationToOffsetBaselineStation Method
OffsetBaselineStationToMainBaselineStation Method
SortedStations Method
OffsetBaseline Properties
AlignmentId Property
BaselineType Property
EndStation Property
EndStationOnMainBaseline Property
Name Property
ProfileId Property
RelatedOffsetBaselineFeatureLines Property
StartStation Property
StartStationOnMainBaseline Property
OffsetBaselineCollection Class
OffsetBaselineCollection Members
OffsetBaselineCollection Methods
GetEnumerator Method
GetObjectEnumerator Method
OffsetBaselineNames Method
OffsetBaselineCollection Properties
CorridorId Property
Count Property
Item Property
Item Property (Int32)
Item Property (String)
OffsetLengthOption Enumeration
OverhangCorrectionType Enumeration
OverriddenStationInfo Structure
OverriddenStationInfo Members
OverriddenStationInfo Fields
IsGeometryOverridden Field
IsParameterOverridden Field
Station Field
Parcel Class
Parcel Members
Parcel Methods
GetAvailableParcelAreaLabelIds Method
ResetAreaSelectionLabel Method
Parcel Properties
AreaLocation Property
AreaSelectionLabelLocation Property
AreaSelectionLabelStyleId Property
Centroid Property
IsAreaSelectionLabelPinned Property
Number Property
ParcelAreaLabel Class
ParcelAreaLabel Members
ParcelAreaLabel Methods
Create Method
Create Method (ObjectId)
Create Method (ObjectId, ObjectId)
GetAvailableLabelIds Method
ParcelAreaLabel Properties
ParcelSegment Class
ParcelSegment Members
ParcelSegment Properties
ParcelSegmentTable Class
ParcelSegmentTable Members
ParcelSegmentTable Properties
ParcelTable Class
ParcelTable Members
ParcelTable Properties
Part Class
Part Members
Part Methods
AddToProfileView Method
AddToSectionView Method
ApplyRules Method
GetOverriddenRuleIds Method
GetProfileViewsDisplayingMe Method
GetSectionViewsDisplayingMe Method
RemoveFromAllProfileViews Method
RemoveFromAllSectionViews Method
RemoveFromProfileView Method
RemoveFromSectionView Method
SwapPartFamilyAndSize Method
Part Properties
ConnectedPartCount Property
Domain Property
Material Property
Name Property
NetworkId Property
NetworkName Property
OverrideRuleSet Property
ParamsBool Property
ParamsDouble Property
ParamsLong Property
ParamsString Property
PartData Property
PartDefId Property
PartDescription Property
PartSizeName Property
PartSubType Property
PartType Property
Position Property
ProfileViewPartId Property
RefAlignmentId Property
RefAlignmentName Property
RefSurfaceId Property
RefSurfaceName Property
RuleSetStyleId Property
RuleSetStyleName Property
SectionViewPartId Property
Solid3dBody Property
SurfaceId Property
WallThickness Property
PartCatalogDataType Enumeration
PartContextType Enumeration
PartDataField Class
PartDataField Members
PartDataField Properties
Context Property
ContextString Property
DataType Property
Description Property
Index Property
IsFromList Property
IsFromRange Property
IsReadOnly Property
Name Property
Units Property
Value Property
ValueList Property
ValueRange Property
PartDataList Class
PartDataList Members
PartDataList Methods
Dispose Method
IsValidValue Method
PartDataList Properties
Context Property
Count Property
DataType Property
Index Property
Item Property
PartDataRange Class
PartDataRange Members
PartDataRange Methods
Dispose Method
IsValidValue Method
PartDataRange Properties
Context Property
DataType Property
Index Property
RangeDefault Property
RangeMax Property
RangeMin Property
PartDataRecord Class
PartDataRecord Members
PartDataRecord Methods
Dispose Method
GetAllDataFields Method
GetDataFieldBy Method
GetDataFieldBy Method (String)
GetDataFieldBy Method (PartContextType)
GetDataFieldBy Method (PartContextType, Int32)
GetMaxIndex Method
GetSupportedContexts Method
PartDef Class
PartDef Members
PartDef Constructor
PartDef Methods
Get3dBody Method
GetBoundingShapeBody Method
GetNetworkPartViewDef Method
GetProfileInFrontView Method
PartParamUsageType Enumeration
PartProfileLabel Class
PartProfileLabel Members
PartProfileLabel Methods
PartProfileLabel Properties
ReferenceAlignmentId Property
PartSectionLabel Class
PartSectionLabel Members
PartSectionLabel Methods
PartSectionLabel Properties
ReferenceAlignmentId Property
PartType Enumeration
PartViewDef Class
PartViewDef Members
PartViewDef Properties
BoundingBodyBlockId Property
BoundingBodyBlockName Property
PartBodyGraphicsBlockId Property
PartBodyGraphicsBlockName Property
PayItemFileFormat Enumeration
Pipe Class
Pipe Members
Pipe Methods
AdjustEndpoint Method
ConnectToPipe Method
ConnectToStructure Method
Disconnect Method
GetAvailablePipeLabelIds Method
GetAvailableSpanningPipeLabelIds Method
GetClosestPointTo Method
GetLabelIds Method
GetParamAtPoint Method
GetPipeLabelIds Method
GetPointAtParam Method
GetProject2dPointVertically Method
IsMaxCoverViolated Method
IsMinCoverViolated Method
ResizeByInnerDiameterOrWidth Method
SetSlopeHoldEnd Method
SetSlopeHoldStart Method
Pipe Properties
Bearing Property
CoverOfEndpoint Property
CoverOfStartPoint Property
CrossSectionalShape Property
Curve2d Property
EndOffset Property
EndPoint Property
EndStation Property
EndStructureId Property
EnergyGradeLineDown Property
EnergyGradeLineUp Property
FlowDirection Property
FlowDirectionMethod Property
FlowRate Property
HoldOnResizeType Property
HydraulicGradeLineDown Property
HydraulicGradeLineUp Property
InnerDiameterOrWidth Property
InnerHeight Property
JunctionLoss Property
Length2D Property
Length2DCenterToCenter Property
Length2DToInsideEdge Property
Length3D Property
Length3DCenterToCenter Property
Length3DToInsideEdge Property
MaximumCover Property
MinimumCover Property
OuterDiameterOrWidth Property
OuterHeight Property
Radius Property
ReturnPeriod Property
Slope Property
StartOffset Property
StartPoint Property
StartStation Property
StartStructureId Property
StyleId Property
SubEntityType Property
PipeEndLocation Enumeration
PipeLabel Class
PipeLabel Members
PipeLabel Methods
Create Method
Create Method (ObjectId, Double)
Create Method (ObjectId, Double, ObjectId)
GetAvailableLabelIds Method
PipeLabel Properties
Ratio Property
ReferenceAlignmentId Property
PipeNetworkBandLabelGroup Class
PipeNetworkBandLabelGroup Members
PipeNetworkBandLabelGroup Methods
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
PipeNetworkBandLabelGroup Properties
PipeProfileLabel Class
PipeProfileLabel Members
PipeProfileLabel Methods
Create Method
Create Method (ObjectId, ObjectId)
Create Method (ObjectId, ObjectId, Double, ObjectId)
GetAvailableLabelIds Method
PipeProfileLabel Properties
Ratio Property
PipeSectionLabel Class
PipeSectionLabel Members
PipeSectionLabel Methods
Create Method
Create Method (ObjectId, ObjectId, ObjectId, Int32)
Create Method (ObjectId, ObjectId, ObjectId, Int32, ObjectId)
GetAvailableLabelIds Method
PipeSectionLabel Properties
PipeSubEntityType Enumeration
Point Class
Point Members
Point Methods
GetXYZ Method
Point Properties
Codes Property
Elevation Property
Index Property
IsHidden Property
IsLoopPoint Property
Offset Property
Station Property
PointCloud Class
PointCloudUtility Class
PointCloudUtility Members
PointCloudUtility Methods
GetCivilPointCloudName Method
IsCivilPointCloud Method
PointCollection Class
PointCollection Members
PointCollection Methods
Add Method
Add Method (Double, Double, String)
Add Method (Double, Double, String[])
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
Remove Method (Int32)
Remove Method (Point)
PointCollection Properties
Count Property
Item Property
PointDescriptionKey Class
PointDescriptionKey Members
PointDescriptionKey Properties
ApplyDrawingScale Property
ApplyFixedLabelRotation Property
ApplyFixedMarkerRotation Property
ApplyFixedScaleFactor Property
ApplyLabelRotationParameter Property
ApplyLabelStyleId Property
ApplyLayerId Property
ApplyMarkerRotationParameter Property
ApplyScaleParameter Property
ApplyScaleXY Property
ApplyScaleZ Property
ApplyStyleId Property
Code Property
FixedLabelRotation Property
FixedMarkerRotation Property
FixedScaleFactor Property
Format Property
LabelRotationParameter Property
LabelStyleId Property
LayerId Property
MarkerRotationParameter Property
RotationDirection Property
ScaleParameter Property
StyleId Property
PointDescriptionKeySet Class
PointDescriptionKeySet Members
PointDescriptionKeySet Methods
Add Method
Clear Method
Contains Method
Contains Method (ObjectId)
Contains Method (String)
GetPointDescriptionKeyIds Method
Remove Method
PointDescriptionKeySet Properties
Count Property
Item Property
PointDescriptionKeySetCollection Class
PointDescriptionKeySetCollection Members
PointDescriptionKeySetCollection Methods
Add Method
Clear Method
Contains Method
Contains Method (ObjectId)
Contains Method (String)
GetEnumerator Method
GetObjectEnumerator Method
GetPointDescriptionKeySets Method
Remove Method
Remove Method (ObjectId)
Remove Method (String)
RemoveAt Method
PointDescriptionKeySetCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
SearchOrder Property
PointFileFormat Class
PointFileFormat Members
PointFileFormat Methods
Equals Method
PointFileFormat Properties
CommentTag Property
Delimiter Property
FileExtension Property
FileFormatType Property
Name Property
PointFileFormatCollection Class
PointFileFormatCollection Members
PointFileFormatCollection Methods
Dispose Method
GetEnumerator Method
GetObjectEnumerator Method
GetPointFileFormats Method
PointFileFormatCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
PointGroup Class
PointGroup Members
PointGroup Methods
ApplyDescriptionKeys Method
ContainsPoint Method
DeletePoints Method
GetPendingChanges Method
GetPointNumbers Method
GetQuery Method
LockPoints Method
SetQuery Method
UnlockPoints Method
Update Method
UseAllClassifications Method
UseCustomClassification Method
UseCustomClassification Method (String)
UseCustomClassification Method (UDPClassification)
UseNoneClassification Method
PointGroup Properties
AllPointsGroupName Property
ElevationOverride Property
IsElevationOverridden Property
IsLocked Property
IsOutOfDate Property
IsPointLabelStyleOverridden Property
IsPointStyleOverridden Property
IsRawDescriptionOverridden Property
Name Property
PointLabelStyleId Property
PointsCount Property
PointStyleId Property
RawDescription Property
RawDescriptionOverride Property
UDPClassificationApplyType Property
UDPClassificationName Property
PointGroupChangeInfo Class
PointGroupChangeInfo Members
PointGroupChangeInfo Properties
PointsToAdd Property
PointsToRemove Property
PointGroupCollection Class
PointGroupCollection Members
PointGroupCollection Methods
Add Method
Contains Method
Contains Method (ObjectId)
Contains Method (String)
GetEnumerator Method
GetObjectEnumerator Method
GetOutOfDatePointGroupIds Method
GetPointGroups Method
Remove Method
Remove Method (ObjectId)
Remove Method (String)
RemoveAt Method
UpdateAllPointGroups Method
PointGroupCollection Properties
AllPointsPointGroupId Property
Count Property
DrawOrder Property
Item Property
Item Property (Int32)
Item Property (String)
PointGroupElevationOverrideInfo Class
PointGroupElevationOverrideInfo Members
PointGroupElevationOverrideInfo Properties
FixedElevation Property
UDP Property
PointGroupOverrideInfo Class
PointGroupOverrideInfo Members
PointGroupOverrideInfo Properties
ActiveOverrideType Property
XDRefId Property
PointGroupOverrideType Enumeration
PointGroupQuery Class
PointGroupQuery Members
PointGroupQuery Properties
QueryString Property
UseCaseSensitiveMatch Property
PointGroupQueryInvalidPointGroupValueException Class
PointGroupQueryInvalidPointGroupValueException Members
PointGroupQueryInvalidPointGroupValueException Methods
PointGroupQueryInvalidPointGroupValueException Properties
InvalidPointGroup Property
PointGroupQueryOperationFailedException Class
PointGroupQueryOperationFailedException Members
PointGroupQueryOperationFailedException Methods
PointGroupQueryOperationFailedException Properties
PointGroupQueryParserException Class
PointGroupQueryParserException Members
PointGroupQueryParserException Methods
PointGroupQueryParserException Properties
Position Property
Query Property
PointGroupQueryToken Class
PointGroupQueryToken Members
PointGroupQueryToken Constructor
PointGroupQueryToken Properties
AND Property
ClosingParenthesis Property
Equal Property
FullDescriptionField Property
GreaterThan Property
GreaterThanOrEqual Property
LessThan Property
LessThanOrEqual Property
NameField Property
NOT Property
NotEqual Property
OpeningParenthesis Property
OR Property
PointElevationField Property
PointGroupField Property
PointNumberField Property
RawDescriptionField Property
SingleQuoteCode Property
ValueDelimiter Property
PointGroupRawDescriptionOverrideInfo Class
PointGroupRawDescriptionOverrideInfo Members
PointGroupRawDescriptionOverrideInfo Properties
FixedRawDescription Property
UDP Property
PointInMem Class
PointInMem Members
PointInMem Constructor
PointInMem Properties
Codes Property
Elevation Property
Index Property
Offset Property
Station Property
PointNumberResolveType Enumeration
PointTable Class
PointTable Members
PointTable Properties
PolylineOptions Structure
PolylineOptions Members
PolylineOptions Methods
Equals Method
Equals Method (Object)
Equals Method (PolylineOptions)
GetHashCode Method
PolylineOptions Operators
Equality Operator
Inequality Operator
PolylineOptions Properties
AddCurvesBetweenTangents Property
EraseExistingEntities Property
PlineId Property
Profile Class
Profile Members
Profile Methods
CreateByLayout Method
CreateByLayout Method (String, ObjectId, ObjectId, ObjectId, ObjectId)
CreateByLayout Method (String, CivilDocument, String, String, String, String)
CreateFromFeatureLine Method
CreateFromSurface Method
CreateFromSurface Method (String, ObjectId, ObjectId, ObjectId, ObjectId, ObjectId)
CreateFromSurface Method (String, CivilDocument, String, String, String, String, String)
CreateFromSurface Method (String, ObjectId, ObjectId, ObjectId, ObjectId, ObjectId, Double, Double, Double)
CreateFromSurface Method (String, CivilDocument, String, String, String, String, String, Double, Double, Double)
ElevationAt Method
GradeAt Method
Profile Properties
AlignmentId Property
DataSourceId Property
DataSourceName Property
DesignCheckSetId Property
DesignCheckSetName Property
DesignSpeedBased Property
ElevationMax Property
ElevationMin Property
EndingStation Property
Entities Property
Length Property
Offset Property
Plinegen Property
ProfileType Property
PVIs Property
StartingStation Property
StyleId Property
StyleName Property
UpdateMode Property
UseDesignCheckSet Property
UseDesignCriteriaFile Property
ProfileBandLabelGroup Class
ProfileBandLabelGroup Members
ProfileBandLabelGroup Methods
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileBandLabelGroup Properties
StyleId Property
StyleName Property
ProfileCircular Class
ProfileCircular Members
ProfileCircular Methods
ProfileCircular Properties
CurveType Property
EntityType Property
GradeChange Property
GradeIn Property
GradeOut Property
HighLowPointElevation Property
HighLowPointStation Property
K Property
M Property
PVIElevation Property
PVIStation Property
Radius Property
TangentOffsetAtPVI Property
ProfileCrestCurveLabelGroup Class
ProfileCrestCurveLabelGroup Members
ProfileCrestCurveLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileCrestCurveLabelGroup Properties
ProfileCriteria Class
ProfileCriteria Members
ProfileCriteria Properties
BoundaryType Property
ProfileId Property
ProfileName Property
ProfileCriteriaCollection Class
ProfileCriteriaCollection Members
ProfileCriteriaCollection Methods
Add Method
GetEnumerator Method
GetObjectEnumerator Method
RemoveAt Method
ProfileCriteriaCollection Properties
Count Property
Item Property
ProfileDataBandLabelGroup Class
ProfileDataBandLabelGroup Members
ProfileDataBandLabelGroup Methods
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileDataBandLabelGroup Properties
ProfileEntity Class
ProfileEntity Members
ProfileEntity Methods
DesignChecks Method
ValidateDesignCheck Method
ProfileEntity Properties
Constraint1 Property
Constraint2 Property
EndElevation Property
EndStation Property
EntityAfter Property
EntityBefore Property
EntityId Property
EntityType Property
HighestDesignSpeed Property
Length Property
MinimumKValueHSD Property
MinimumKValuePSD Property
MinimumKValueSSD Property
StartElevation Property
StartStation Property
ProfileEntityCollection Class
ProfileEntityCollection Members
ProfileEntityCollection Methods
AddFixedSymmetricParabolaByEntityEndAndThroughPoint Method
AddFixedSymmetricParabolaByEntityEndAndThroughPoint Method (UInt32, Point2d)
AddFixedSymmetricParabolaByEntityEndAndThroughPoint Method (UInt32, Point3d)
AddFixedSymmetricParabolaByThreePoints Method
AddFixedSymmetricParabolaByThreePoints Method (Point2d, Point2d, Point2d)
AddFixedSymmetricParabolaByThreePoints Method (Point3d, Point3d, Point3d)
AddFixedSymmetricParabolaByTwoPointsAndEndGrade Method
AddFixedSymmetricParabolaByTwoPointsAndEndGrade Method (Point2d, Point2d, Double)
AddFixedSymmetricParabolaByTwoPointsAndEndGrade Method (Point3d, Point3d, Double)
AddFixedSymmetricParabolaByTwoPointsAndK Method
AddFixedSymmetricParabolaByTwoPointsAndK Method (Point2d, Point2d, VerticalCurveType, Double)
AddFixedSymmetricParabolaByTwoPointsAndK Method (Point3d, Point3d, VerticalCurveType, Double)
AddFixedSymmetricParabolaByTwoPointsAndRadius Method
AddFixedSymmetricParabolaByTwoPointsAndRadius Method (Point2d, Point2d, VerticalCurveType, Double)
AddFixedSymmetricParabolaByTwoPointsAndRadius Method (Point3d, Point3d, VerticalCurveType, Double)
AddFixedSymmetricParabolaByTwoPointsAndStartGrade Method
AddFixedSymmetricParabolaByTwoPointsAndStartGrade Method (Point2d, Point2d, Double)
AddFixedSymmetricParabolaByTwoPointsAndStartGrade Method (Point3d, Point3d, Double)
AddFixedTangent Method
AddFixedTangent Method (Point2d, Point2d)
AddFixedTangent Method (Point3d, Point3d)
AddFixedTangentWithPreviousEntity Method
AddFixedTangentWithPreviousEntity Method (UInt32, Point2d, Point2d)
AddFixedTangentWithPreviousEntity Method (UInt32, Point3d, Point3d)
AddFloatingSymmetricParabolaByThroughPointAndGrade Method
AddFloatingSymmetricParabolaByThroughPointAndGrade Method (UInt32, Point2d, Double, EntityAttachType)
AddFloatingSymmetricParabolaByThroughPointAndGrade Method (UInt32, Point3d, Double, EntityAttachType)
AddFloatingSymmetricParabolaByThroughPointAndK Method
AddFloatingSymmetricParabolaByThroughPointAndK Method (UInt32, Point2d, Double, EntityAttachType)
AddFloatingSymmetricParabolaByThroughPointAndK Method (UInt32, Point3d, Double, EntityAttachType)
AddFloatingSymmetricParabolaByThroughPointAndRadius Method
AddFloatingSymmetricParabolaByThroughPointAndRadius Method (UInt32, Point2d, Double, EntityAttachType)
AddFloatingSymmetricParabolaByThroughPointAndRadius Method (UInt32, Point3d, Double, EntityAttachType)
AddFloatingTangent Method
AddFloatingTangent Method (UInt32, Point2d, EntityAttachType)
AddFloatingTangent Method (UInt32, Point3d, EntityAttachType)
AddFreeAsymmetricParabolaByPVIAndLengths Method
AddFreeCircularCurveByPVIAndLength Method
AddFreeCircularCurveByPVIAndRadius Method
AddFreeCircularCurveByPVIAndThroughPoint Method
AddFreeCircularCurveByPVIAndThroughPoint Method (ProfilePVI, Point2d)
AddFreeCircularCurveByPVIAndThroughPoint Method (ProfilePVI, Point3d)
AddFreeSymmetricParabolaByK Method
AddFreeSymmetricParabolaByLength Method
AddFreeSymmetricParabolaByPVIAndCurveLength Method
AddFreeSymmetricParabolaByPVIAndK Method
AddFreeSymmetricParabolaByPVIAndThroughPoint Method
AddFreeSymmetricParabolaByPVIAndThroughPoint Method (ProfilePVI, Point2d)
AddFreeSymmetricParabolaByPVIAndThroughPoint Method (ProfilePVI, Point3d)
AddFreeSymmetricParabolaByRadius Method
AddFreeTangent Method
Clear Method
EntityAtId Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
RemoveAt Method
ProfileEntityCollection Properties
Count Property
FirstEntity Property
Item Property
LastEntity Property
ProfileEntityConstraintType Enumeration
ProfileEntityType Enumeration
ProfileHatchArea Class
ProfileHatchArea Members
ProfileHatchArea Properties
Criteria Property
Name Property
ShapeStyleId Property
ShapeStyleName Property
ProfileHatchAreaCollection Class
ProfileHatchAreaCollection Members
ProfileHatchAreaCollection Methods
Add Method
GetEnumerator Method
GetObjectEnumerator Method
Remove Method
ProfileHatchAreaCollection Properties
Count Property
Item Property
Item Property (Int32)
Item Property (String)
ProfileHorizontalGeometryPointLabelGroup Class
ProfileHorizontalGeometryPointLabelGroup Members
ProfileHorizontalGeometryPointLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
GetGeometryPointsOptions Method
SetGeometryPointsOptions Method
ProfileHorizontalGeometryPointLabelGroup Properties
StaggerLineHeight1 Property
StaggerLineHeight2 Property
ProfileLabelGroup Class
ProfileLabelGroup Members
ProfileLabelGroup Methods
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileLabelGroup Properties
ProfileLineLabelGroup Class
ProfileLineLabelGroup Members
ProfileLineLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileLineLabelGroup Properties
Weeding Property
ProfileMinorStationLabelGroup Class
ProfileMinorStationLabelGroup Members
ProfileMinorStationLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileMinorStationLabelGroup Properties
MajorStationLabelGroup Property
ProfileOverride Class
ProfileOverride Members
ProfileOverride Methods
GetLabelGroupIds Method
GetProfileLabelGroupIds Method
ProfileOverride Properties
OverrideStyleId Property
OverrideStyleName Property
ProfileId Property
ProfileName Property
ProfileOverrideCollection Class
ProfileOverrideCollection Members
ProfileOverrideCollection Methods
GetEnumerator Method
ProfileOverrideCollection Properties
SplitAt Property
ProfileParabolaAsymmetric Class
ProfileParabolaAsymmetric Members
ProfileParabolaAsymmetric Methods
ProfileParabolaAsymmetric Properties
AsymmetricLength1 Property
AsymmetricLength2 Property
CurveType Property
EntityType Property
GradeChange Property
GradeIn Property
GradeOut Property
HighLowPointElevation Property
HighLowPointStation Property
K Property
PVIElevation Property
PVIStation Property
TangentOffsetAtPVI Property
ProfileParabolaSymmetric Class
ProfileParabolaSymmetric Members
ProfileParabolaSymmetric Methods
GetHeadlightSightDistance Method
GetPassingSightDistance Method
GetStoppingSightDistance Method
SetHeadlightSightDistance Method
SetPassingSightDistance Method
SetStoppingSightDistance Method
ProfileParabolaSymmetric Properties
CurveType Property
EntityType Property
GradeAtThroughPoint1 Property
GradeAtThroughPoint2 Property
GradeChange Property
GradeIn Property
GradeOut Property
HighLowPointElevation Property
HighLowPointStation Property
K Property
M Property
PVIElevation Property
PVIStation Property
Radius Property
TangentOffsetAtPVI Property
ThroughPoint1Elevation Property
ThroughPoint1Station Property
ThroughPoint2Elevation Property
ThroughPoint2Station Property
ThroughPoint3Elevation Property
ThroughPoint3Station Property
ProfileProjection Class
ProfileProjection Members
ProfileProjection Properties
ProfileProjectionLabel Class
ProfileProjectionLabel Members
ProfileProjectionLabel Methods
Create Method
ProfileProjectionLabel Properties
ProjectionSourceId Property
ProfilePVI Class
ProfilePVI Members
ProfilePVI Properties
Elevation Property
EntityAfter Property
EntityBefore Property
GradeIn Property
GradeOut Property
HeadlightSightDistance Property
PassingSightDistance Property
PVIType Property
Station Property
StoppingSightDistance Property
VerticalCurve Property
ProfilePVICollection Class
ProfilePVICollection Members
ProfilePVICollection Methods
AddPVI Method
AddPVIArc Method
AddPVIAsymParabola Method
AddPVISymParabola Method
GetEnumerator Method
GetObjectEnumerator Method
GetPVIAt Method
Remove Method
RemoveAt Method
RemoveAt Method (Int32)
RemoveAt Method (Double, Double)
ProfilePVICollection Properties
Count Property
Item Property
ProfilePVILabelGroup Class
ProfilePVILabelGroup Members
ProfilePVILabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfilePVILabelGroup Properties
StaggerLineHeight1 Property
StaggerLineHeight2 Property
Weeding Property
ProfileSagCurveLabelGroup Class
ProfileSagCurveLabelGroup Members
ProfileSagCurveLabelGroup Methods
Create Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileSagCurveLabelGroup Properties
ProfileStationLabelGroup Class
ProfileStationLabelGroup Members
ProfileStationLabelGroup Methods
Create Method
CreateMajor Method
GetAvailableLabelGroupIds Method
GetAvailableLabelGroups Method
ProfileStationLabelGroup Properties
Increment Property
StaggerLineHeight1 Property
StaggerLineHeight2 Property
ProfileTangent Class
ProfileTangent Members
ProfileTangent Methods
ProfileTangent Properties
EntityType Property
Grade Property
ThroughPoint1Elevation Property
ThroughPoint1Station Property
ThroughPoint2Elevation Property
ThroughPoint2Station Property
ProfileType Enumeration
ProfileUpdateType Enumeration
ProfileView Class
ProfileView Members
ProfileView Methods
Create Method
Create Method (ObjectId, Point3d)
Create Method (ObjectId, Point3d, SplitProfileViewCreationOptions)
Create Method (ObjectId, Point3d, StackedProfileViewsCreationOptions)
Create Method (ObjectId, Point3d, StackedProfileViewsCreationOptions, SplitProfileViewCreationOptions)
Create Method (ObjectId, Point3d, String, ObjectId, ObjectId)
Create Method (ObjectId, Point3d, String, ObjectId, StackedProfileViewsCreationOptions)
Create Method (CivilDocument, String, ObjectId, ObjectId, Point3d)
Create Method (CivilDocument, String, String, String, Point3d)
Create Method (ObjectId, Point3d, String, ObjectId, ObjectId, SplitProfileViewCreationOptions)
Create Method (ObjectId, Point3d, String, ObjectId, StackedProfileViewsCreationOptions, SplitProfileViewCreationOptions)
CreateMultiple Method
CreateMultiple Method (ObjectId, Point3d, MultipleProfileViewsCreationOptions)
CreateMultiple Method (ObjectId, Point3d, StackedProfileViewsCreationOptions, MultipleProfileViewsCreationOptions)
CreateMultiple Method (ObjectId, Point3d, MultipleProfileViewsCreationOptions, SplitProfileViewCreationOptions, ProfileViewDatumType)
CreateMultiple Method (ObjectId, Point3d, StackedProfileViewsCreationOptions, MultipleProfileViewsCreationOptions, SplitProfileViewCreationOptions, ProfileViewDatumType)
CreateMultiple Method (ObjectId, Point3d, String, ObjectId, ObjectId, MultipleProfileViewsCreationOptions)
CreateMultiple Method (ObjectId, Point3d, String, ObjectId, StackedProfileViewsCreationOptions, MultipleProfileViewsCreationOptions)
CreateMultiple Method (ObjectId, Point3d, String, ObjectId, ObjectId, MultipleProfileViewsCreationOptions, SplitProfileViewCreationOptions, ProfileViewDatumType)
CreateMultiple Method (ObjectId, Point3d, String, ObjectId, StackedProfileViewsCreationOptions, MultipleProfileViewsCreationOptions, SplitProfileViewCreationOptions, ProfileViewDatumType)
FindStationAndElevationAtXY Method
FindXYAtStationAndElevation Method
GetAvailablePipeProfileLabelIds Method
GetAvailableSpanningPipeProfileLabelIds Method
GetAvailableStructureProfileLabelIds Method
GetLabelIds Method
GetProfileViewLabelIds Method
ProfileView Properties
AlignmentId Property
AlignmentName Property
Bands Property
ElevationMax Property
ElevationMin Property
ElevationRangeMode Property
GraphOverrides Property
HatchAreas Property
SplitDataLines Property
SplitDatumRounding Property
SplitHeight Property
SplitProfileView Property
SplitStationMode Property