Defines the label style type.
Namespace: Autodesk.Civil.DatabaseServices.StylesAssembly: AeccDbMgd (in AeccDbMgd.dll) Version: 10.3.488.0
Syntax
C# |
---|
public enum LabelStyleType |
Visual Basic |
---|
Public Enumeration LabelStyleType |
Visual C++ |
---|
public enum class LabelStyleType |
Members
Member name | Value | Description | |
---|---|---|---|
SectionSegment | 251704402 | ||
Appurtenance | 251704727 | ||
Fitting | 251704726 | ||
PressurePipe | 251704725 | ||
CatchmentArea | 251704720 | ||
AlignmentSpiral | 251704329 | ||
AlignmentCurve | 251704330 | ||
AlignmentLine | 251704328 | ||
ParcelCurve | 251704372 | ||
ParcelLine | 251704371 | ||
CatchmentFlowSegment | 251704721 | ||
ProfileCrestCurve | 251704342 | ||
ProfileSagCurve | 251704341 | ||
SectionBandIncrementalDistance | 268563024 | ||
SectionBandSampleLineVertices | 268562992 | ||
SectionBandGradeBreaks | 268563008 | ||
SectionBandCenterline | 268562976 | ||
SectionBandMinorIncrement | 268562960 | ||
SectionBandMajorIncrement | 268562944 | ||
SectionBandSegmentSurfaceLabels | 268563200 | ||
ProfileBandPipeNetworkPipeLocation | 268547648 | ||
ProfileBandPipeNetworkStructureLocation | 268547632 | ||
ProfileBandSectionalDataIncrementalSectionData | 268547680 | ||
ProfileBandSectionalDataSampleLineLocation | 268547664 | ||
ProfileBandSuperelevationDataSlopeTransition | 268547408 | ||
ProfileBandSuperelevationDataShoulderCritical | 268547616 | ||
ProfileBandSuperelevationDataFullSuper | 268547376 | ||
ProfileBandSuperelevationDataReverseCrown | 268547360 | ||
ProfileBandSuperelevationDataLevelCrown | 268547392 | ||
ProfileBandSuperelevationDataNormalCrown | 268547328 | ||
ProfileBandHorizontalGeometryPointOfIntersection | 268547120 | ||
ProfileBandHorizontalGeometrySpiral | 268547104 | ||
ProfileBandHorizontalGeometryCurve | 268547088 | ||
ProfileBandHorizontalGeometryTangent | 268547072 | ||
ProfileBandVerticalGeometrySagCurve | 268546864 | ||
ProfileBandVerticalGeometryCrestCurve | 268546848 | ||
ProfileBandVerticalGeometryDownhillTangent | 268546832 | ||
ProfileBandVerticalGeometryUphillTangent | 268546816 | ||
ProfileBandIncrementalDistance | 268546640 | ||
ProfileBandStationEquation | 268546624 | ||
ProfileBandVGP | 268546608 | ||
ProfileBandHGP | 268546592 | ||
ProfileBandMinorIncrement | 268546576 | ||
ProfileBandMajorIncrement | 268546560 | ||
MatchLineRight | 251704609 | ||
MatchLineLeft | 251704608 | ||
ViewFrame | 251704607 | ||
IntersectionLocationLabels | 251704697 | ||
StructureLabelStyle | 251704380 | ||
PipeCrossSection | 251704412 | ||
PipePlanProfile | 251704379 | ||
SectionViewProjection | 251704695 | ||
SectionViewGrade | 251704404 | ||
SectionViewOffsetElevation | 251704403 | ||
SectionGradeBreak | 251704401 | ||
SectionMinorOffset | 251704400 | ||
SectionMajorOffset | 251704399 | ||
SampleLineLabelStyles | 268607503 | ||
ProfileViewProjection | 251704694 | ||
ProfileViewDepth | 251704347 | ||
ProfileViewStationElevation | 251704346 | ||
ProfileCurve | 251704339 | ||
ProfileLine | 251704338 | ||
ProfileGradeBreaks | 251704340 | ||
ProfileHorizontalGeometryPoint | 251704335 | ||
ProfileMinorStation | 251704334 | ||
ProfileMajorStation | 251704333 | ||
AlignmentPointOfIntersection | 251704833 | ||
AlignmentTangentIntersection | 251704327 | ||
AlignmentStationOffset | 251704326 | ||
AlignmentSuperelevationCriticalPoints | 251704331 | ||
AlignmentDesignSpeed | 251704325 | ||
AlignmentStationEquation | 251704324 | ||
AlignmentProfileGeometryPoint | 251704832 | ||
AlignmentGeometryPoint | 251704323 | ||
AlignmentMinorStation | 251704322 | ||
AlignmentMajorStation | 251704321 | ||
ParcelArea | 251704370 | ||
SurfaceWatershed | 251704397 | ||
SurfaceSpotElevation | 251704369 | ||
SurfaceSlope | 251704367 | ||
SurfaceContour | 251704366 | ||
Point | 268481548 | ||
GeneralShape | 251704408 | ||
GeneralLink | 251704406 | ||
GeneralMarker | 251704407 | ||
GeneralCurve | 251704376 | ||
GeneralLine | 251704375 | ||
GeneralNote | 251704374 |