The profile lable set wrapper class.

Namespace: Autodesk.Civil.DatabaseServices.Styles
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 10.3.488.0

Syntax

C#
public sealed class ProfileLabelSetStyle : BaseLabelSetStyle, 
	IEnumerable<ProfileLabelSetItem>
Visual Basic
Public NotInheritable Class ProfileLabelSetStyle _
	Inherits BaseLabelSetStyle _
	Implements IEnumerable(Of ProfileLabelSetItem)
Visual C++
public ref class ProfileLabelSetStyle sealed : public BaseLabelSetStyle, 
	IEnumerable<ProfileLabelSetItem^>

Inheritance Hierarchy

System..::..Object
  System..::..MarshalByRefObject
    DisposableWrapper
      RXObject
        Drawable
          DBObject
            Autodesk.Civil.DatabaseServices..::..DBObject
              Autodesk.Civil.DatabaseServices.Styles..::..StyleBase
                Autodesk.Civil.DatabaseServices.Styles..::..BaseLabelSetStyle
                  Autodesk.Civil.DatabaseServices.Styles..::..ProfileLabelSetStyle

See Also