The TinVolumeSurface class. This class encapsulates a TIN volume surface.

Namespace: Autodesk.Civil.DatabaseServices
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 10.3.488.0

Syntax

C#
public sealed class TinVolumeSurface : Surface, 
	ITinSurface, IVolumeSurface
Visual Basic
Public NotInheritable Class TinVolumeSurface _
	Inherits Surface _
	Implements ITinSurface, IVolumeSurface
Visual C++
public ref class TinVolumeSurface sealed : public Surface, 
	ITinSurface, IVolumeSurface

Remarks

A TIN volume surface is a composite surface created from a combination of points in a top (comparison) and base surface, also known as a differential surface.

Inheritance Hierarchy

System..::..Object
  System..::..MarshalByRefObject
    DisposableWrapper
      RXObject
        Drawable
          DBObject
            Entity
              Curve
                Entity
                  Autodesk.Civil.DatabaseServices..::..Entity
                    Autodesk.Civil.DatabaseServices..::..Surface
                      Autodesk.Civil.DatabaseServices..::..TinVolumeSurface

See Also