The Surface type exposes the following members.

Methods

  NameDescription
Public methodCreateSnapshot
Creates a snapshot that contains the current state of points and triangles resulting from previous Surface operations. A snapshot can improve the performance of Surface builds from subsequent operations.
Public methodExportToDEM(String, String, Double, ExportDetermineElevationType)
Exports the Surface to a DEM file.
Public methodExportToDEM(String, String, Double, ExportDetermineElevationType, Boolean, Single)
Exports the surface to a DEM file, with an optional custom value for null elevation.
Public methodFindDirectionAtXY
Gets the direction of the Surface at the specified location (x, y).
Public methodFindElevationAtXY
Gets the elevation of the Surface at the specified location (x, y).
Public methodFindSlopeAtXY
Gets the slope of the Surface at the specified location (x, y).
Public methodGetBoundedVolumes(Point3dCollection)
Calculates the volume of an area defined by several points.
Public methodGetBoundedVolumes(Point3dCollection, Double)
Calculate the volume of an area defined by several points.
Public methodGetGeneralProperties
Gets the general properties of the surface.
Public methodGetIntersectionPoint
Gets the intersection point with surface by the specified point and vector.
Public methodStatic memberGetProperty<Autodesk::Civil::DatabaseServices::GeneralSurfaceProperties>
Public methodStatic memberGetProperty<Autodesk::Civil::DatabaseServices::GridSurfaceProperties>
Public methodStatic memberGetProperty<Autodesk::Civil::DatabaseServices::TerrainSurfaceProperties>
Public methodStatic memberGetProperty<Autodesk::Civil::DatabaseServices::TinSurfaceProperties>
Public methodStatic memberGetProperty<Autodesk::Civil::DatabaseServices::VolumeSurfaceProperties>
Public methodRebuild
Rebuilds the surface by processing all the operations one by one in the list.
Public methodRebuildSnapshot
Rebuilds the snapshot for the surface.
Public methodRemoveSnapshot
Removes the existing snapshot for the surface.

Properties

  NameDescription
Public propertyAnalysis
Gets a SurfaceAnalysis object that exposes the surface analysis properties for the Surface.
Public propertyBoundariesDefinition
Gets the collection of boundaries associated with the Surface.
Public propertyBuildOptions
Gets an object that encapsulates options applied to building or re-building a Surface.
Public propertyHasSnapshot
Gets a boolean value that specifies whether the surface has a snapshot.
Public propertyIsOutOfDate
Gets whether this surface is out-of-date.
Public propertyIsSnapshotOutOfDate
Gets whether the snapshot in the surface is out-of-date.
Public propertyIsVolumeSurface
Gets whether the surface is a volume surface.
Public propertyLock
Gets or sets whether the Civil 3D GUI shows this surface as locked.
Public propertyMasks
Gets all the masks in the Surface.
Public propertyOperations
Gets the operation list for the Surface.
Public propertyStyleId
Sets the Surface's style Id.
(Overrides Entity..::..StyleId.)

See Also