The InterferenceStyle type exposes the following members.

Methods

  NameDescription
Public methodGetDisplayStyleModel
Gets the DisplayStyle object that defines the model style for the component indicated by the specified InterferenceDisplayStyleType value.
Public methodGetDisplayStylePlan
Gets the DisplayStyle object that defines the Plan style for the component indicated by the specified InterferenceDisplayStyleType value.
Public methodGetDisplayStyleSection
Gets the DisplayStyle object that defines the Section style for the component indicated by the specified InterferenceDisplayStyleType value.

Properties

  NameDescription
Public propertyAbsoluteModelSize
Gets or sets the absolute model size.
Public propertyDrawingScaleModelSize
Gets or sets the drawing scale model size.
Public propertyMarkerStyle
Gets or sets the marker style.
Public propertyModelOptions
Gets or sets the model options, TrueSolid or Sphere.
Public propertyModelSizeOptions
Gets or sets the model size options, UseAbsoluteUnits or UseDrawingScale.
Public propertyModelSizeType
Gets or sets the interference size type, SolidExtents or UserDefined.

See Also