The SuperelevationDataBandStyle type exposes the following members.

Methods

  NameDescription
Public methodGetDisplayStylePlan
Gets the DisplayStyle object that specifies plan display properties for the SuperelevationData component.

Properties

  NameDescription
Public propertyBandType
Gets the BandType enum value that specifies the type of data band data.
(Overrides BandStyle..::..BandType.)
Public propertyFullSuperLabelStyleId
Gets the band label style id at the full super.
Public propertyFullSuperTickStyle
Gets the band tick style at the full super.
Public propertyLevelCrownLabelStyleId
Gets the band label style id at the level crown.
Public propertyLevelCrownTickStyle
Gets the band tick style at the level crown.
Public propertyNormalCrownLabelStyleId
Gets the band label style id at the normal crown.
Public propertyNormalCrownTickStyle
Gets the band tick style at the normal crown.
Public propertyReverseCrownLabelStyleId
Gets the band label style id at the reverse crown.
Public propertyReverseCrownTickStyle
Gets the band tick style at the reverse crown.
Public propertyShoulderCriticalPointsLabelStyleId
Gets the band label style id at the shoulder critical points.
Public propertyShoulderCriticalPointsTickStyle
Gets the band tick style at the shoulder critical points.
Public propertySlopeTransitionRegionLabelStyleId
Gets the band label style id at the slope transition region.
Public propertySlopeTransitionRegionTickStyle
Gets the band tick style at the slope transition region.
Public propertyTitleTextLabelStyleId
Gets the band profile data title text label style.
(Overrides BandStyle..::..TitleTextLabelStyleId.)

See Also