The ProfileDataBandStyle type exposes the following members.

Methods

  NameDescription
Public methodGetDisplayStylePlan
Gets the DisplayStyle object that specifies plan display properties for the ProfileData component.

Properties

  NameDescription
Public propertyBandType
Gets the BandType enum value that specifies the type of data band data.
(Overrides BandStyle..::..BandType.)
Public propertyHGPLabelStyleId
Gets the band profile data label style id at the horizontal geometry point (HGP).
Public propertyHGPTickStyle
Gets the band profile data tick style at the horizontal geometry point (HGP).
Public propertyIncrementalDistanceLabelStyleId
Gets the band profile data label style id at the incremental distance.
Public propertyMajorIncrementLabelStyleId
Gets the band profile data label style id at the major increment.
Public propertyMajorIncrementTickStyle
Gets the band profile data tick style at the major increment.
Public propertyMinorIncrementLabelStyleId
Gets the band profile data label style id at the minor increment.
Public propertyMinorIncrementTickStyle
Gets the band profile data tick style at the minor increment.
Public propertyStationEquationLabelStyleId
Gets the band profile data label style id at the station equation.
Public propertyStationEquationTickStyle
Gets the band profile data tick style at the station equation.
Public propertyTitleTextLabelStyleId
Gets the band profile data title text label style.
(Overrides BandStyle..::..TitleTextLabelStyleId.)
Public propertyVGPLabelStyleId
Gets the band profile data label style id at the vertical geometry point (VGP).
Public propertyVGPTickStyle
Gets the band profile data tick style at the vertical geometry point (VGP).

See Also