Used to control the visual style of various roadway shape objects. Also used to style ProfileView ProfileHatchArea objects. ShapeStyle objects defined for a drawing are kept in the
CivilDocument::Styles::ShapeStyles collection.
Namespace: Autodesk.Civil.DatabaseServices.StylesAssembly: AeccDbMgd (in AeccDbMgd.dll) Version: 10.3.488.0
Syntax
C# |
---|
public sealed class ShapeStyle : SubassemblySubentityStyle |
Visual Basic |
---|
Public NotInheritable Class ShapeStyle _ Inherits SubassemblySubentityStyle |
Visual C++ |
---|
public ref class ShapeStyle sealed : public SubassemblySubentityStyle |
Examples

1// Create a new shape style and change it so that it has 2// an orange border and a yellow hatch fill. 3objId = doc.Styles.ShapeStyles.Add("Style3"); 4ShapeStyle oShapeStyle = ts.GetObject(objId, OpenMode.ForWrite) as ShapeStyle; 5// 50 = yellow 6oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.AreaFill).Color = Color.FromColorIndex(ColorMethod.ByAci, 50); 7oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.AreaFill).Visible = true; 8//oShapeStyle. GetDisplayStylePlan(ShapeDisplayStyleType.Border). HatchType = HatchType.PreDefined; 9// oShapeStyle.AreaFillHatchDisplayStylePlan.Pattern = "LINE"; 10// 30 = orange 11oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.Border).Color = Color.FromColorIndex(ColorMethod.ByAci, 30); 12oShapeStyle.GetDisplayStylePlan(ShapeDisplayStyleType.Border).Visible = true; 13 14ts.Commit();
Inheritance Hierarchy
System..::..Object
System..::..MarshalByRefObject
DisposableWrapper
RXObject
Drawable
DBObject
Autodesk.Civil.DatabaseServices..::..DBObject
Autodesk.Civil.DatabaseServices.Styles..::..StyleBase
Autodesk.Civil.DatabaseServices.Styles..::..SubassemblySubentityStyle
Autodesk.Civil.DatabaseServices.Styles..::..ShapeStyle
System..::..MarshalByRefObject
DisposableWrapper
RXObject
Drawable
DBObject
Autodesk.Civil.DatabaseServices..::..DBObject
Autodesk.Civil.DatabaseServices.Styles..::..StyleBase
Autodesk.Civil.DatabaseServices.Styles..::..SubassemblySubentityStyle
Autodesk.Civil.DatabaseServices.Styles..::..ShapeStyle