Converting Tessellated Lines to Arcs

 
 
 

Fits a curve from a selection of vertices with a feature line, survey figure, parcel, or 3D polyline

Use this command to convert tessellated lines to true arcs, or to add fillets to straight segments. You can specify start and end points or set options for automatic arc generation.

Tessellation occurs when you convert a 2D polyline with arcs to a 3D polyline. It also occurs when you export feature lines with arcs from corridor models.

Grading created from tessellated footprint (left) compared with grading created from arc (right)

Feature line points that define a grade break are inserted as elevation points on the arc when using this command.

There are three ways to select the segments to turn into arcs.

You can specify the command options by editing the FitCurveFeature command settings, or by using the Options keyword when running the Fit Curve command.

To fit a curve

  1. Click Modify tabEdit Geometry panelFit Curve.
  2. Select the feature line or other object.
  3. Do one of the following:
    • Move your mouse over the feature line. Arcs appear where they can be inserted. Click your mouse to insert an arc.
    • Enter Points (P). Then select the start and end point on the feature line for the arc location. This option ignores the minimum number of segments setting.

      If the start and end points span more than one segment but the points do not define an arc, an error message is displayed indicating that an arc cannot be created between the specified points. This error occurs if the segments do not all curve in the same direction or if there is a straight segment that is composed of multiple small segments (which therefore have no deflection angle).

      Note

      If the segments can define an arc but are not within the tolerance, you are prompted with an option to override the tolerance setting and insert the arc.

    • Enter Options (O) to display the Fit Curve dialog box where you can change the tolerance and minimum number of segments settings.

Ribbon

Click Modify tabEdit Geometry panelFit Curve

Menu

Grading menu Edit Feature Line GeometryFit Curve

Command Line

FitCurveFeature

Supported Objects

  • Feature lines
  • Survey figures
  • 3D polylines
  • 2D polylines