Autodesk Infrastructure Map Server 2016 System Requirements

Before installing any Autodesk® product, it is important that you verify that your computer meets, or exceeds, the minimum system requirements for operation.

If your system does not meet the minimum requirements, problems can occur while running the product, and at the operating system level.

For more information about determining the bit count for your operating system, refer to the Microsoft Support site and read http://support.microsoft.com/kb/827218.

Operating Systems



System Requirements (32-bit)

The following tables outline the hardware and software requirements if you're running on a system installed with a 32-bit environment.

Hardware and Software Requirements
Operating System

Server Components: Autodesk® Infrastructure Map Server & Autodesk® Infrastructure Web Server Extension & Autodesk® Infrastructure Application Extension

  • Microsoft Windows Server 2008 Enterprise SP2

Client Components: Autodesk® Infrastructure Administrator & Autodesk® Infrastructure Studio

  • Windows 7 Ultimate SP1
  • Windows 8/8.1
  • Windows 8/8.1 Professional
  • Windows 8/8.1 Enterprise
Browser

Microsoft Internet Explorer 10.0

Microsoft Internet Explorer 11.0

Mozilla Firefox 37.0

Google Chrome 42.0

Apple Safari 5.1

The browsers listed have been tested and verified to run with Autodesk Infrastructure Map Server 2016.

Note: Running newer browser versions may result in unexpected product performance.

Processor Minimum Intel Pentium 4 or AMD Athlon 64 processor
Memory

2 GB RAM (minimum)

4 GB RAM (recommended)

Graphics Card

A graphics adapter supporting a resolution of:

1024 x 768 (1600 x 1050 or higher recommended) with True Color

Hard Disk Server Components (Autodesk® Infrastructure Map Server & Autodesk® Infrastructure Web Server Extension & Autodesk® Infrastructure Application Extension)
  • 12 GB (minimum)

Client Components (Autodesk® Infrastructure Administrator & Autodesk® Infrastructure Studio)

  • 12 GB (minimum)
Pointing Device MS-Mouse compliant
Media Download and Installation from DVD
.NET Framework .NET Framework Version 4.5 SP1
Optional Software for Web Servers

Microsoft Windows Apache HTTP Server 2.4.10

Microsoft IIS 7.0 on Windows 2008 Enterprise SP2

Optional for Software Application Development

Java JDK 6.0 or above

Tomcat Servlet Engine 7.0.56

PHP 5.5.11

FDO Version 4.0.0.0


An instance of Oracle is optional for some products.

Optional: Database
Oracle Database Specifications - Server

Oracle 10g R2 (10.2.0.4.0) Standard Edition, Standard Edition One, or Enterprise Edition

Oracle 11g R2 (11.2.0.4.0) Enterprise Edition

Oracle 12cR1 (12.1.0.1.0) Enterprise Edition

Oracle 10g or 11g Enterprise Edition is required to support jobs and long transactions.

Oracle 11g and Spatial or Oracle 12c and Spatial are required to support 3D.

Microsoft Windows Server 2008 R2 requires Oracle 11g R2

Oracle Database Specifications - Client

Oracle Database 11g Client Release 2 (11.2.0.3.0) Administrator (Not Instant or Run-time)

Oracle Database 12c Client Release 1 (12.1.0.1.0) Administrator (not Instant or Run-time)

Microsoft Windows 7, 8 and 8.1 require an Oracle 11g R2 Client or Oracle 12cR1 Client

During the installation and configuration of your products, you must connect to the database. Make sure your administrator provides the following settings and passwords:


FDO Provider Requirements
FDO Provider Certified with Notes
Microsoft SQL Server

Microsoft SQL Server 2008 SP2 Standard and Enterprise Editions;

Microsoft SQL Server 2008 R2 Standard and Enterprise Editions;

Microsoft SQL Server 2012 Standard and Enterprise Editions;

Microsoft SQL Server 2014 Standard and Enterprise Editions

Oracle 10g Release 2 Oracle Standard, and Enterprise Editions
Oracle 11g Release 2 Oracle Express, Standard, and Enterprise Editions
Oracle 12c Release 1 Standard Edition, Standard Edition 1, and Enterprise Edition
Raster JPG, JPEG, JPE, PNG, BMP, CAL, TGA, TIF, TIFF, SID, ECW
Autodesk SDF 3.0
ESRI ArcSDE ArcSDE 9.3 SP1,ArcSDE 10, ArcSDE 10.1, ArcSDE 10.2 This Provider requires ESRI licensed components to be installed on client system. Required components depend on the type of connection (SDE Service or Direct Connect).
MySQL 5.6 Note: for Linux, libmysqlclient.so.15 is still needed when connecting to a MySQL 5.5 or MySQL5.6 data base.
ODBC The FDO ODBC provider has been tested with corresponding versions of ODBC drivers that are shipped with the relevant supported operating systems version.
OGC WMS WMS 1.3.0
OGC WFS WFS 1.1.0
SQLite SQLite 3.6
PostgreSQL PostgreSQL 9.2+PostGIS 2.0

ODBC Drivers Tested Versions
Microsoft Access Driver (*.mdb, *.accdb) Microsoft Access database engine 2010(English) 14.00.4760.1000
Microsoft Excel Driver (*.xls, *.xlsx, *.xlsm, *.xlsb) Microsoft Access database engine 2010(English) 14.00.4760.1000
MySQL ODBC 5.3 Driver 5.03.04.00
Oracle in OraClient11g_home1 11.02.00.03

Note: Adobe Flash Player is not installed by default. If a version of Flash is not currently installed on your system, a message is displayed requesting that you install it. Flash Player can be installed from the product media or Adobe’s website - www.adobe.com.



Return to Top

System Requirements (64-bit)

The following tables outline the hardware and software requirements if you're running on a system installed with a 64-bit environment.

Hardware and Software Requirements

Operating Systems

Server Components: Autodesk® Infrastructure Map Server & Autodesk® Infrastructure Web Server Extension & Autodesk® Infrastructure Application Extension

  • Microsoft Windows Server 2008 Enterprise Release 2 SP1
  • Microsoft Windows Server 2012 Standard
  • Microsoft Windows Server 2012 R2 Standard

Client Components: Autodesk® Infrastructure Administrator & Autodesk® Infrastructure Studio

  • Windows 7 Ultimate SP1
  • Windows 8/8.1
  • Windows 8/8.1 Professional
  • Windows 8/8.1 Enterprise
Note: Studio is a 32-bit application that can run on 64-bit operating system.
Browser

Microsoft Internet Explorer 10.0

Microsoft Internet Explorer 11.0

Mozilla Firefox 37.0

Google Chrome 42.0

Apple Safari 5.1

The browsers listed have been tested and verified to run with Autodesk Infrastructure Map Server 2016.

Note: Running newer browser versions may result in unexpected product performance.

Processor Minimum Intel Pentium 4 or AMD Athlon 64 processor
Memory

8 GB RAM (minimum)

16 GB RAM (recommended)

Graphics Card

A graphics adapter supporting a resolution of:

1024 x 768 (1600 x 1050 or higher recommended) with True Color

Hard Disk

Server Components (Autodesk® Infrastructure Map Server & Autodesk® Infrastructure Web Server Extension & Autodesk® Infrastructure Application Extension)

  • 12 GB (minimum)

Client Components (Autodesk® Infrastructure Administrator & Autodesk® Infrastructure Studio)

  • 12 GB (minimum)
Pointing Device MS-Mouse compliant
Media Download and Installation from DVD
.NET Framework .NET Framework Version 4.5 SP1
Optional Software for Web Servers

Apache HTTP Server 2.4.10

Microsoft IIS 7.5 or above on Windows 2008 Enterprise R2 SP1, Windows Server 2012 Standard and Windows Server 2012 R2

Optional for Software Application Development

Java JDK 6.0 or above

Tomcat Servlet Engine 7.0.56

PHP 5.5.11

FDO Version 4.0.0.0


An instance of Oracle is optional for some products.

Optional: Database
Oracle Database Specifications - Server

Oracle 10g R2 (10.2.0.4.0) Standard Edition, Standard Edition One, or Enterprise Edition

Oracle 11g R2 (11.2.0.4.0) Enterprise Edition

Oracle 12cR1 (12.1.0.1.0) Enterprise Edition

Oracle 10g or 11g Enterprise Edition is required to support jobs and long transactions.

Oracle 11g and Spatial or Oracle 12c and Spatial are required to support 3D.

Microsoft Windows Server 2008 R2 requires Oracle 11g R2

Oracle Database Specifications - Client

Oracle Database 11g Client Release 2 (11.2.0.4.0) Administrator (Not Instant or Run-time)

Oracle Database 12c Client Release 1 (12.1.0.1.0) Administrator (not Instant or Run-time)

Microsoft Windows 7, 8 and 8.1 require an Oracle 11g R2 Client or Oracle 12cR1 Client

During the installation and configuration of your products, you must connect to the database. Make sure your administrator provides the following settings and passwords:


FDO Provider Requirements
FDO Provider Certified with Notes
Microsoft SQL Server

Microsoft SQL Server 2008 SP2 Standard and Enterprise Editions;

Microsoft SQL Server 2008 R2 Standard and Enterprise Editions;

Microsoft SQL Server 2012 Standard and Enterprise Editions;

Microsoft SQL Server 2014 Standard and Enterprise Editions

Oracle 10g Release 2 Oracle Standard, and Enterprise Editions
Oracle 11g Release 2 Oracle Express, Standard, and Enterprise Editions
Oracle 12c Release 1 Standard Edition, Standard Edition 1, and Enterprise Edition
Raster JPG, JPEG, JPE, PNG, BMP, CAL, TGA, TIF, TIFF, SID, ECW
Autodesk SDF 3.0
ESRI ArcSDE ArcSDE 9.3 SP1,ArcSDE 10, ArcSDE 10.1, ArcSDE 10.2 This Provider requires ESRI licensed components to be installed on client system. Required components depend on the type of connection (SDE Service or Direct Connect).
MySQL 5.6
ODBC The FDO ODBC provider has been tested with corresponding versions of ODBC drivers that are shipped with the relevant supported operating systems version.
OGC WMS WMS 1.3.0
OGC WFS WFS 1.1.0
SQLite SQLite 3.6
PostgreSQL PostgreSQL 9.2+PostGIS 2.0

ODBC Drivers Tested Versions
Microsoft Access Driver (*.mdb, *.accdb) Microsoft Access database engine 2010(English) 14.00.4760.1000
Microsoft Excel Driver (*.xls, *.xlsx, *.xlsm, *.xlsb) Microsoft Access database engine 2010(English) 14.00.4760.1000
MySQL ODBC 5.3 Driver 5.03.04.00
Oracle in OraClient11g_home1 11.02.00.04

Note: Adobe Flash Player is not installed by default. If a version of Flash is not currently installed on your system, a message is displayed requesting that you install it. Flash Player can be installed from the product media or Adobe’s website - www.adobe.com.

Return to Top

System Requirements (Linux)

The following table outlines the hardware and software system requirements for systems running a Linux environment.


Hardware and Software Requirements for the Infrastructure Map Server (Linux)
Hardware / Software Requirement Notes
Operating System Red Hat Enterprise Linux ES version 5.5
Browser

Microsoft Internet Explorer 10.0

Microsoft Internet Explorer 9.0

Mozilla Firefox 37.0

Google Chrome 42.0

Apple Safari 5.1

The browsers listed have been tested and verified to run with Autodesk Infrastructure Map Server 2016.

Note: Running newer browser versions may result in unexpected product performance.

Processor Intel Pentium 3 or higher, running at 450 Mhz (minimum).
Memory 2 GB RAM (minimum)
Graphics Card

A graphics adapter supporting a resolution of:

1024 x 768 (1600 x 1050 or higher recommended) with True Color

Hard Disk Server Components (Autodesk® Infrastructure Map Server & Autodesk® Infrastructure Web Server Extension)

12 GB

Pointing Device MS-Mouse compliant
Media Download and Installation from DVD
Network Card Compatible with existing Ethernet network infrastructure The Network License Manager supports multiple network interface cards, but at least one must be an Ethernet card.
Communication Protocol TCP/IP The Network License Manager uses TCP packet types.
Optional Software: Web Servers Apache HTTP Server 2.4.10
Optional Software: Application Development

Java JDK 6.0 or above

Tomcat Servlet Engine 7.0.56

PHP 5.5.11

FDO Version 4.0.0.0

FlexLM 11.7.0.0

Return to Top

Copyright© 2015 Autodesk, Inc.