Overview of Workspace Customization
 
 
 

Customization options for workspaces include creating a workspace using the Customize User Interface (CUI) Editor, changing the properties of a workspace, and displaying a toolbar in all workspaces.

Create or Modify a Workspace Outside the Customize User Interface Editor

The easiest way to create or modify user interface elements in a workspace is by customizing them in the application window. From the application window, you can control the display and appearance of several of the most commonly used user interface elements.

Once you customize the workspace, you can save the changes to an existing or new workspace using the WSSAVE command. Once saved, you can access the workspace any time you need to draw within that workspace environment. For more information about customizing workspaces without the Customize User Interface Editor, see Control User Interface Elements Outside the CUI Editor.

Create or Modify a Workspace Using the Customize User Interface Editor

In the Customize User Interface (CUI) Editor, you can create or modify workspaces with precise properties associated with the application and drawing windows, and user interface elements (Quick Access toolbar, toolbars, menus, ribbon tabs, and palettes).

You customize a workspace by selecting a workspace from the Workspaces node in the Customizations In pane. The Workspace Contents and Properties panes are displayed. To modify a workspace, you click the Customize Workspace button in the Workspace Contents pane.

For more information about customizing workspaces with the Customize User Interface Editor, see Control User Interface Elements in the CUI Editor.

After you click Customize Workspace in the Workspace Contents pane, the Customizations In <file name> pane lists the user interface elements that can be added to the workspace that is currently being modified. Check boxes are displayed next to each user interface element in the loaded CUIx files. You use the check boxes to add or remove user interface elements from a workspace.

Change the Properties of a Workspace

In the Customize User Interface (CUI) Editor, you can define workspace properties, such as the workspace name, description, whether the Model or layout tab is displayed or not, and so on. The following table shows the AutoCAD Classic workspace properties as they appear in the Properties pane.

Properties for the AutoCAD Classic Workspace

Properties Pane Item

Description

Example

Name

String displayed in the drop-down box on the Workspaces toolbar, at the command prompt for the WORKSPACE command, under the Workspaces menu item in the Tools menu, and in the CUI Editor.

AutoCAD Classic

Description

Text that describes the workspace; does not appear in the user interface.

 

Start On

Determines if the Model tab, last active layout tab, or the current active tab in the drawing is displayed when the workspace is restored or set current.

Model

Menu bars

Determines if the menu bar is displayed or not when the workspace is restored or set current.

On

Status bars

Determines if the status bars for the drawing window or application are displayed or not when the workspace is restored or set current. The available options are Application Only, All Off, All On, or Drawing Status Bar Only.

Application only

Model/Layout tabs

Determines if the Model/layout tabs are visible or not in the drawing window when the workspace is restored or set current.

On

Screen menus

Determines if the Screen menu is visible or not when the workspace is restored or set current.

Off

Scroll bars

Determines if the scroll bars are visible or not when the workspace is restored or set current.

On

Import a Workspace to a Main CUIx File

You can import a workspace to the main CUIx file using the Transfer tab of the Customize User Interface (CUI) Editor. Workspaces in partially loaded CUIx files must be transferred to the main CUIx file if you want to set that workspace current.

Set the Default Workspace

Workspaces in a CUIx file can be marked as default. This identifies which workspace in the CUIx file should be restored when the CUIx file is loaded into the program the first time, or after the CUIx file has been loaded with the CUILOAD command.

Set a Workspace Current

Once a workspace is created or modified, it must be set current before the workspace can be used to control the current display of the user interface. You set workspaces current through the user interface or the Customize User Interface (CUI) Editor. From the user interface, you can set a workspace current with the Workspaces toolbar, Workspace Switching button on the status bar, Tools menu on the menu bar, and the WORKSPACE command.

You can also use the /w command line switch to set a workspace current when you double-click the desktop shortcut to start AutoCAD. For more information about command line switches, see Customize Startup in the User’s Guide.

Show Me: Create a Workspace
See Also
To create a workspace using the CUI Editor
To save or create a workspace from the user interface
To change the properties of a workspace
To duplicate a workspace
To set a workspace current from the user interface
To set a workspace current from the CUI Editor
To restore the “classic” workspace
To set a workspace as default
NoteIn the Network Deployment Wizard, the main and enterprise CUIx files can be specified. If the main CUIx file has a default workspace set, the default workspace will be set as the current workspace when the file is loaded into AutoCAD the first time.
To restore a workspace with a command line switch
To import a workspace to a main CUIx file
Commands
System Variables
Utilities
Command Modifiers