Data View Window
 
 
 

Provides the primary interface for viewing and editing external database tables from within the program. You can open this dialog box using the following methods:

 Toolbar: dbConnect Manager buttons Select a link template, a label template, or a table from the dbConnect Manager and choose View Table or Edit Table. 
 Menu: dbConnect View Data View External Table, Edit External Table, View Linked Table, or Edit Linked Table. (Displays a dialog box in which you can select a database table to open.)
 Shortcut menu: Right-click a link template or a database table in the dbConnect Manager and choose View Table or Edit Table.
 Pointing device: Double-click a database table or a link template in the dbConnect Manager. Double-clicking a link template that has no links created in the drawing it's associated with opens the Link Template dialog box. The database table is opened in either Edit mode or Read-only mode, depending on the dbConnect Settings specified on the System tab of the Options dialog box. See OPTIONS.

The Data View window displays records from the selected database table. The Data View contains a set of buttons, a grid window for viewing and editing records, and a set of navigation controls for navigating through the record set. After you open the Data View window, the Data View menu is added to the menu bar. You can specify whether the Data View window can be docked or anchored by right-clicking the title bar and choosing an option from the shortcut menu.

The appearance of the Data View window is governed by your computer's system settings, and it can be changed in the Windows Control Panel. Text in the cells is displayed using the system window text color. If the database table is opened in Read-only mode, the cell background is shown using the system 3D objects button shade color (light gray by default). If it is opened in Edit mode, the cell background is shown using the system window color (white by default). When a cell is selected, it is shown using the system- selected items background and text colors.

The Data View window has the following buttons:

Data View Buttons

Create links and display linked records and graphical objects.

Link

Links the currently selected database table row or rows to one or more graphical objects. The link and, if desired, the label from the currently selected link and label templates are created in the Data View window. To change the current link creation setting, choose the Link and Label Settings button. Three distinct link methods are available:

Link

Creates a link to one or more graphical objects without creating a corresponding label. If the current drawing has a selection set already established, a link is created for each object in the selection set. If the current drawing does not have a current selection set, you are prompted to select objects to link to.

Create Freestanding Label

Creates a freestanding label that isn't associated with a graphical object. You are prompted to specify an insertion point for the label.

Create Attached Label

Creates a link to one or more graphical objects and creates a corresponding label. If the current drawing has a selection set already established, a link is created for all objects in the selection set. If the current drawing does not have a current selection set, you are prompted to select objects to link to.

View Linked Objects in Drawing

Selects graphical objects in the current drawing that are linked to the currently selected Data View row or rows.

View Linked Records in Table

Selects records in the Data View window that are linked to the current selection set of graphical objects.

AutoView Linked Objects in Drawing

Displays linked objects automatically in the current drawing as you select rows from the database table.

AutoView Linked Records in Table

Displays linked records automatically in the Data View window as you select graphical objects in the current drawing.

Print Data View

Prints the contents of the Data View window to the current Microsoft® Windows® system printer.

Data View and Query Options

Opens the Data View and Query Options dialog box, in which you can specify a number of settings that affect the interaction and display of linked objects in the Data View window and the current drawing.

Query, Return to Query, and Return to Link Select

Opens either the New Query dialog box, the Query Editor, or the Link Select dialog box, depending on the method used to open the Data View window. If the Data View window was opened to view or edit a database table, this button's tooltip is Query, and choosing it opens the New Query dialog box. If the Data View window was opened to return the results of a query, this button's tooltip is Return to Query, and choosing it returns you to the Query Editor. If the Data View window was opened to return the results of a Link Select operation, this button's tooltip is Return to Link Select, and choosing it returns you to the Link Select dialog box.

Link Template List

Creates a new link template, or specifies a link template from those that are defined for the open table. The selected link template is applied when you create new links in the current drawing. To create a new link template, select the New Link Template option from the Link Template list, and then choose the Link button flyout.

Label Template List

Creates a new label template, or specifies a label template from those that are defined for the currently selected table. The selected label template is applied when you create new labels in the current drawing. To create a new label template, select the New Label Template option from the Label Template list and choose either the Create Freestanding Label or the Create Attached Label button flyout. If there is no link template defined for the selected database table in the current drawing, the New Link Template dialog box is displayed.

Data View Grid Window

Displays a subset of the records from a database table. You can select records by clicking the following elements:

Column Shortcut Menu

Displays the following options when you right-click one or more selected column headers.

Sort

Opens the Sort dialog box, in which you can select a combination of up to five columns to use in specifying a sort order for the Data View.

A small triangle in the column header indicates that the data is sorted by that column.

Hide

Removes all selected columns from the Data View display.

Unhide All

Restores all hidden columns to the Data View display. Available only if you have hidden one or more columns.

Freeze

Freezes all selected columns so that they do not scroll when you use the horizontal scroll bar. Available only if the selected columns are contiguous.

Unfreeze All

Unfreezes all frozen columns so that they scroll when you use the horizontal scroll bar. Available only if you have frozen one or more columns.

Align

Aligns the current column. Standard right-aligns numeric fields and left-aligns all others, Left left-aligns the column cells, Center center-aligns the cells, and Right right-aligns the cells.

Find

Opens the Find dialog box, which you can use to search for a specific value. Find is limited to the values stored in the currently selected column.

Replace

Opens the Replace dialog box, which you can use to search for a specific value to overwrite with a replacement value that you specify. Replace is limited to the values stored in the currently selected column. Available only for database tables that are opened in Edit mode.

Cell Shortcut Menu

Displays the following options when you right-click the selected cell.

View Linked Objects

Indicates graphical objects in the current drawing that are linked to the selected database record.

Link

Links the current row to a graphical object. The link and, if desired, the label from the currently selected link and label templates are created in the Data View. You can specify whether a link, a freestanding label, or an attached label is created by changing the settings from the Link and Label Settings cell shortcut menu option.

Link and Label Settings

Lists the currently selected link creation mode. You can specify whether a link, a freestanding label, or an attached label is created when the Link shortcut menu option is chosen.

Find

Opens the Find dialog box, which you can use to search for a specific value. The Find shortcut menu option limits its search to records contained in the same column as the currently selected cell.

Replace

Opens the Replace dialog box, which you can use to search for a specific value to overwrite with a replacement value that you specify. Replace limits its search to records contained in the same column as the currently selected cell. Available only for database tables that are opened in Edit mode.

Edit

Enables you to change the value of the currently selected cell. Available only for database tables that are opened in Edit mode.

Cut

Clears the current cell and copies its value to the Clipboard. Available only for database tables that are opened in Edit mode.

Copy

Copies the value from the current cell to the Clipboard.

Paste

Inserts the value currently stored on the Clipboard into the selected cell. Available only for database tables that are opened in Edit mode.

Clear

Deletes the value in the current cell. Available only for database tables that are opened in Edit mode.

Record Shortcut Menu

Displays the following options when you right-click one or more selected record headers.

View Linked Objects

Indicates graphical objects in the current drawing that are linked to the selected database records.

Link

Links the selected row or rows to one or more graphical objects. The link and, if desired, the label from the currently selected link and label templates are created in the Data View window. You can specify whether a link, a freestanding label, or an attached label is created by choosing the Link and Label Settings shortcut menu option.

Link and Label Settings

Lists the currently selected link creation mode. You can specify whether a link, a freestanding label, or an attached label is created when the Link shortcut menu option is chosen.

Copy

Copies the selected records to the Clipboard.

Delete Record

Deletes the selected records. Available only for database tables that are opened in Edit mode.

Add New Record

Adds a new record with blank field values to the end of the record set. Available only for database tables that are opened in Edit mode.

Clear All Marks

Clears record selection marks from the selected records in the Data View window.

Grid Header Shortcut Menu

Displays the following options when you right-click the grid header.

Commit

Saves all changes made in the Data View window to the source database table and closes the Data View window. Available only when a database table is open in Edit mode and you have edited its values.

Restore

Undoes any changes made to a database table during an editing session and closes the Data View window. Available only when a database table is open in Edit mode and you have edited its values.

Unhide All Columns

Restores any hidden columns to the Data View window display.

Unfreeze All Columns

Unfreezes any frozen columns so that they scroll when you use the horizontal scroll bar.

Clear All Marks

Clears all record selection marks from the Data View window.

Print Preview

Opens the Print Preview window in the Data View window, in which you can preview your printed report.

Print

Prints the contents of the Data View window to the current Windows system printer.

Format

Opens the Format dialog box, in which you can control how data is displayed in the Data View window.

Navigation Controls

Cycle quickly through the records in the Data View window. The following controls are available:

First Button

Selects the first record.

Previous Button

Selects the previous record.

Next Button

Selects the next record.

Last Button

Selects the last record.

Data View Print Preview Window

Loads into the Data View window a preview image of how the current table appears when you print it. When the Data View window is in Preview mode, none of the primary Data View buttons is available and the navigation buttons are removed from the bottom of the window. You can open this dialog box using the following methods:

 Menu: Data View Print Preview
 Shortcut menu: Right-click the grid header in the Data View window and choose Print Preview.

Print

Opens the default system Print dialog box.

Next Page

Presents a preview image of the next page of the database table.

Prev Page

Restores the preview image of the previous page of the database table.

Two Page

Toggles the display between one and two preview pages. If you choose Two Page, the name of the button changes to One Page and vice versa.

Zoom In

Magnifies the preview page so that you can view the details more closely.

Zoom Out

Shrinks the preview page to display a larger region of the database table.

Close

Closes the Data View Print Preview window and restores the default Data View window display.