Select From Scene

 
 
 

Command entry:Main Toolbar (Select by Name)
Command entry:Standard menu: Edit menu Select By Name
Command entry:Enhanced menu: Edit menu Select Select By Name
Command entry:Keyboard H

This dialog, named Select From Scene or Select Objects in most contexts, lets you select or designate objects by choosing them from a list of all objects currently in the scene.

Select From Scene is a modal, read-only version of the Scene Explorer; you can’t use it to change object properties such as name and color. Other differences between Select From Scene and Scene Explorer include:

NoteThe Select From Scene dialog name and functionality are context dependent. When a transform such as Select And Move is active, the dialog lets you choose from all objects in the scene. But when certain modes are active, the choices in the dialog are more limited. For example, when Select and Link is active, the dialog is entitled Select Parent, and shows linkable objects but not the child object already selected. Similarly, if Group Attach is active, the dialog is named Attach To Group and lists groups but not solitary objects.
TipIf you prefer to use the legacy Select Objects dialog instead of Select From Scene, it’s available as an option. Open the CurrentDefaults.ini file (see Market-Specific Defaults), find the [Scene Explorer] section, and change the SelectByNameUsesSceneExplorer setting. If set to 1, then Select By Name and related commands use the Select From Scene dialog. If set to 0, then Select By Name and related commands use the legacy Select Objects dialog. The latter’s functionality is essentially the same as the Selection Floater, except that it’s modal, not modeless.

Procedures

To select objects by name:

  1. Do one of the following:
    • On the main toolbar, click (Select By Name).
    • Choose Edit menu Select By Name.
    • Press H.

      The Select From Scene dialog opens. By default, it lists all objects in the scene, displaying any hierarchies as collapsible branches. Currently selected objects are highlighted in the list.

  2. Choose one or more objects in the list by doing one of the following:
    • To select a single object and close the dialog, double-click the object name.
    • Drag, or click and then Shift+click to select a contiguous range of objects and Ctrl+click to select noncontiguous objects.
    • In the field above the list, type a search phrase. As you type, all matches for the current phrase are highlighted in the list. To highlight only objects whose case matches the search phrase exactly, turn on Find Case Sensitive (from the Select menu) .
    NoteIn some cases, such as when linking objects, you can select only one object.
  3. Click Select.

    The selection is made as the dialog closes.

To highlight a single item from among multiple highlighted items:

Clicking one list item among several highlighted items does not unhighlight the rest. When several items are highlighted, but you want to highlight only one of them, do either of the following:

Creative Commons License Except where otherwise noted, this work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License