Menus Panel

 
 
 
Command entry:Customize menu Customize User Interface Menus tab

The Menus panel lets you customize the menus in 3ds Max. You can edit existing menus or create your own. You can customize menu labels, functionality, and layout.

When you load, save, or reset customized menu settings, 3ds Max uses the MNUX file format. (Prior to 3ds Max 2013, menu files had a file name extension of MNU. This format is now superseded.)

Procedures

To create a menu:

  1. Choose Customize menu Customize User Interface Menus tab.
  2. Click New.

    The New Menu dialog appears.

  3. Enter the name of the menu, and click OK.

    The new menu appears in the menu list.

To add a command to a menu:

  1. Choose Customize menu Customize User Interface Menus tab.
  2. Choose the menu you want to edit from the drop-down list.

    If you want to change the name of the menu, click Rename, and enter a new name in the Rename Menu dialog.

  3. Choose the appropriate Group and Category from the respective drop-down lists.
  4. Choose a command from the action list and drag it into the Menu window.

    Use the same procedure to add menus and separators to your menu.

To delete a menu:

  1. Choose Customize menu Customize User Interface Menus tab
  2. Choose the menu you want to delete from the drop-down list.
  3. Click Delete.

To remove a command from a menu:

  1. Choose Customize menu Customize User Interface Menus tab.
  2. Choose the menu you want to edit from the drop-down list.
  3. Choose the command you want to remove.
  4. Press Delete.

    Use the same procedure to remove menus and separators from your menus.

To move a command in a menu:

Interface

Group drop-down list
Lets you select the context you want to customize, such as: Main UI, Track View, Material Editor, and so on.
Category drop-down list
Lets you choose among categories of user interface actions for the chosen context.
Action list
Displays all the available actions for the chosen group and category. To add an action to a specific menu, select it and drag it to the menu window on the right side of this dialog. Right-click an action in this window to edit the macro script that defines this action (if there is one).
Separator list
Displays a separator line that can be used to separate groups of menu items. To add a separator to a specific menu, select it and drag it to the menu window on the right side of this dialog.
Menus list
Displays the names of all menus. To add a menu to another menu (shown in the Menu List), select and drag it to the menu window on the right side of this dialog. Right-click a menu in this window to delete the menu, rename it, or create a new, empty menu.
[menus drop-down list]
Displays the default menus as well as any new ones you create or load.
New
Displays the New Menu dialog. Enter the name of the menu you want to create and click OK. The new menu appears in the menu window on the left side of the dialog as well as in the Menu List.
Delete
Deletes the item displayed in the menu list window.
Rename
Displays the Edit Menu Item Name dialog. Select a command in the menu list window and click Rename. This dialog lets you specify a custom name to be displayed in the menu. If you precede a letter in the custom name with the “&” (ampersand) character, that letter is used as a menu accelerator.
[menu window]
Displays the menu options for the menu currently chosen in the menus drop-down list. To add menus and commands (actions), simply select and drag the options from the Action and Menus lists to this window.

There are several actions available when you right-click any item in the menu window:

  • Delete Menu ItemRemoves the highlighted action, separator, or menu from the menu.
  • Edit Menu Item NameOpens the Edit Menu Item Name dialog. The Customize Name checkbox must be on to edit the name. Enter the desired name in the name text field and press OK. The item name is changed in the menu, but not in the menu window. If you precede a letter in the custom name with the “&” (ampersand) character, that letter is used as a menu accelerator.
  • Flatten Sub-MenuDisplays contents of the highlighted submenu at the top level of the menu. If you choose this item, the menu name is followed by the string: "[FLAT]".
  • Edit MacroScriptOpens the script for the highlighted action in a MAXScript editor window.
Load
Displays the Load Menu File dialog. Allows you to load custom menu (MNUX) files into the 3ds Max interface.
Save
Displays the Save Menu File As dialog. Allows you to save changes to the menus in an MNUX file.
Note Quad menu customizations also use MNUX files.
Reset
Restores the default setup (defaultui.mnux).