Menüleiste der Partikelansicht

 
 
 
Befehlseingabe: Wählen Sie das Symbol einer Partikelflussquelle aus Modifikatorgruppe Rollout "Einrichten" Auf "Partikelansicht" klicken (oder drücken Sie die Taste 6).
Befehlseingabe: Erstellungsgruppe (Geometrie) Partikelsysteme Rollout "Objekttyp" Auf "PF-Quelle" klicken. Rollout "Einrichten" Auf "Partikelansicht" (oder drücken Sie die Taste 6) klicken.

Über die Menüleiste stehen einige wichtige Funktionen für die Partikelansicht zur Verfügung.

Vorgehensweise

So rendern Sie ausschließlich Partikel in bestimmten Ereignissen:

  1. Markieren Sie in der Partikelansicht die Ereignisse mit den Partikeln, die gerendert werden sollen.
  2. Wählen Sie im Menü "Auswählen" Befehl "Auswahl dem Ansichtsfenster zuweisen" aus.
  3. Rendern Sie mit ausgewählter Option Zu rendernder Bereich.

So übernehmen Sie ein Partikelfluss-System in eine andere Szene:

  1. Markieren Sie in der Partikelansicht die Ereignisse mit den Partikeln, die Sie in einer anderen Szene zusammenführen möchten. Wenn Sie beispielsweise nur einen bestimmten Fluss zuweisen möchten, markieren Sie dessen globales Ereignis, und wählen Sie dann im Menü "Auswählen" "Nachfolgende auswählen" aus.
  2. Wählen Sie im Menü "Auswählen" "Auswahl speichern" aus, und geben Sie über das Dialogfeld die zu speichernde Datei an.
    AnmerkungAlle Szenenobjekte, von denen der Partikelfluss abhängig ist, werden ebenfalls gespeichert. Wenn beispielsweise ein Operator des Typs Formexemplar in einem markierten Ereignis auf ein bestimmtes Objekt verweist, dann wird dieses Objekt zusammen mit den angegebenen Ereignissen gespeichert.
  3. Öffnen oder erstellen Sie die Szene, mit der das gespeicherte Partikelfluss-System kombiniert werden soll, und führen Sie dann die Datei aus Schritt 2 mit Zusammenführen zusammen.

Benutzeroberfläche

Menü "Bearbeiten"

Die ersten drei Befehle in diesem Menü verfügen über Untermenüs, in denen alle Aktionen aufgeführt sind. Wählen Sie den gewünschten Befehl und anschließend eine Aktion aus dem dazugehörigen Untermenü.

AnmerkungDie Befehle "Rückgängig" und "Wiederherstellen" können über das Menü "Bearbeiten" von 3ds Max aufgerufen werden und sind in der Standardeinstellung mit folgenden Tastaturbefehlen belegt: Strg+Z bzw. Strg+Y.
Neu

Fügt ein neues Ereignis mit der gewählten Aktion zur Ereignisanzeige hinzu.

Einfügen vor

Fügt das gewählte Element vor jeder markierten Aktion ein. Dieser Befehl ist nur verfügbar, wenn eine oder mehrere Aktionen markiert sind.

Anhängen an

Fügt das gewählte Element am Ende jedes markierten Ereignisses ein. Dieser Befehl ist nur verfügbar, wenn ein oder mehrere Ereignisse markiert sind.

Alle aktivieren

Aktiviert alle Aktionen und Ereignisse.

Alle deaktivieren

Deaktiviert alle Aktionen und Ereignisse.

Ausgewählte aktivieren

Aktiviert alle markierten Aktionen oder Ereignisse, die bislang deaktiviert waren. Dieser Befehl ist nur verfügbar, wenn ein oder mehrere markierte Elemente deaktiviert sind.

Ausgewählte deaktivieren

Deaktiviert alle markierten Aktionen oder Ereignisse, die bislang aktiviert waren. Dieser Befehl ist nur verfügbar, wenn ein oder mehrere markierte Elemente aktiviert sind.

Eindeutig zuweisen

Wandelt das Exemplar einer Aktion in eine Kopie um, die für das dazugehörige Ereignis eindeutig ist. Dieser Befehl ist nur verfügbar, wenn ein oder mehrere Exemplare von Aktionen markiert sind.

Auswahl vernetzen

Vernetzt einen oder mehrere markierte Tests mit einem markierten Ereignis bzw. ein oder mehrere markierte globale Ereignisse mit einem markierten Erzeugungsereignis. Dieser Befehl ist nur verfügbar, wenn ein oder mehrere Tests und ein einzelnes Ereignis markiert sind oder wenn ein oder mehrere globale Ereignisse und ein einzelnes Erzeugungsereignis markiert sind.

Kopieren

Kopiert alle markierten Ereignisse, Aktionen und Vernetzungen in die Zwischenablage. Tastaturbefehl: Strg+C

Einfügen

Fügt den Inhalt der Zwischenablage in die Ereignisanzeige ein. Tastaturbefehl: Strg+V

Zu welchem Ergebnis das Kopieren und Einfügen mehrerer Elemente führt, hängt von den kopierten Elementen ab:

  • Wenn Sie mehrere Aktionen kopieren, werden diese beim Einfügen in ein einziges neues Ereignis eingefügt, selbst wenn sie ursprünglich aus unterschiedlichen Ereignissen stammen.
  • Wenn Sie mehrere Ereignisse oder Vernetzungen kopieren, werden diese originalgetreu wieder eingefügt.
  • Wenn Sie eine Kombination von Aktionen und Ereignissen kopieren, wird beim Einfügen für jede Gruppe von Aktionen, die aus einem einzelnen Ereignis stammen, ein neues Ereignis erstellt. Wenn Sie zum Beispiel Ereignis A, einige Aktionen aus Ereignis B und einige Aktionen aus Ereignis C markieren, würden durch Kopieren und Einfügen drei Ereignisse hinzugefügt: eine Kopie von Ereignis A, ein zweites Ereignis mit den Aktionen aus Ereignis B sowie ein drittes Ereignis mit den Aktionen aus Ereignis C.
Exemplar einfügen

Fügt den Inhalt der Zwischenablage in die Ereignisanzeige ein, wobei Exemplare aller eingefügten Aktionen und ihrer Originale erstellt werden.

Welches Ergebnis das Einfügen mehrerer kopierter Elemente hat, ist unter dem Befehl "Einfügen" weiter oben beschrieben.

Löschen

Löscht alle markierten Elemente. Tastaturbefehl: Entf

Beim Löschen eines Ereignisses werden auch die dazugehörigen Aktionen gelöscht.

Umbenennen

Ermöglicht die Eingabe eines neuen Namens für ein markiertes Element in der Ereignisanzeige. Dieser Befehl ist nur verfügbar, wenn eine Aktion oder ein Test markiert ist.

Menü "Auswählen"

Als Vorgabe ist das Hilfsmittel "Auswählen" aktiv, wenn die Partikelansicht geöffnet ist. Dies können Sie daran erkennen, dass der Mauszeiger die Form eines Pfeils hat. Mit diesem Hilfsmittel können Sie Ereignisse, Aktionen, Hilfsmittel und Vernetzungen markieren, verschieben und kopieren. Sie können die Befehle im Menü "Auswählen" auch dazu verwenden, alle Elemente, keine Elemente oder Elemente nach Kategorie zu markieren.

AnmerkungWenn Sie eine Szene mit einer der Optionen aus dem Menü "Auswählen" rendern, werden in 3ds Max nur die Ereignisse gerendert, die in den Ansichtsfenstern ausgewählt sind. Mit den letzten drei Befehlen in diesem Menü können Sie die Auswahl von Ereignissen und Flüssen zwischen der Partikelansicht und den Ansichtsfenstern verwalten und koordinieren. Das gilt auch für die Verwendung von Menü "Ansichten" Befehl "Auswahl schattieren".
Auswahl-Hilfsmittel

Aktiviert das Hilfsmittel "Auswählen". Mit diesem Befehl können Sie erneut das Hilfsmittel "Auswählen" aktivieren, nachdem Sie in der Ereignisanzeige die interaktiven Hilfsmittel für das Panen und Zoomen verwendet haben. Alternativ können Sie auch einfach mit der rechten Maustaste auf eine beliebige Stelle der Ereignisanzeige klicken, um das Hilfsmittel "Auswählen" zu aktivieren.

Alle auswählen

Markiert alle Elemente in der Ereignisanzeige.

Nichts auswählen

Hebt die Markierung aller Elemente in der Ereignisanzeige auf. Alternativ können Sie auch in einen leeren Bereich der Ereignisanzeige klicken.

Aktionen auswählen

Markiert alle Operatoren und Tests in der Ereignisanzeige.

Operatoren auswählen

Markiert alle Operatoren in der Ereignisanzeige.

Tests auswählen

Markiert alle Tests in der Ereignisanzeige.

Ereignisse auswählen

Markiert alle Ereignisse in der Ereignisanzeige.

Vernetzungen auswählen

Markiert alle Vernetzungen in der Ereignisanzeige.

Nachfolgende auswählen

Markiert alle Ereignisse, die auf die derzeit markierten Ereignisse folgen. Dieser Befehl ist nur verfügbar, wenn ein oder mehrere Ereignisse markiert sind.

Auswahl speichern

Speichert nur die markierten Elemente in der Ereignisanzeige in einer MAX-Datei. Sie können diese Datei anschließend öffnen oder sie mit einer vorhandenen Szene kombinieren, indem Sie im Menü "Anwendung" "Importieren" Befehl "Zusammenführen" wählen.

Anmerkung"Partikelansicht" Befehl "Auswahl speichern" speichert alle in der Partikelansicht und in der Szene ausgewählten Elemente. Wenn also in der Szene ein Symbol für eine Partikelflussquelle ausgewählt ist, speichert dieser Befehl deren globales Ereignis sowie alle zugehörigen Erzeugungsereignisse. Wenn Sie nur Teile eines Partikelfluss-Systems speichern möchten, heben Sie zunächst die Auswahl aller Bestandteile der Szene auf.

Entsprechend wird, wenn eine Aktion ein Objekt referenziert (zum Beispiel wenn ein Operator des Typs "Formexemplar" ein Geometrieobjekt verwendet) und die Aktion oder das ihr übergeordnete Ereignis markiert ist, bei Verwendung des Befehls "Auswahl speichern" auch das Referenzobjekt gespeichert.

Auswahl aus Ansichtsfenster abrufen

Markiert globale Ereignisse, deren Quellensymbole in den Ansichtsfenstern ausgewählt sind.

Auswahl dem Ansichtsfenster zuweisen

Überträgt die ausgewählten Ereignisse in die Ansichtsfenster. Verwenden Sie diesen Befehl, wenn Sie ausschließlich Partikel in bestimmten Ereignissen rendern möchten. Markieren Sie hierfür zunächst die Ereignisse in der Partikelansicht, die Sie rendern möchten. Wählen Sie anschließend diesen Befehl, und rendern Sie zuletzt die Ereignisse mit ausgewählter Option Zu rendernder Bereich.

Ausgewählte Quellen/Ereignisse im Ansichtsfenster synchronisieren

Wählt alle Ereignisse der in den Ansichtsfenstern ausgewählten Quellensymbole aus. Mit dem Befehl "Auswahl aus Ansichtsfenster abrufen" können Sie diese Auswahl dann in die Partikelansicht übernehmen.

Mit dieser Funktion können Sie einen bestimmten Partikelfluss rendern, indem Sie eine der Optionen unter "Rendern" "Auswahloptionen" verwenden.

Menü "Anzeige"

Die ersten fünf Befehle in diesem Menü stehen im Bereich der Anzeigehilfsmittel am rechten unteren Rand des Dialogfelds "Partikelansicht" auch als Symbole zur Verfügung. Die Symbole der einzelnen Anzeigebefehle sind unten abgebildet.

Pan-Hilfsmittel

Ziehen Sie die Maus in der Ereignisanzeige, um den Ansichtsausschnitt zu verschieben. Der Mauszeiger nimmt die Form einer Hand an. Sie können die Ansicht auch panen, indem Sie die Maus bei gedrückter mittlerer Maustaste oder gedrücktem Rad ziehen.

Klicken Sie mit der rechten Maustaste in die Ereignisanzeige, oder wählen Sie diesen Befehl erneut, um diesen Modus wieder zu verlassen.

Zoom-Hilfsmittel

Ziehen Sie die Maus in der Ereignisanzeige, um die Ansicht zu zoomen. Der Mauszeiger nimmt die Form einer Lupe an. Ziehen Sie die Maus nach oben, um die Ansicht zu vergrößern, bzw. nach unten, um die Ansicht zu verkleinern.

Klicken Sie mit der rechten Maustaste in die Ereignisanzeige, oder wählen Sie diesen Befehl erneut, um diesen Modus wieder zu verlassen.

Bereichszoom-Hilfsmittel

Ziehen Sie die Maus in der Ereignisanzeige, um ein Zoom-Rechteck festzulegen. Der Mauszeiger nimmt die Form einer Lupe innerhalb eines Zoom-Bereichs an. Wenn Sie die Maustaste wieder loslassen, wird in der Ereignisanzeige nur noch der definierte Bereich angezeigt.

Klicken Sie mit der rechten Maustaste in die Ereignisanzeige, oder wählen Sie diesen Befehl erneut, um diesen Modus wieder zu verlassen.

Zoom Grenzen

Stellt die Ansicht so ein, dass das gesamte Partikeldiagramm in der Ereignisanzeige zu sehen ist.

Kein Zoom

Stellt den Zoom auf den Standard-Zoomfaktor ein. Diese Einstellung wird beim ersten Öffnen der Partikelansicht ein einer Sitzung verwendet.

Parameter

Aktiviert bzw. deaktiviert die Anzeige des Parameterfensters, das sich auf der rechten Seite des Dialogfelds "Partikelansicht" befindet. Vorgabe = Aktiviert.

Depot

Aktiviert bzw. deaktiviert die Anzeige des Depots, das sich unterhalb der Ereignisanzeige im Dialogfeld "Partikelansicht" befindet. Vorgabe = Aktiviert.

Beschreibung

Aktiviert bzw. deaktiviert das Beschreibungsfenster, das sich rechts neben dem Depot befindet. Vorgabe = Aktiviert.

Im Beschreibungsfenster wird eine kurze Beschreibung der im Depot markierten Aktion angezeigt.

Menü "Optionen"

Dieses Menü enthält eine Reihe von Optionen, die für die Analyse und Fehlerbehebung von Partikelsystemen hilfreich sind.

Vorgabeanzeige

Bestimmt, ob der Operator "Anzeige" lokal oder global auf neue Partikelsysteme und Ereignisse angewendet wird. Vorgabe = Lokal.

  • GlobalWenn Sie ein neues Partikelsystem erstellen, wird ein einzelner Operator "Anzeige" zum globalen Ereignis hinzugefügt. Es wird nicht jedem neuen Ereignis ein Operator "Anzeige" hinzugefügt.
  • LokalDas Partikelfluss-System fügt jedem neuen Ereignis einen Operator "Anzeige" hinzu. Auf diese Weise können Sie Partikel in unterschiedlichen Ereignissen in den Ansichtsfenstern leicht unterscheiden.
Aktionsreihenfolge

Verwenden Sie in globalen und lokalen Ereignissen nicht ähnliche Aktionen. Sie können damit unvorhergesehene Ergebnisse vermeiden. Wenn jedoch im globalen Ereignis und in anderen Ereignissen ähnliche Aktionen definiert sind, wendet das Partikelfluss-System diese in der hier festgelegten Reihenfolge an. In der Regel ist der zuletzt angewendete Effekt im Partikelsystem sichtbar. Vorgabe = Lokale zuerst.

Stellen Sie sich beispielsweise folgende Situation vor: Das globale Ereignis enthält den Operator "Form" mit der Einstellung "Würfel"; die anderen Ereignisse in demselben System enthalten ebenfalls Operatoren des Typs "Form" mit der Einstellung "Tetra" oder "Kugel". Als Vorgabe wendet das Partikelfluss-System bei jedem Integrationsschritt zuletzt den globalen Operator "Form" an und setzt damit alle lokalen Formen außer Kraft, sodass alle Partikel die Form eines Würfels haben. Wenn Sie für die Einstellung "Aktionsreihenfolge" hingegen die Option "Globale zuerst" wählen, werden die lokalen Formen zuletzt angewendet, sodass die Partikel abhängig vom aktuellen Ereignis die Form eines Tetraeders bzw. einer Kugel haben.

  • Globale zuerstBei jedem Integrationsschritt werden zuerst Aktionen im globalen Ereignis und anschließend Aktionen in den anderen (lokalen) Ereignissen angewendet. In der Regel hat dies zur Folge, dass Aktionen in den lokalen Ereignissen vergleichbare Aktionen im globalen Ereignis überschreiben.
  • Lokale zuerstBei jedem Integrationsschritt werden zuerst Aktionen in den lokalen Ereignissen und anschließend Aktionen im globalen Ereignis angewendet. In der Regel hat dies zur Folge, dass Aktionen im globalen Ereignis vergleichbare Aktionen in den lokalen Ereignissen überschreiben.
Aktualisierungstyp

Diese Einstellung legt fest, wie Partikelsystem aktualisiert wird, wenn Sie einen Parameter während der Wiedergabe ändern. Da der Zustand des Partikelsystems an einem bestimmten Frame von den Ereignissen in den vorherigen Frames abhängen kann, ist das Ergebnis der Änderung bei Verwendung der Option "Vollständig" deutlicher zu erkennen. Dies geht jedoch zu Lasten der Geschwindigkeit, da es länger dauert, das gesamte System ab dem ersten Frame neu zu berechnen. Vorgabe = Vollständig.

  • VollständigWenn Sie eine Einstellung während der Wiedergabe ändern, aktualisiert Partikelfluss das gesamte System ab dem ersten Frame.
  • VorwärtsWenn Sie eine Einstellung während der Wiedergabe ändern, aktualisiert Partikelfluss das System ab dem aktuellen Frame.
Aktualisierung verfolgen

Hier finden Sie Optionen für die Statusanzeige des Partikelsystems in der Partikelansicht.

  • PartikelzahlFügt über jedem Ereignis eine Registerkarte hinzu, auf der die Anzahl der Partikel im Ereignis angezeigt wird. Die Partikelzahl des globalen Ereignisses gibt die Gesamtzahl der Partikel im Partikelsystem an.

    Verwenden Sie diese Funktion in Verbindung mit der Möglichkeit, die Anzeige der Partikel in jedem Ereignis separat anzupassen, um den Verlauf der Partikel in dem System zu verfolgen.

  • AktualisierungsfortschrittHebt jede Aktion während der Analyse durch das Partikelfluss-System farbig hervor.

    Obwohl die Hervorhebung sehr schnell erfolgt, kann diese Option den Berechnungsaufwand für das Partikelsystem erheblich vergrößern, sodass bei der Echtzeitwiedergabe unter Umständen eine größere Anzahl an Frames übersprungen wird. Damit dennoch alle Frames angezeigt werden, deaktivieren Sie in diesem Fall unter "Zeitkonfiguration" "Echtzeit".

Dynamische Namen verwenden

Wenn diese Option aktiviert ist, werden hinter den Namen von Aktionen in Ereignissen die wichtigsten Einstellungen dieser Aktionen in Klammern angezeigt. Ist die Option deaktiviert, werden nur die Aktionsnamen angezeigt. Vorgabe = Aktiviert.

Menü "Extras"

Das Menü "Extras" in der Partikelansicht bietet verschiedene Dienstprogramme für den Partikelfluss.

Layer synchronisieren

Synchronisiert die Partikelfluss-Geometrie mit Quellobjekten. Verwenden Sie diese Option, wenn Sie PF-Quellenobjekte auf einen anderen Layer verschoben haben. Die Option "Layer synchronisieren" ändert die Objekt-Layer nicht, sondern synchronisiert die Partikelfluss-Geometrie mit den Quellobjekten, damit eine ordnungsgemäße Funktion gewährleistet ist.

  • MAXScript particleFlowUtility.synchronizeLayers()
Cache-System reparieren

Repariert das Cache-System, wenn dieses die Funktion versagt.

Wenn ein Cache-Operator durch direkte Aktionen oder durch Zusammenführen mit einem anderen Partikelflusssystem in ein anderes Ereignis versetzt wird, kann dessen Funktion aufgrund eines ID-Konflikts gestört sein. Verwenden Sie in derartigen Fällen diese Funktion, um das Cache-System wieder in Betrieb zu setzen.

  • MAXScript particleFlow.repairCacheSystem(bool doReport)
Voreinstellungs-Manager

Öffnet das Dialogfeld "Partikelfluss-Voreinstellungs-Manager" (siehe unten).

  • MAXScriptparticleFlow.presetManager()

Dialogfeld "Partikelfluss-Voreinstellungs-Manager"

Mit dem Voreinstellungs-Manager können Sie eine Szene als Voreinstellung speichern und später über Voreinstellungsfluss in der Partikelansicht abrufen. Vergessen Sie nicht, dass alle Objekte in der Szene als Teil der Voreinstellung gespeichert werden, unabhängig davon, ob Sie zum Partikelfluss gehören. Dadurch wird sichergestellt, dass alle Referenzobjekte für den Partikelfluss in der Voreinstellung enthalten sind.

Geben Sie zum Speichern einer neuen Voreinstellung einen Voreinstellungsnamen und eine Voreinstellungsbeschreibung ein und klicken dann auf "Szene als Voreinstellung speichern".

Voreinstellungsname

Geben Sie einen Namen für die neue Voreinstellung ein.

Voreinstellungsbeschreibung

Geben Sie eine Beschreibung der neuen Voreinstellung ein.

Voreinstellungen

Eine Liste der aktuellen Voreinstellungen im System. Klicken Sie auf eine Voreinstellung, um deren Beschreibung anzuzeigen.

Szene als Voreinstellung speichern

Speichert die aktuelle Szene als Voreinstellung. Die Voreinstellung wird als Dateipaar gespeichert: Voreinstellungsname.txt mit der Beschreibung der Voreinstellung und Voreinstellungsname.max mit Szene selbst. Beide Dateien werden unter "\plugcfg\Particle Flow Presets\" im Installationsordner gespeichert. Da Voreinstellungen als Dateien gespeichert werden, können Sie Voreinstellungen durch Manipulation der Dateien austauschen oder ändern.